답변:
dmg 파일 (OS X El Capitan.app/Contents/SharedSupport/InstallESD.dmg 설치)은 부팅 가능한 이미지가 아닙니다.
부팅 가능한 파일을 만들려면 다음 스크립트를 사용하십시오. 일부 경로 (예 : 마지막 행의 사용자 이름 및 6 번째 행의 OS X El Capitan.app 설치 경로 및 내부 InstallESD.dmg 파일 경로)를 수정해야 할 수도 있습니다.
#!/bin/bash
# Create bootable El Capitan ISO
# Mount the installer image
hdiutil attach "/Applications/Install OS X El Capitan.app/Contents/SharedSupport/InstallESD.dmg" -noverify -nobrowse -mountpoint /Volumes/esd
# Create empty cdr image
hdiutil create -o ElCapitan.cdr -size 8000m -layout SPUD -fs HFS+J
# Mount the cdr image
hdiutil attach ElCapitan.cdr.dmg -noverify -nobrowse -mountpoint /Volumes/iso
# Restore Base System to the cdr image
asr restore -source /Volumes/esd/BaseSystem.dmg -target /Volumes/iso -noprompt -noverify -erase
# Remove Package link and replace with actual files
rm /Volumes/OS\ X\ Base\ System/System/Installation/Packages
# Copy Base System
cp -rp /Volumes/esd/Packages /Volumes/OS\ X\ Base\ System/System/Installation
cp -rp /Volumes/esd/BaseSystem.chunklist /Volumes/OS\ X\ Base\ System/
cp -rp /Volumes/esd/BaseSystem.dmg /Volumes/OS\ X\ Base\ System/
# Unmount the installer image
hdiutil detach /Volumes/esd
# Unmount the cdr image
hdiutil detach /Volumes/OS\ X\ Base\ System
# Convert the cdr to ISO/CD master
hdiutil convert ElCapitan.cdr.dmg -format UDTO -o ElCapitan.iso
# Rename the ISO and move it to the desktop
mv ElCapitan.iso.cdr $HOME/Desktop/ElCapitan.iso
# Clean up temporary file
rm ElCapitan.cdr.dmg
텍스트 편집기의 내용을 새 문서에 일반 텍스트로 붙여넣고 바탕 화면에 Preparing_elcapitan_cdr.sh로 저장하십시오.
터미널을 열고 스크립트를 chmod하고 실행하십시오.
chmod +x ~/Desktop/prepare_elcapitan_cdr.sh
cd ~/Desktop
./prepare_elcapitan_cdr.sh
VM에서 elcap.dmg를 분리하십시오. 설치 프로그램 iso로 최종 ElCapitan.iso를 사용하여 가상 SATA 포트 1에 연결하십시오. ElCapitan.cdr.dmg 파일을 삭제할 수 있습니다.
hdutil convert
다시 실행) 등 일부 문제에 도움이 되었습니다. ) 및 부팅시 검은 색 화면 (RAM이 2Gb에서 증가한 경우 마더 보드 칩셋을 PIIX3으로 변경).
hdiutil: attach failed - No such file or directory
입니다. InstallESD.dmg
Finder에서 터미널로 끌어서 놓기 때문에 경로 가 올바른지 알고 있습니다. 무엇입니까 /Volumes/esd
? 볼륨을 만들어야합니까? 내 라인 :hdiutil attach "/Applications/Install\ macOS\ Sierra.app/Contents/SharedSupport/InstallESD.dmg" -noverify -nobrowse -mountpoint /Volumes/esd
macOS Catalina Version 10.15.4를 실행하는 Mac mini (2018)를 사용 하여이 질문에 대한 klanomoath의 대답을 테스트했습니다. 다음과 같이 변경해야했습니다.
InstallMacOSX.dmg
Apple 웹 사이트에서 다운로드 했습니다 . OS X El Capitan으로 업그레이드하는 방법 . 파일이 내 Downloads
폴더에 저장되었습니다. 다운로드 후 파인더 응용 프로그램으로 파일을 열어야합니다.klanomoath의 답변에서 첫 번째 명령은 다음과 같습니다.
# Create bootable El Capitan ISO
# Mount the installer image
hdiutil attach "/Applications/Install OS X El Capitan.app/Contents/SharedSupport/InstallESD.dmg" -noverify -nobrowse -mountpoint /Volumes/esd
이 명령은 아래에 주어진 명령으로 대체되어야합니다. 폴더에 이름 El Capitan
이 지정된 임시 폴더 가 생성됩니다 Downloads
.
# Create bootable El Capitan ISO
# Extract the files from the downloaded file
hdiutil attach "$HOME"/Downloads/InstallMacOSX.dmg
rm -rf /tmp/El\ Capitan
pkgutil --expand /Volumes/Install\ OS\ X/InstallMacOSX.pkg /tmp/El\ Capitan
diskutil eject Install\ OS\ X
cd /tmp/El\ Capitan
# Mount the installer image
hdiutil attach InstallMacOSX.pkg/InstallESD.dmg -noverify -nobrowse -mountpoint /Volumes/esd
klanomoath의 답변에서 마지막 두 명령은 아래에 나와 있습니다.
# Rename the ISO and move it to the desktop
mv ElCapitan.iso.cdr $HOME/Desktop/ElCapitan.iso
# Clean up temporary file
rm ElCapitan.cdr.dmg
위의 명령은 아래에 제공된 명령으로 대체해야합니다.
# Rename the ISO and move it to the Downloads folder
mv ElCapitan.iso.cdr "$HOME"/Downloads/ElCapitan.iso
# Clean up temporary folder
cd "$HOME"
rm -r /tmp/El\ Capitan
명령을 실행할 때 아래와 비슷한 오류 메시지가 나타날 수 있습니다. 부팅 가능한 디스크 드라이브를 만들 때 시스템이 멈추는 문제는 이 오류를 해결합니다.
asr: Couldn't personalize volume /Volumes/OS X Base System
가상 머신을 시작하기 전에 다음 명령을 입력해야했습니다 El Capitan
.
참고 : El Capitan을 2018 Mac mini에 설치할 수 없으므로이 명령을 입력해야했습니다. El Capitan을 Mac에 설치할 수 있다면이 명령을 입력하지 않아도됩니다.
VBoxManage setextradata "El Capitan" "VBoxInternal/Devices/efi/0/Config/DmiSystemProduct" "Macmini6,2"
VBoxManage setextradata "El Capitan" "VBoxInternal/Devices/efi/0/Config/DmiSystemVersion" "1.0"
VBoxManage setextradata "El Capitan" "VBoxInternal/Devices/efi/0/Config/DmiBoardProduct" "Mac-F65AE981FFA204ED"
VBoxManage setextradata "El Capitan" "VBoxInternal/Devices/smc/0/Config/DeviceKey" "ourhardworkbythesewordsguardedpleasedontsteal(c)AppleComputerInc"
VBoxManage setextradata "El Capitan" "VBoxInternal/Devices/smc/0/Config/GetKeyFromRealSMC" 1
VBoxManage modifyvm "El Capitan" --cpuidset 00000001 000106e5 06100800 0098e3fd bfebfbff