VRF를 사용하는 것은 별도의 라우터를 사용하는 것과 같습니다. 두 VRF에 동일한 WAN IP가있는 경우 두 WAN 인터페이스에서 두 번 구성해야합니다. 그러나 하나의 WAN 인터페이스 만 사용하는 경우이 인터페이스를 트렁크 (VLAN 사용) 또는 하위 인터페이스로 나눠야합니다.
전의:
interface FastEthernet0.5
encapsulation dot1Q 5
ip address 1.1.1.1 255.255.255.252
우리는 ip vrf 전달을 사용하지 않습니다. 여기서는 기본 vrf를 사용하고 있습니다.
interface FastEthernet0.10
ip vrf forwarding wanconnection:1
encapsulation dot1Q 10
ip address 1.1.1.1 255.255.255.252 (<== this can be another IP if you prefer to divide it with 2 different IP's)
연결은 다음과 같습니다.
- 라우터 (일반 vrf) => wan 연결 => dot1Q 태그 5에 사용되는 VPN
- 라우터 (wanconnection : 1 vrf) => wan connection => dot1Q 태그 10에 사용되는 VPN
태그를 지정하지 않고이 작업을 수행하고 2 개의 물리적 인터페이스 만있는 경우 동일한 구현입니다.
interface FastEthernet0
ip address 1.1.1.1 255.255.255.252
interface FastEthernet1
ip vrf forwarding wanconnection:1
ip address 1.1.1.1 255.255.255.252
특정 vrf "wanconnection : 1"에 필요한 다른 모든 인터페이스는 동일한 방식으로 추가해야합니다.
ip vrf forwarding wanconnection:1
전의:
interface FastEthernet4
ip vrf forwarding wanconnection:1
ip address 10.0.0.1 255.255.255.0
vrf 만들기 : http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/15.02SG/configuration/guide/vrf.html
ip vrf wanconnection:1
rd 65000:1
rd 100 : 1 명령 설명 : 라우트 구분자를 지정하여 VRF 테이블을 작성합니다. AS 번호와 임의의 숫자 (xxx : y) 또는 IP 주소와 임의의 숫자 (ABCD : y)를 입력하십시오.
라우팅 부분의 경우 :
ip route 0.0.0.0 0.0.0.0 1.1.1.2
ip route vrf wanconnection:1 0.0.0.0 0.0.0.0 1.1.1.2
태그를 사용하지 않고 하나의 WAN 연결 만있는 경우 Vrf 간 라우팅을 사용할 수 있습니다. http://packetlife.net/blog/2010/mar/29/inter-vrf-routing-vrf-lite/
전의:
ip vrf wanconnection:1
rd 65000:1
route-target export 65000:2
route-target import 65000:99
ip vrf wanconnection:2
rd 65000:2
route-target export 65000:1
route-target import 65000:99
ip vrf shared:1
rd 65000:99
route-target export 65000:99
route-target import 65000:1
route-target import 65000:2
interface FastEthernet0
ip vrf forwarding shared:1
ip address 1.1.1.1 255.255.255.252
interface loopback1
ip vrf forwarding shared:1
ip address 2.2.2.2 255.255.255.255
ip route vrf shared:1 0.0.0.0 0.0.0.0 1.1.1.2
ip route vrf wanconnection:1 0.0.0.0 0.0.0.0 2.2.2.2
ip route vrf wanconnection:2 0.0.0.0 0.0.0.0 2.2.2.2
interface FastEthernet1
ip vrf forwarding wanconnection:1
ip address 10.0.0.1 255.255.255.0
description "LAN interface vrf 1"
interface FastEthernet2
ip vrf forwarding wanconnection:2
ip address 10.0.2.1 255.255.255.0
description "LAN interface vrf 2"
여기서 FastEthernet1은 vrf wanconnection : 1에 대한 기본 경로를 사용하고 FastEthernet2는 vrf wanconnection : 2에 대한 기본 경로를 사용합니다 ( "ip route"명령으로 제공).