유효한 이메일 주소의 최대 길이는 얼마입니까?


987

유효한 이메일 주소의 최대 길이는 얼마입니까? 표준으로 정의되어 있습니까?


어떤 종류의 이메일 주소? 인터넷, X.400 또는 기타?
— Toby Speight

참고 앱이 부과해야 길이 제한 이메일 주소를이 수 없습니다 과 동일 이론적 인 최대 입니다 ( 이 모든 의견보다 더 ). : 다른 답변은 예를 들어 그 질문, 토론 stackoverflow.com/questions/1297272
— MGOwen

답변:


1205

이메일 주소는 254 자를 초과 할 수 없습니다 .

이것은 정오표 제출 후 IETF에 의해 수락되었습니다 . 특정 주소에 대한 전체 진단은 온라인 으로 제공 됩니다 . RFC 3696의 원래 버전은 320을 최대 길이로 설명했지만 경로가 다음과 같이 정의 되었기 때문에 John Klensin은 잘못된 값을 수락했습니다.

Path = "<" [ A-d-l ":" ] Mailbox ">"

따라서 사서함 요소 (예 : 전자 메일 주소)에는 주위에 꺾쇠 괄호가있어 경로를 형성하며 경로 길이를 256 자 이하로 제한하기 위해 최대 254 자입니다.

RFC 5321 상태에 지정된 최대 길이 :

역방향 경로 또는 순방향 경로의 최대 총 길이는 256 자입니다.

RFC 3696이 여기 에서 수정되었습니다 .

사람들은 특히 RFC 3696 에 대한 정오표를 알고 있어야합니다 . 정식 예제 중 3 개는 실제로 잘못된 주소입니다.

http://www.dominicsayers.com/isemail 에서 찾을 수있는 수백 개의 테스트 주소를 정리했습니다 .


7
이메일 주소에서 유니 코드를 허용하는 새로운 RFC 표준은 어떻습니까?
— Pacerier

3
@ 앞에 몇 개의 문자와 몇 개의 문자가 있는지, 아니면 중요하지 않습니까?
— systemovich

5
@Lodewijk RFC 3696은 표준이 아니며 사람들이 기본 표준을 올바르게 해석하도록 도와줍니다. 불행하게도, 상황을 명확하게하기 위해 Klensin은 에라타에서 수정 된 중대한 오류를 포함했습니다. 그러나 아무도 정오표를 읽지 않으므로 RFC 3693은 매우 도움이되지 않는 아이러니하게됩니다.
— Dominic Sayers 2019

3
국제화 된 전자 메일 주소를 사용하면 문자가 아닌 254 옥텟으로 제한을 정의하는 것이 더 정확합니다 . 그러나 나는 확실하지 않다. RFC 6531은 RFC 5321 역방향 및 순방향 경로를 확장하여 UTF-8 문자를 허용하지만 RFC 5321은 구분 기호 ( "문자"라고하는 RFC 2821의 의도적 인 변경)를 포함하여 제한이 "256 옥텟"이라고 구체적으로 말합니다. 256- 옥텟 제한 (254에서 -2)은 대체되지 않으며 멀티 바이트 UTF-8 문자를 가진 주소의 경우 유효 문자 제한이 줄어 듭니다.
— Andre D

1
도메인은 이메일 이외의 다른 목적으로 사용되며 다른 RFC에 의해 정의되기 때문에 @JohnLBevan. Jon Postel이 더 일관성을 유지하기를 원했지만 대부분의 도메인이 매우 짧았을 때 봉투 주소를 두 개 이상의 패킷으로 나누는 것만으로도 매우 긴 도메인의 가능성을 고려할 때 과잉이되었을 것입니다. 이름.
— Dominic Sayers

38

320

세그먼트는 다음과 같습니다

{64} @ {255}

64 + 1 + 255 = 320

이메일을 확인하는 경우에도 읽어야합니다

http://haacked.com/archive/2007/08/21/i-knew-how-to-validate-an-email-address-until-i.aspx


그러나이 스펙 (학생 대출 데이터)에 따르면 20 페이지의 nchelp.org/elibrary/ESC/CommonRecord-CommonLineDocumentation/… : "이메일 길이는 현재 ANSI 표준을 반영하도록 변경되었습니다. 이메일 주소는 최대 길이입니다 128 자입니다. " 흠.
— Nathan Nathan

8
다음은 "max len == 320"을 포함하여 전자 메일에 대한 다양한 신화를 없애는 멋진 기사입니다. 한계는 실제로 254입니다.
— Carl

26
사랑스러운 기사는 어디에 있습니까?
— Bob

1
이 대답은 맞습니다. 2821은 <>대괄호를 사용하여 MAIL / RCPT 명령을 256으로 제한하기 때문에 유효하지만 절대적으로 사용할 수 없습니다 .
— vp_arth

1
그 형식의 이메일을 포함합니까 user+inbox@domain?
— Aaron Esau

20

사용자

사용자 이름의 최대 총 길이는 64 자입니다.

도메인

도메인 부분에서 최대 255 자 (“@”다음 문자)

그러나 RFC 2821 판독 에는 제한이 있습니다 .

역경로 또는 순방향 경로의 최대 총 길이는 문장 부호 및 요소 구분 기호를 포함하여 256 자입니다.” 해당 필드에 맞지 않는 주소는 일반적으로 유용하지 않으므로 주소 길이의 상한은 일반적으로 256으로 간주되어야하지만 경로는 다음과 같이 정의됩니다. Path = "<"[Adl ":"] Mailbox "> ”전달 경로에는 전자 메일 주소를 254 자로 제한하는 사서함 외에 최소한 한 쌍의 꺾쇠 괄호가 포함됩니다.


7
쿨, 1982 년 고대 RFC는 ... SMTP에 대한 RFC5321있다
— vp_arth

14

나와 같은 혼란스러운 신인을 돕기 위해 "유효한 이메일 주소의 최대 길이는 얼마입니까?" 입니다 254 자 .

응용 프로그램에서 전자 메일을 사용하는 경우 필드를 254 자 이하로 설정하면됩니다.

이메일에서 여러 가지 테스트를 실행하여 여기에서 유효한지 확인할 수 있습니다. http://isemail.info/

RFC 또는 의견 요청은 254자를 제한으로 정의하는 IETF (Internet Engineering Task Force)의 간행물 유형입니다. 여기에 위치-https: //tools.ietf.org/html/rfc5321#section-4.5.3


12

다른 하나는 물을 약간 어둡게합니다. 간단한 답변 : 전자 메일에 대한 우리의 제어에서 총 254 개의 문자 256은 전체 전자 메일 주소를위한 것이며, 여기에는 처음에 "<", 끝에 ">"가 포함됩니다. 따라서 254 개가 남았습니다.


4

아래 기사에 따르면 :

http://tools.ietf.org/html/rfc3696 (페이지 6, 섹션 3)

다음과 같이 언급되었습니다.

"이메일 주소에는 길이 제한이 있습니다.이 제한은"로컬 부분 "("@ "이전)에서 최대 64 자 (옥텟)이고 도메인 부분에서 최대 255 자 (옥텟)입니다 ( "@")를 사용하여 총 길이는 320 자입니다. 전자 메일을 처리하는 시스템은 거의 발생하지 않지만 긴 주소를 처리 할 수 ​​있도록 준비해야합니다. "

따라서 이메일 주소의 최대 총 길이는 320 자입니다 ( "로컬 부분": 64 + "@": 1 + "도메인 부분": 255, 320)


320 자 이메일 ID를 확인하기 위해 자바 스크립트로 정규식을 제공해 주시겠습니까? 미리 감사드립니다.
— Kamlesh

1
표준의이 부분은 정오표에 총 254자를 포함하도록 수정되었습니다. 정오표에 대한 자세한 내용과 링크는 허용 된 답변을 참조하십시오.
— Matthijs Kooijman
당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.