IIS 7.5에서 관리자 계정에 대한 FTP 오류“디렉토리 목록을 검색하지 못했습니다”를 해결하는 방법


20

관리자 계정을 사용하여 FileZilla를 사용하여 IIS 7.5 FTP 사이트에 FTP로 연결했습니다. 파일을 성공적으로 업로드 할 수 있었지만 응답으로 "디렉토리 목록을 검색하지 못했습니다"라는 메시지가 계속 나타납니다.

패시브 모드에서 명령, 응답 및 오류는 다음과 같습니다.

Command:    LIST
Response:   150 Opening BINARY mode data connection.
Response:   550 The network connection was aborted by the local system. 
Error:  Failed to retrieve directory listing

활성 모드에서 명령, 응답 및 오류는 다음과 같습니다.

Command:    PORT 192,168,1,129,102,151
Response:   501 Server cannot accept argument.
Error:  Failed to retrieve directory listing

내가 뭘 잘못 했니?

답변:


12

이 문제도 있었으며 IIS에서 선택한 데이터 포트와 관련이 있습니다. 특정 포트 범위를 사용하도록 설정했지만 클라이언트가 수동 모드를 사용하려고 시도했을 때 잘못된 포트를 사용하고 있음을 보여주었습니다.

이 기사에서는 사용중인 포트를 계산하는 방법에 대해 설명합니다. 예 :

227 Entering Passive Mode (x1,x2,x3,x4,y1,y2)

사용하는 IP는 x1.x2.x3.x4 및 포트 (y1 * 256) + y2입니다. y1 및 y2에 잘못된 값이 표시되어 IIS의 FTP 방화벽 설정에서 설정 한 값을 실제로 인식하도록 "Microsoft FTP 서비스"를 다시 시작해야했습니다.


1
감사. Microsoft FTP 서비스를 다시 시작하면 문제가 해결되었습니다.
— Shiv

내 서버의 IP가 변경됨-이전 IP가 어딘가에서 사용되고 있음이 밝혀졌습니다 ... Hrmph
— mjohnsonengr

"방화벽 지원"섹션의 "방화벽 외부 IP 주소" -iis.net/configreference/system.applicationhost/sites/site/…
— mjohnsonengr

5

저에게는 재시작이 도움이되지 않지만 수동 모드를 비활성화 하면 도움 이되었습니다.


2
FileZilla에서 명시 적으로 활성 모드를 설정했으며 저에게 효과적이었습니다.
— Sohail Ahmed


2

나는 같은 문제가 있었지만 해결책이 있습니다.

위치 경로 ftp 디렉토리를 확인 everyone하고이 폴더에 대한 전체 액세스 권한이있는 사용자 를 추가하십시오 .


보안 상 위험하지 않습니까?
— Zeeshan


1

Windows 2008 Server에서 동일한 오류가 발생하여 방화벽과 Windows 방화벽 (공개 프로필) 모두에서 모든 (수동 포트)을 허용해야했으며 IIS 6.0 FTP에서 IIS 7.5 FTP로 업그레이드해야했습니다.


특정 문제에 대한 매우 과감한 방화벽 솔루션입니다.
— itsbruce

나는 모든 포트를 의미하는 것이 아니라 모든 FTP 수동 포트를 의미합니다
— Alexandre Marcondes

1

동일한 정확한 문제가 발생했으며 FTP Firewall Support외부 IP와 일치하도록 IIS에서 설정 한 후에도 여전히 문제가 발생했습니다. 마지막 단계에서의 실제 FTP 규칙을 편집 하여 탭에서 Windows Firewall허용 하고 서비스에서 다시 시작했습니다 . 그 후 나는 더 이상 문제가 없었습니다.Edge traversal -> Allow Edge TraversalAdvancedApply/OKFTPSVC


당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.