잘못된 명령 'VirtualDocumentRoot'


13

아파치가 재부팅 될 때 왜 다음과 같은 오류가 발생하는지 확실하지 않습니다.

Invalid command 'VirtualDocumentRoot', perhaps misspelled or defined by a module not included in the server configuration Action 'start' failed.

참조하는 스 니펫은 다음과 같습니다.

<VirtualHost *:80>
        ServerAdmin help@mydomain.com
        VirtualDocumentRoot /local/www/staging/%1

        ServerAlias *.staging.mydomain.com
</VirtualHost>

나는 그것이 말한 바와 같이 철자가 틀렸다고 생각했지만 내 다른 서버에서 직접 복사되었습니다. 그것은 완벽하게 작동합니다. 어떤 아이디어?

답변:


27

설명서 는 지시문이 vhost_alias 모듈에 의해 제공됨을 제안합니다. 당신이 가지고 있는지 확인해야합니다

LoadModule vhost_alias_module modules/mod_vhost_alias.so

작동하지 않는 서버의 구성 파일에 구성 지시문이 있습니다.


12
대단히 감사합니다! 그것은 그것을 해결하는 데 도움이되었습니다. 게시 한 코드는 직접 작동하지 않았지만 다음을 사용하여 모듈을로드했습니다.a2enmod vhost_alias
— andy

힌트부터 시작하고 더 세게 파고 들었을 때 좋습니다.
— MadHatter

3

앤디가 제공 한 것과 같은 오류가 있었지만 제 경우에는 상황이 약간 다릅니다. 그리고 MadHatter의 답변으로부터 나는 문제를 고안 할 수있었습니다.

내 아파치 2 서버는 약간 달랐다. 여기에는 /etc/apache2/mods-available& 디렉토리가 2 개 /etc/apache2/mods-enabled있습니다. 디렉토리 mods-available에는로드 가능한 모듈 구성 파일 목록이 표시됩니다.이 경우 vhost_alias.load구성이 포함 된 이름의 파일이 표시 됩니다.

LoadModule vhost_alias_module /usr/lib/apache2/modules/mod_vhost_alias.so

그래서 아래 명령을 사용 하여이 구성을 활성화했습니다.

sudo a2enmod vhost_alias
당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.