"MPM이로드되지 않았습니다",하지만 mpm을 사용하지도 않습니다.


10

Vagrant의 Ubuntu Precise64에서 Apache2 실행 시작하려고하면 다음과 같이 말합니다.

vagrant@precise64:/etc/apache2$ /etc/init.d/apache2 start
 * Starting web server apache2
 *
 * The apache2 configtest failed.
Output of config test was:
AH00534: apache2: Configuration error: No MPM loaded.
Action 'configtest' failed.
The Apache error log may have more information.

그러나 문제는 내 /etc/apache2/apache2.conf파일이 어디서나 MPM을 요구하지 않는다는 것입니다 ! 나는 여기에 붙여 넣을 것이지만 거대한 게시물을 만들 것입니다 ...

오류 로그를 찾으려고 시도했지만 어느 곳에서도 찾을 수 없습니다. 도움?

편집 : apache2 -l 이것을 제공합니다 :

vagrant@precise64:/$ apache2 -l  
Compiled in modules:             
  core.c                         
  mod_so.c                       
  mod_watchdog.c                 
  http_core.c                    
  mod_log_config.c               
  mod_logio.c                    
  mod_version.c                  
  mod_unixd.c                    
  mod_unixd.c                    

mpm이 설치되지 않은 것 같습니다. MPM이 설치되어 있지 않고 구성 파일에 언급 된 MPM이 없는데 왜이 오류가 계속 발생합니까?


1
dpkg -l 'apache2-mpm *'의 출력은 무엇입니까
— sciurus

나를 위해 그것을 제거, 재설치에 충분하고 범인이었다 무엇 이건, 기존의 설정 파일을 복사)
— 멜리사 루스

답변:


10

apache2 -t -D DUMP_MODULES (또는 -M)은 모듈 목록을 제공해야합니다. worker.c 또는 prefork.c 또는 event.c가 표시되어야합니다. 이를 사용하여 사용중인 MPM을 판별하십시오.

프리 포크 MPM을 사용하는 경우와 같은 것이 있다면 설정 파일을 살펴보십시오.

예를 들면 다음과 같습니다.

<IfModule mpm_prefork_module>
StartServers          5
MinSpareServers       5
MaxSpareServers      10
MaxClients          150
MaxRequestsPerChild   0
</IfModule>

이와 같은 블록을 구성 파일에 추가하면 작동합니다. apache2-mpm-prefork (또는 작업자 또는 이벤트)가 올바르게 설치되었는지 확인하십시오.

사용에 적합한 MPM을 선택하는 데 도움이되도록이 설명서를 읽으십시오 (필수). http://httpd.apache.org/docs/2.2/mpm.html


명령 출력으로 원래 질문을 업데이트했습니다 ... mpm 모델이 전혀없는 것 같아서 왜 오류가 발생하는지 이해할 수 없습니다. 어떤 생각?
— ezuk

1
MPM 모듈을 선택해야합니다 (필수).
— Vinz

@Vinz 안녕하세요. 나는 실제로 같은 문제 (우분투 13.10, 아파치 2.4.6)를 가지고 해결책을 시도했다. 구성 파일에서 해당 블록이 누락되었지만 추가해도 문제가 해결되지 않았습니다. 다른 아이디어가 있습니까? 나는 여기서 길을 잃었다.
— Itai Bar-Haim

@ ItaiBar-Haim :이 블록을 추가 한 후 오류 메시지는 무엇입니까?
— Vinz

@Vinz 같은 오류였습니다. 그러나 기본 Apache 구성을 사용하고 어떤 식 으로든 구성을 재정의하지 않으면 작동하는 것으로 나타났습니다.
— Itai Bar-Haim

10

나는 같은 문제가 있었다. 실수로 덮어 썼습니다 /etc/apache2/apache2.conf. 수정하려면 sudo apt-get purge apache2아파치를 완전히 제거한 다음 sudo apt-get install apache2원래 apache2.conf파일을 다시 가져 오기 위해 실행 해야했습니다 .

참고 : /etc/apache2/sites-available제거하기 전에 사용자 정의 파일을 백업하십시오 .


Vagrant를 실행하는 데 비슷한 문제가 있었고 실수로 apache2.conf의 모든 내용을 지 웠습니다. 그래도 조금 더 쉽게 되돌릴 수 vagrant destroy && vagrant up있습니다.
— forsvunnet
당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.