SERVER에 대해 구성된 RSA 인증서에 서버 이름과 일치하는 ID가 포함되어 있지 않습니다


28

최근에 WordPress에서 LAMP 서버 (모든 최신 버전)를 시작했으며 최근에 구입 한 SSL 인증서를 설치하려고합니다. 내가 다시 시작할 때 apachectlerror_log는 다음을 제공합니다.

[Tue Feb 25 01:07:14.744222 2014] [mpm_prefork:notice] [pid 1744] AH00169: caught SIGTERM, shutting down
[Tue Feb 25 01:07:17.135704 2014] [suexec:notice] [pid 1765] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Feb 25 01:07:17.217424 2014] [auth_digest:notice] [pid 1766] AH01757: generating secret for digest authentication ...
[Tue Feb 25 01:07:17.218686 2014] [lbmethod_heartbeat:notice] [pid 1766] AH02282: No slotmem from mod_heartmonitor
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/5.5/modules/mysql.so' - /usr/lib64/php/5.5/modules/mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/5.5/modules/mysqli.so' - /usr/lib64/php/5.5/modules/mysqli.so: cannot open shared object file: No such file or directory in Unknown on line 0
[Tue Feb 25 01:07:17.305292 2014] [mpm_prefork:notice] [pid 1766] AH00163: Apache/2.4.6 (Amazon) OpenSSL/1.0.1e-fips PHP/5.5.7 configured -- resuming normal operations
[Tue Feb 25 01:07:17.305378 2014] [core:notice] [pid 1766] AH00094: Command line: '/usr/sbin/httpd'

ssl_error_log가 나에게 이것을 제공하지만 :

[Tue Feb 25 00:57:15.802287 2014] [ssl:warn] [pid 1705] AH01909: RSA certificate configured for ec2-XX-XXX-XXX-XX.compute-1.amazonaws.com:443 does NOT include an ID which matches the server name
[Tue Feb 25 00:57:15.899327 2014] [ssl:warn] [pid 1706] AH01909: RSA certificate configured for ec2-XX-XXX-XXX-XX.compute-1.amazonaws.com:443 does NOT include an ID which matches the server name

"ServerName"을 ssl.conf서버 이름 (dcturano.com)으로 변경하고 다시 시작 apachectl했지만이 오류가 발생합니다. 어떤 아이디어가 있습니까?

따로, 서버의 CommonName을 설정하지 않았습니다. 문제가 될 수 있습니까?

답변:


45
openssl x509 -in server.crt -noout -subject

인증서의 CN을 반환해야합니다. 이것이 ServerName 지시문에서 사용하고 연결해야하는 이름입니다.


# openssl x509 -in server.crt -noout -subject 인증서 server.crt를 여는 중 오류 발생 140451499632288 : error : 02001002 : system library : fopen : 파일 또는 디렉토리가 없습니다 : r ') 140451499632288 : 오류 : 20074002 : BIO 루틴 : FILE_CTRL : system lib : bss_file.c : 400 : 인증서를로드 할 수 없음
— jmituzas

1
@jmituzas, 당신은 변경해야합니다 server.crt으로 openssl x509 -in server.crt -noout -subject당신의는 server.crt 배치에
— avivmg

4
실제로 오늘날 모든 공용 CA는 SubjectAlternativeName 확장명을 가진 인증서를 발급 하며 해당 확장명에 와일드 카드와 일치하는 이름을 사용할 수 있습니다. OpenSSL이는 고립 SAN을 표시하지 않습니다,하지만 당신은 같은 것을 할 수openssl x509 -in cert -text | grep -A1 "Subject Alternative Name"
— dave_thompson_085

1
또한 ServerName 지시문을 추가하고 가상 호스트의 주소를 설정하지 말아야합니다 (제 경우에는 문제가되었습니다).
— hugovdberg

그 트릭을했다. 복사 CN 값 localhost의 출력과 sudo openssl x509 -in /etc/ssl/certs/server.crt -noout -subject같은 ServerName localhost에서 sudo nano /etc/httpd/conf.d/ssl.conf. 나는 centos 7을 방랑자로 사용하고 있습니다.
— Damodar Bashyal

2

또는 나와 같이 ssl을 사용하지 않는 경우에도 ssl 사용이 기본적으로 켜져 있기 때문에이 오류 메시지가 계속 표시됩니다. 이 경우 전원을 끄십시오! 발췌 내용은 다음과 같습니다 config.d/ssl.conf.

#   SSL Engine Switch:
#   Enable/Disable SSL for this virtual host.
#SSLEngine on
SSLEngine off

7
질문에 인증서를 구입했다고 명시되어 있으므로 귀하의 답변을 평가했습니다. 나는 보통 사용하지 않을 물건을 사지 않습니다.
— hugovdberg

2

나는 같은 문제가 있었지만 다른 이유 때문이었습니다. 미래 Google 직원을 위해 여기에 게시합니다.

내 아파치 설정 파일에 갖는 대신에 <VirtualHost *:443>, 나는했다 <VirtualHost *:80>. 내가 고치 자마자 사이트가 백업되어 실행 중이었습니다.


1

/etc/hosts파일을 통해이 문제를 발생 시켰습니다 .

나는 가상 호스트를 가지고있다. www.effinwhatever.com

서버의 호스트 이름은 www2 입니다.

나는 /etc/hosts가상 호스트에 대해 물건을 말릴 수 있도록 줄을 추가했습니다 .

192.168.1.200         www.effinwhatever.com

에서 해당 줄을 제거하자마자 /etc/hostsApache 서버가 정상적으로 다시 서비스를 시작했습니다 (서비스가 다시 시작됨). 기묘한.

SSL 인증서가 와일드 카드 도메인 용인 것도 관련이있을 수 있습니다.


0

동일한 AH01909 : RSA 인증서 오류가 발생했습니다. 내 경우에는 올바른 serverName값을 가졌습니다 .

<VirtualHost 10.11.12.13:443>보안 사이트 정의 에서 오류의 원인이 잘못된 IP 주소였습니다 . 나는 그것을 잘못 입력했다!


-1

ServerName이 openssl x509 -in server.crt -noout -subject출력 과 정확히 동일해야 합니다. www가 있으면 ServerName도 필요합니다. 그렇지 않은 경우 ServerName은 www를 삭제해야합니다.

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.