Docker : 페어 인터페이스를 추가하지 못했습니다 (작업이 지원되지 않음)


23

Docker를 설치 한 후 Hello World 예제를 실행하려고 할 때 오류가 발생합니다.

Error response from daemon: Cannot start container 4145d0fccd96b904e4ab4413735f1129b8765429bad5be71dc8d5f4c0760666d:
failed to create endpoint high_saha on network bridge:
failed to add the host (veth7f6f907) <=> sandbox (veth788d9dc) pair interfaces: operation not supported

(방금 데비안 서버를 Wheezy에서 Jessie로 업그레이드했습니다.)

누구 든지이 오류가 발생하는 이유를 알고 있습니까? 업그레이드 중에 무언가를 놓쳤습니까?

당신의 도움을 주셔서 감사합니다.


어떤 커널을 실행하고 있습니까?
— Michael Hampton

3.10.23-xxxx-std-ipv6-64
— piero-la-lune

답변:


7

OVH 사양에 내장 된 OVH의 사용자 정의 커널로 시스템을 부팅했으며 실행하려는 소프트웨어를 실행하기에 적합하지 않을 수 있습니다.

Linux 배포에서 제공하는 하드 드라이브에 설치된 커널에서 부팅하도록 전용 서버 구성을 변경하십시오.

OVH 부팅 구성 화면


1
새 커널을 설치하고 Grub에게 사용하도록 지시했습니다. 이제 작동합니다! 감사 !
— piero-la-lune

1
새 커널로 업데이트했지만 이전에 설치된 버전에서 계속 실행중인 경우이 오류가 나타납니다. 재부팅 후 문제가 해결됩니다.
— Darragh

90

제 경우에는 Linux 커널을 업데이트 할 때마다 오류가 나타납니다. 컴퓨터를 다시 시작하면 사라집니다.

아치 리눅스를 사용하고 있습니다.


8
커널 업그레이드에서는 /usr/lib/modules/{KERNEL_VERSION}실행중인 커널의 모든 .ko 모듈 파일 이 삭제 되므로 정상 입니다. Docker는 인터페이스를 생성하기 위해 툰 / 탭 모듈이 필요하며 커널 업그레이드 후로드 시도가 실패합니다. 모든 커널 파일이 새 커널에 포함되어 있으므로 재부팅하면 도움이됩니다. 또 다른 해결 방법은 pacman 패키지가 여전히 있고 재부트를 피하려는 경우 이전 커널의 모듈을 다시 추출하는 것입니다.
— cbley

3
커널 업데이트 후 재부팅 했습니까?
— Daniel Andrei Mincă

1
여기에서도 마찬가지입니다. 그로 인해 오류가 사라지고 재부팅 후 컨테이너가 올바르게 시작됩니다.
— Nicolas Modrzyk
당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.