PHP를 다시 컴파일하려고하는데 ./configure가 실패합니다. configure: error: Cannot find OpenSSL's <evp.h> LibSSL 1.0.0, LibSSL 0.9.8, LibSSL-Dev, OpenSSL이 설치되어 있습니다. --with-openssl=/usr/include/openssl 내가 시도 할 때 --with-openssl 나에게 말한다 : 구성 : 오류 : OpenSSL의 라이브러리를 찾을 수 없습니다 ****는 어디 문제입니까? PS Php는 5.2.5, OS는 우분투
의 맨 페이지는 다음과 logrotate같이 말합니다. It can be used when some program cannot be told to close its logfile and thus might continue writing to the previous log file for some time. 나는 이것으로 혼란스러워합니다. 프로그램이 로그 파일을 닫으라고 지시 할 수 없으면 언젠가가 아니라 영원히 계속 작성 됩니다 …
나는 최근에 PHP 5.2.9 바이너리를 컴파일했고 , PHP 스크립트를 사용해 보았습니다. 문제없이 일부 스크립트를 실행할 수 있지만 그 중 하나는 오류나 경고없이 종료되는 도중에 실행이 중단됩니다. 프로세스의 리턴 상태 코드는 255입니다. 설명서에서 그러한 상태가 '예약 됨'이라고 읽었습니다. 문제는 무엇을 위해서인가? PHP 실행 파일에서 누락 된 종속성과 관련이 있다고 생각하지만 확실하지 …
과 함께 디렉토리를 반복적으로 삭제하려고하는데 rm -Force -Recurse somedirectory여러 개의 "디렉토리가 비어 있지 않습니다"오류가 발생합니다. 내가 경우 동일한 명령을 다시 시도 , 그것은 성공합니다. 예: PS I:\Documents and Settings\m\My Documents\prg\net> rm -Force -Recurse .\FileHelpers Remove-Item : Cannot remove item I:\Documents and Settings\m\My Documents\prg\net\FileHelpers\FileHelpers.Tests\Data\RunTime\_svn: The directory is not empty. At line:1 …
NAT를 사용할 때 libvirt / KVM을 실행하는 서버의 포트를 VM의 지정된 포트로 어떻게 전달할 수 있습니까? 예를 들어 호스트의 공용 IP는 1.2.3.4입니다. 포트 80을 10.0.0.1로, 포트 22를 10.0.0.2로 전달하고 싶습니다. iptables 규칙을 추가해야한다고 가정하지만 적절한 위치와 정확히 무엇을 지정 해야하는지 잘 모르겠습니다. iptables의 출력 -L Chain INPUT (policy ACCEPT) target …
때때로 사람들은 자신이하지 말아야 할 파일을 삭제합니다. 장기간 실행되는 프로세스에서 여전히 파일이 열려 있고, catting하여 데이터를 복구하는 /proc/<pid>/fd/N것만으로는 충분하지 않습니다. ln에 매직 옵션을 실행하여 삭제를 "실행 취소"할 수 있으면 충분할 것입니다. 그러면 inode 번호 (lsof를 통해 복구)에 다시 연결할 수 있습니다. 최소한 커서가있는 인터넷 검색 으로이 작업을 수행 할 수있는 …
예를 들어 웹 서버가 다시 시작되는지 여부를 알 수 있도록 업그레이드로 인해 패키지와 관련된 스크립트 / 트리거를 볼 수 있기를 원합니다. 나에게 그것을 보여주는 적성 옵션을 찾을 수 없습니다 (또는 apt / dpkg). 내가 얻을 수있는 가장 좋은 것은 내용 (파일)입니다. 내가 놓친 시뮬레이션 / 세부 / 컨텐츠 스위치의 조합이 …
실패시 시스템 서비스가 자동으로 다시 시작되기를 원합니다. 또한 재시작 횟수를 제한하고 싶습니다. 90 초 동안 최대 3 번의 재시작을 허용하려고합니다. 따라서 다음 구성을 수행했습니다. [서비스] Restart = 항상 StartLimitInterval = 90 StartLimitBurst = 3 이제 서비스가 실패하면 다시 시작됩니다. 3 개의 빠른 실패 / 레스토랑 후에는 더 이상 예상대로 다시 …
Ansible을 사용하여 개발 서버를 프로비저닝하고 있습니다. 나는 항상 나를 위해 몇 가지 서비스를 시작하기를 원합니다. 이 목적을위한 핸들러가 있지만 조건없이 핸들러 실행을 트리거하는 가장 좋은 방법은 무엇입니까? 이 같은: tasks: - name: Trigger handler run_handler: name=nginx-restart