서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

8
서버 환경에서 소비자 (또는 프로슈머) SSD와 빠른 HDD
서버 환경에서 소비자 SSD와 빠른 10-15k 회전 드라이브 의 장단점은 무엇입니까 ? 엔터프라이즈 SSD는 엄청나게 비싸므로 사용할 수 없습니다. 특정 사용 사례에 대한 참고 사항은 다음과 같습니다. 최대 5-10 개의 VM을 가진 하이퍼 바이저 개별 VM이 미친 I / O를 집중적으로 사용하지는 않습니다. 내부 RAID 10, SAN / NAS 없음 …

2
AWS에 인증서를 업로드 할 수 없습니다
나는 일을 해요: aws iam upload-server-certificate --server-certificate-name MysiteCertificate --certificate-body Downloads/mysite/mysite.crt --private-key mysite.pem --certificate-chain Downloads/mysite/COMODOSSLCA.crt 그래도 오류가 발생합니다. A client error (MalformedCertificate) occurred when calling the UploadServerCertificate operation: Unable to parse certificate. Please ensure the certificate is in PEM format. pem= (그래도 유효한 파일입니다)

6
Linux OOM 킬러가 프로세스를 종료하지 못하게하는 방법은 무엇입니까?
물리적 메모리는 적지 ​​만 스왑 공간이 충분할 때 Linux OOM 킬러가 프로세스를 종료하지 않도록하려면 어떻게해야합니까? OOM killing을 비활성화하고 sysctl vm.overcommit_memory = 2로 오버 커밋했습니다. VM에는 3GB의 완전 무료 조각화되지 않은 스왑이 있으며 OOM 강제 종료중인 프로세스의 최대 메모리 사용량은 200MB 미만입니다. 장기 스와핑이 성능면에서 끔찍하다는 것을 알고 있지만 메모리 요구 …
28 linux  swap  oom 


7
이것이 MSI 설치를 방해하는 이유 : 시스템 관리자가이 설치를 방지하는 정책을 설정했습니다
랩 도메인의 일부인 Windows Server 2012 컴퓨터에 MSI를 설치하려고합니다. 로컬 및 도메인 관리자이지만이 MSI를 설치하지 못하는 것 같습니다. 명확히하기 위해 관리자 그룹의 일부인 도메인 사용자로 로그인 한 Visual Studio 용 git 확장 프로그램 ( 여기 에 위치 ) 을 설치하려고 하면 다음 오류가 발생합니다. 오류를보고하는 컴퓨터는 Windows Server 2012입니다. 나는 …

3
Haproxy에서 여러 SSL 인증서 구성
내 haproxy 인스턴스는 2 개의 도메인을 제공합니다 (주로 기본 사이트에서 XSS를 피하기 위해). 규칙은 다음과 같습니다 bind :443 ssl crt /etc/ssl/haproxy.pem acl is_static hdr_end(Host) -i example.com acl is_api hdr_end(Host) -i api.example.com acl is_files hdr_end(Host) -i example.io redirect scheme https if !{ ssl_fc } is_static is_api 이제 SSL은 /etc/ssl/haproxy.pem기본 인증서로 사용 …
28 haproxy 

8
OpenSSL을 업데이트 한 후에도 서버가 여전히 허풍에 취약합니다.
우분투 12.04 서버가 있습니다. OpenSSLHeartbleed 취약점을 해결하기 위해 패키지를 업데이트했습니다 . 그러나 웹 서버와 전체 서버를 다시 시작했지만 여전히 취약합니다. 내 취약점을 확인하려면 다음을 사용하십시오. http://www.exploit-db.com/exploits/32745/ http://filippo.io/Heartbleed dpkg는 다음을 제공합니다. dpkg -l |grep openssl ii openssl 1.0.1-4ubuntu5.12 Secure Socket Layer (SSL) binary and related cryptographic tools (launchpad.net/ubuntu/+source/openssl/1.0.1-4ubuntu5.12)

1
Linux에서 소프트웨어 RAID 및 LVM을 사용할 때 어떤 IO 스케줄러 및 미리 읽기 설정이 적용됩니까?
여러 계층 (실제 드라이브-> md-> dm-> lvm)의 경우 스케줄러, 미리 읽기 설정 및 기타 디스크 설정은 어떻게 상호 작용합니까? mdadm으로 만든 소프트웨어 RAID 장치 (/ dev / md0)의 모든 부분에 여러 디스크 (/ dev / sda-/ dev / sdd)가 있다고 가정합니다. 각 장치 (물리 디스크 및 / dev / md0 …
28 linux  raid  lvm 


3
Amazon SES에서 Gmail로 전송 한 이메일에서 "via"를 제거합니다.
Amazon SES에서 이메일을 보낼 때 gmail은 "amazonses.com을 통해 보냄"을 표시합니다. 이것을 어떻게 제거합니까? 구글에 따르면 저는 발신자이며 수신자가 "연결"링크를 보지 못하게하고 싶습니다. 내가 무엇을 할 수 있을지? Gmail은 이메일이 올바르게 인증되었는지 확인합니다. 대량 메일 공급 업체 또는 타사 계열사가 메시지를 보내는 경우 메시지를 보내고 해당 도메인과 연결된 DKIM3 서명으로 메시지에 …

3
XFS 파일 시스템이 RHEL / CentOS 6.x에서 손상되었습니다. 어떻게해야합니까?
RHEL의 최신 버전은 / CentOS는 (EL6)는 몇 가지 흥미로운 변화 가져 XFS는 특정 파일 시스템 난에 의존 한 많이 10 년 이상. 지난 여름 에 문서화가 잘 안된 커널 백 포트로 인해 XFS 스파 스 파일 상황을 추적하는 데 시간을 보냈습니다 . 다른 사람들은 EL6으로 전환 한 후 불행한 성능 …

7
NTFS의 이론상 최대 데이터 전송 처리량은 얼마입니까?
최근에 로컬 사용자 그룹 회의에서 발표자가 NTFS IO 스택의 최대 처리량은 1GBps라고 언급했습니다. 그는 동일한 논리 볼륨에서 다른 논리 볼륨으로 두 개의 큰 파일을 동시에 복사하여 (즉, [a]는 소스이고, [b]는 목적지 1이고, [c]는 목적지 2 임) 동시에 전송률이 500에 달한다고 주장하면서 주장을 입증했습니다. MBps. 그는이 테스트를 몇 차례 반복했으며 기본 …
28 windows  ntfs 

5
리눅스 커널 튜닝-업스트림 유닉스 소켓으로 nginx 처리량을 늘려야합니까?
다음과 같이 업스트림 유닉스 소켓에 프록시 역할을하는 nginx 서버를 실행 중입니다. upstream app_server { server unix:/tmp/app.sock fail_timeout=0; } server { listen ###.###.###.###; server_name whatever.server; root /web/root; try_files $uri @app; location @app { proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto $scheme; proxy_set_header Host $http_host; proxy_redirect off; proxy_pass http://app_server; } } 일부 앱 서버 …

2
누군가가 지나치게 단순화하지 않고 Windows SPN (서비스 원칙 이름)을 설명 할 수 있습니까?
서비스 원칙 이름으로 몇 번 씨름했고 Microsoft 설명 만으로는 충분하지 않습니다. 도메인에서 작동하도록 IIS 응용 프로그램을 구성하고 있는데 내 문제 중 일부는 내 사이트를 호스팅하는 응용 프로그램 풀을 실행하는 Windows 서비스 계정에서 http 특정 SPN 을 구성해야 할 필요성과 관련이있는 것 같습니다 . 이 모든 것이 서비스 유형 (MSSQL, http, …

2
한 도메인에서 다른 도메인으로 간단한 Apache2 리디렉션
내가하고 싶은 것은 다음과 같습니다. 내 도메인 xy.example.com이 더 이상 존재하지 않습니다. 따라서 새 도메인 abc.example.com으로 간단히 리디렉션하고 싶습니다. 브라우저 바 http://xy.example.com/team.php 에 입력 할 때 작동하는 리디렉션이어야합니다. http://abc.example.com/team.php로 리디렉션해야합니다. 나는 이미 몇 가지 시도했지만 실제로 작동하지 않았습니다. Apache 2 구성에 무엇을 넣어야합니까?

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.