서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

3
AWS Autoscaling 그룹에서 나가는 트래픽에 대한 고정 IP 주소
VPC의 기본 서브넷에있는 Elastic Beanstalk 자동 확장 그룹에 여러 EC2 인스턴스가 있습니다. 이러한 EC2 인스턴스의 앱은 액세스를 허용하기 위해 IP 주소 화이트리스트를 사용하는 타사 서비스에 연결해야합니다. 따라서이 서비스 제공 업체에 제공 할 수있는 하나 이상의 고정 IP 주소가 있어야 화이트리스트에 추가 할 수 있습니다. 정적 IP를 얻는 유일한 방법은 탄력적 …

2
IPv6 서브 네트 / 64-무엇을 깨고 어떻게 해결합니까?
IPv6에서는 / 64 (RFC 5375)보다 작은 서브넷을 서브넷으로 사용해서는 안됩니다. 무엇보다도 SLAAC는 더 작은 서브넷에서 작동하지 않으며 다른 일부 기능도 작동하지 않습니다. ISP가 단일 / 64 만 제공하지만 내부에 여러 서브넷이 필요한 상황에 대한 해결 방법은 무엇입니까? 일반적인 조언은 / 56 또는 / 48를 나눠 줄 다른 ISP를 찾는 것 …
27 ipv6  subnet 

7
도커 로그 지우기 / 삭제
GCE의 도커 구현에서 루트 파일 시스템의 공간이 부족합니다. 이미지 자체는 별도의 1TB 볼륨에 저장되므로 이미지 자체는 문제가되지 않습니다. 하나의 후보는 Docker 자체가 저장하는 중앙 집중식 로그 파일 (어딘가 json 파일입니까?), 해당 파일 / 파일의 위치 / 위치 및 로그를 자르거나 자르는 방법을 아는 사람이 있습니까?
27 ubuntu  logging  docker 


12
CRON에서 AWS CLI를 실행할 수 없음 (자격 증명)
간단한 AWS CLI 백업 스크립트를 실행하려고합니다. 포함 파일에서 행을 반복하고 해당 경로를 S3까지 백업하며 출력을 로그 파일로 덤프합니다. 이 명령을 직접 실행하면 오류없이 실행됩니다. CRON을 통해 실행할 때 출력 로그에 "자격 증명을 찾을 수 없습니다"라는 오류가 발생합니다. 쉘 스크립트 : AWS_CONFIG_FILE="~/.aws/config" while read p; do /usr/local/bin/aws s3 cp $p s3://PATH/TO/BUCKET …

9
sshd 서비스가 시작되지 않습니다
왜 시작되지 않는지 또는 왜 연결하지 못하게되는지 잘 모르겠습니다.이 오류가 발생합니다. sshd.service - OpenSSH Daemon Loaded: loaded (/usr/lib/systemd/system/sshd.service; enabled) Active: failed (Result: start-limit) since Wed 2013-09-11 08:45:13 BST; 1min 21s ago Process: 701 ExecStart=/usr/bin/sshd -D (code=exited, status=1/FAILURE) Sep 11 08:45:13 alarmpi systemd[1]: sshd.service: main process exited, code=exited, status=1/FAILURE Sep 11 …
27 ssh  arch-linux 

4
여러 EC2 보안 그룹-허용 또는 제한?
인스턴스에 여러 보안 그룹을 할당하면 어떻게됩니까? 보안 그룹 중 하나가 허용하면 트래픽이 허용된다는 의미에서 허용됩니까? 또는 모든 보안 그룹이 트래픽을 전달하도록 허용해야한다는 의미에서 제한적인가? 예를 들어 동일한 계정의 다른 인스턴스와 만 대화하는 인스턴스 클래스가 있다고 가정 해 보겠습니다. 또한 HTTP (포트 80)를 통한 트래픽 만 허용하는 인스턴스 클래스도 있습니다. 두 …

1
리버스 프록시-서브 디렉토리 제거
가까운 장래에 3 개의 nginx 서버가 있습니다. 하나는 다른 하나의 SSL에 대한 리버스 프록시입니다. 예를 들어 다음으로 이동합니다. https://www.mysitename.com/site1 이 예에서 다른 두 서버는 site1과 site2입니다. 프록시에 SSL 인증서를 설치하고 리버스 프록시를 사용하고 싶습니다 (3 개 모두가 내부 네트워크에 있으므로 SSL이 필요하지 않습니다). 테스트 목적으로 nginx가 443에서 SSL / 리버스 …
27 nginx 

3
UDP에 대한 텔넷 대응
UDP에 "telnet과 같은"기능을 활성화하는 것이 있습니까? TCP와 UDP의 차이점과 텔넷 자체가 작동하지 않는 이유를 알고 있지만 최종 사용자 관점에서 텔넷 클라이언트와 비슷한 것이 있는지 궁금합니다. 예를 들어 udp-telnet [ip] [sending-port] [receiving-port]는 패킷을 다시 출력했는지 여부를 출력합니다. 이와 같은 도구를 사용하면 UDP 연결을 사용하는 OpenVPN의 방화벽 설정을 테스트하는 데 도움이됩니다.
27 vpn  openvpn  testing  udp 

4
이 Windows 2012 대시 보드 오류를 수정하는 방법 : Google Update Service
새로운 Windows 2012 x64 가상 머신을 설치했습니다. 내가 한 첫 번째 일은 Chrome을 설치하는 것이 었습니다. 대시 보드에 갔을 때 다음과 같은 오류가 발생합니다 (또는 오류처럼 보임). 그래서, 이 오류가 무엇인지 아는 사람이 있습니까? 이 문제를 어떻게 '수정'할 수 있습니까? 감사합니다. 편집 : 수정 사항으로 G-Chrome을 제거하지 마십시오.

6
매우 낮은 KVM 디스크 성능 (qcow2 디스크 파일 + virtio)
KVM 게스트를 설정하는 동안 디스크 성능에 심각한 문제가 있습니다. 간단한 사용하여 dd테스트의 qcow2 이미지 (미러링 된 RAID 어레이)에 상주하는 호스트의 파티션에 걸쳐에서 기록 1백20메가바이트가 / S 내 손님에 이르기까지 쓰기 느끼는 동안, 0.5 3메가바이트에를 / S . 게스트는 몇 개의 CPU와 4G의 RAM으로 구성되었으며 현재 다른 것을 실행하지 않습니다. 현재로서는 …

7
파일 전송을위한 Putty SSH의 GUI 대안이 있습니까?
또는 Amazon EC2 Linux 인스턴스 서버 용 GUI SSH? 두 개의 Linux 가상 서버간에 파일을 전송해야하며 현재 Putty (아마존 권장)가 있습니다. 그러나 나는 서버 / 가상 세계에 익숙하지 않으며 명령에 대한 경험이 없습니다. 나는 기본적으로 폴더를 서버에 복사 / 붙여 넣기 또는 드래그 / 드롭 할 수 있도록 초보자와 같은 …
27 linux  ssh  putty 

11
MySQL은“localhost”를 통해 연결할 수 없으며 127.0.0.1 만 가능합니다
이것은 나에게 다소 신비입니다. MySQL에 연결할 수있는 유일한 방법은 "127.0.0.1"을 통해 호출하는 것입니다. 예를 들어 PHP 연결 스크립트가 localhost와 작동하지 않습니다. Mac OS X Lion, 내장 된 apache2, MySQL, PHP, phpMyAdmin을 실행하고 있습니다. mysqladmin : count 0 debug-check FALSE debug-info TRUE force FALSE compress FALSE character-sets-dir (No default value) default-character-set …
27 php  mysql  localhost 


2
여러 수신자에게 메일을 전달하도록 postfix를 설정할 수 있습니다
다음 접미사 virtual파일이 있습니다. test@domain.com bob@me.com 이것은 모든 이메일을 test@domain.com에 올바르게 전달합니다.bob@me.com 그러나이 이메일도 전달하고 싶습니다 bob2@me.com. 이 변경을 시도했지만 작동하지 않는 것 같습니다. test@domain.com bob@me.com test@domain.com bob2@me.com postfix에 모든 이메일을 여러 수신자에게 전달하도록하려면 어떻게해야합니까?

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.