서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

3
IPTables로 FTP 허용
현재 시나리오에는 다양한 규칙을 허용하지만 어디에서나 ftp에 액세스 할 수 있어야합니다. OS는 Cent 5이며 VSFTPD를 사용하고 있습니다. 구문이 맞지 않는 것 같습니다. 다른 모든 규칙은 올바르게 작동합니다. ## Filter all previous rules *filter ## Loopback address -A INPUT -i lo -j ACCEPT ## Established inbound rule -A INPUT -m state …
26 linux  centos  iptables  ftp 

4
Windows에 PID가 주어지면 명령 행 명령을 어떻게 찾습니까?
데이터베이스에서 현재 실행중인 모든 프로세스의 목록과 프로세스를 시작한 sql 명령을 얻을 수 있습니다. 창문 상자에서 비슷한 일을하고 싶습니다. 프로세스 목록을 얻을 수는 있지만 프로세스를 시작한 명령 줄은 아닙니다. 내 질문은 : Windows에서 PID 가 주어 졌을 때-PID를 실행 한 명령 줄 명령을 어떻게 찾습니까? 가정 : Windows 7 및 동등한 …

2
절대 죽지 않는 프로세스를 죽이는 방법?
문제 SIGTERM이나 SIGKILL로 죽지 않는 Java 프로세스가 있습니다. logstash 2591 1 99 13:22 ? 00:01:46 /usr/bin/java -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -Djava.awt.headless=true -Dfile.encoding=UTF-8 -XX:+HeapDumpOnOutOfMemoryError -Xmx1g -Xms256m -Xss2048k -Djffi.boot.library.path=/usr/share/logstash/vendor/jruby/lib/jni -Xbootclasspath/a:/usr/share/logstash/vendor/jruby/lib/jruby.jar -classpath : -Djruby.home=/usr/share/logstash/vendor/jruby -Djruby.lib=/usr/share/logstash/vendor/jruby/lib -Djruby.script=jruby -Djruby.shell=/bin/sh org.jruby.Main --1.9 /usr/share/logstash/lib/bootstrap/environment.rb logstash/runner.rb --path.settings /etc/logstash 신호가 수신 될 때마다 다시 생성됩니다. Sep 15 13:22:17 …

3
rsync를 사용하여 변경된 파일 만 목록으로 만들 수 있습니까?
bash 스크립트에서 rsync를 사용하여 파일을 몇 대의 서버와 NAS 사이에서 동기화 상태로 유지합니다. 내가 겪었던 한 가지 문제는 rsync 중에 변경된 파일 목록을 생성하는 것입니다. 아이디어는 rsync를 실행할 때 텍스트 파일로 변경된 파일을 메모리의 배열을 더 기대하면서 출력 할 수 있으며 스크립트가 존재하기 전에 변경된 파일 에서만 chown을 실행할 수 …
26 bash  scripting  rsync 

3
Linux 사용자 및 비밀번호를 새 서버로 복사
서버를 통해 새 하드웨어로 마이그레이션하고 있습니다. 시스템의 일부가 재 구축됩니다. 사용자 이름, 비밀번호, 그룹, 파일 소유권 및 파일 권한이 그대로 유지되도록 복사하기 위해 어떤 파일과 디렉토리가 필요합니까? 우분투 12.04 LTS.
26 linux  passwd 

7
CentOS 6이 설치된 Dell PERC H710 Raid Controller의 하드 디스크 상태를 모니터링하는 방법은 무엇입니까?
Raid 5 가 설치된 Raid Controller 카드를 CentOS 6사용하여 Dell 서버를 실행 PERC H710하고 있으며 Raid Controller 뒤의 하드 디스크 오류 / 작동 상태를 모니터링하고 싶습니다. 그런 다음 bash 스크립트를 사용하여 하드 디스크 상태를 모니터링하고 문제가 발생한 경우 경고 이메일을 보낼 수 있어야합니다. LSI MegaRAID SAS명령 도구 (LSI 메가 RAID …

1
Gunicorn 중요한 작업자 시간 초과 오류를 해결하는 방법?
nginx와 gunicorn을 사용하여 두 대의 서버에서 웹 사이트를 호스팅했습니다. 두 서버 모두 동일한 버전의 패키지가 있으며 웹 사이트가 성공적으로 호스팅됩니다. 그러나 내 서버 중 하나에서 gunicorn은 항상 시간 초과되고 오류가 발생합니다. [CRITICAL]Worker Timeout Booting worker with pid Worker cannot boot with pid 그리고이 후에 웹 페이지에 502 Badgateway 오류가 발생합니다. …
26 nginx  gunicorn 

1
Tor를 제외한 모든 트래픽을 어떻게 차단할 수 있습니까?
Linux 시스템에는 Tor 네트워크를 통과하지 않는 한 모든 인바운드 및 아웃 바운드 트래픽을 차단할 수있는 방법이 있습니다. 여기에는 TCP 연결뿐만 아니라 모든 형태의 IP 통신이 포함됩니다. 예를 들어 UDP를 Tor를 통과 할 수 없으므로 UDP를 완전히 차단하고 싶습니다. 이 시스템의 인터넷 사용이 완전히 익명이되기를 원하며 응용 프로그램이 유출되는 것을 원하지 …
26 linux  iptables  tor 

4
로그온 할 필요없이 네트워크 공유를 영구적으로 마운트 하시겠습니까? (윈도우)
Windows 2008 R2 서버 (표준)에서는 특정 사용자가 먼저 컴퓨터에 로그온하지 않고도 네트워크 드라이브를 마운트해야합니다. 유닉스 머신을 NFS통한 마운트 와 같습니다 fstab. 네트워크 드라이브는 BlackArmor (Seagate) 어플라이언스 (Samba를 실행한다고 가정)를 통해 공유됩니다. 필요한 경우 어플라이언스는 도메인의 구성원 일 수 있습니다. 지금까지 나는 그것을 실행 한 곳에서 Edit Group Policy-> Configuration-> Windows-> …

2
iptables 및 여러 포트
이것은 나를 위해 작동하지 않습니다 : # iptables -A INPUT -p tcp --dports 110,143,993,995 -j ACCEPT iptables v1.4.7: unknown option `--dports' Try `iptables -h' or 'iptables --help' for more information. 그러나 매뉴얼 페이지에는 옵션이 있습니다 --dports... 어떤 아이디어가 있습니까?

3
Nginx-특정 IP를 가진 사용자를 특수 페이지로 리디렉션하는 방법
나는 상당히 큰 이미지 갤러리를 운영하고 있으며 매일 웹 복사기를 사용하여 전체 사이트를 다운로드하여 엄청난 양의 트래픽을 발생시키는 5 명의 방문자가 있습니다. 해당 방문자는 고정 IP를 사용합니다. 내가 달성하고자하는 것은 5 명의 IP가 사이트를 방문하자마자 특정 페이지로 리디렉션되는 것입니다 (이것은 왜 문제가 있는지 설명합니다). 다른 모든 방문자는 사이트를 정상적으로 탐색 …
26 nginx  ip  redirect 

4
“crontab -e”파일을 백업하는 방법?
완전한 서버 백업을 하고 싶습니다 . 웹 응용 프로그램의 모든 html / php 파일과 mysql 데이터베이스를 복사하여 .tar.gz 파일에 저장하는 백업 스크립트가 이미 있습니다. 해당 백업에 crontab 파일을 추가하려면 어떻게해야합니까? crontab을 저장할 때마다 / tmp 폴더로 이동합니다. 바로 그 폴더를 확인하면 비어 있습니다.

5
Xvfb 용 yum-yum 저장소를 통해 Xvfb를 설치 하시겠습니까?
yum을 사용하여 RHEL 6.2 시스템에 Xvfb를 설치하려고합니다. 그러나 내가 찾은 모든 도움은 다음과 같이 입력합니다. yum install Xvfb 또는... yum install xorg-x11-server-Xvfb 올바른 리포지토리를 구성한 경우 제대로 작동하지만 확실하지 않습니다. 오류가 발생하기 때문에 : No package Xvfb available. 이 시스템에 대한 유일한 repos는 redhat.repo와 rhel-source.repo입니다. 어떤 저장소에 Xvfb 패키지가 포함되어 …

3
사이트 전체에서 기본 인증을 사용하도록 설정하고 하위 페이지에 대해 인증을 사용하지 않습니까?
비교적 간단한 구성이 있습니다. upstream appserver-1 { server unix:/var/www/example.com/app/tmp/gunicorn.sock fail_timeout=0; } server { listen 80; server_name example.com; location / { proxy_pass http://appserver-1; proxy_redirect off; proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; auth_basic "Restricted"; auth_basic_user_file /path/to/htpasswd; } location /api/ { auth_basic off; } } /api/하위 트리를 제외하고 전체 웹 …


당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.