서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
Docker 볼륨을 glusterfs에 저장하는 것이 좋습니다?
현재 일부 서버 및 앱을 coreOS 환경으로 마이그레이션 하려고 합니다. 여기서 볼 수있는 문제 중 하나는 coreOS가 컨테이너를 새 시스템으로 옮길 때 Docker 볼륨을 처리하지 않으므로 영구 데이터를 관리하는 것입니다. 일부 연구 결과 , 모든 문제를 해결할 수있는 클러스터 파일 시스템 인 glusterFS 를 발견 했습니다 . 내 현재 아이디어는 …

7
종료 한 후 사람에게서 읽은 내용을 어떻게 유지할 수 있습니까?
그래서 우리 man whatever는 whatever명령 과 관련된 사용법과 다른 정보를 얻는 데 사용합니다. 정보 의 관련 섹션이 발견되면 man화면에 정보가 남은 상태에서 명령 을 종료하고 싶습니다 . 위의 심판과 함께 다음 명령을 입력 할 수 있습니다. 그러나 man명령은 전체 화면을 종료하여와 유사한 이전 화면을 복구합니다 vim. 이것을 달성 할 수있는 …
24 terminal  man 

2
sshd가 특정 포트에서만 암호를 허용하도록 할 수 있습니까?
sshd여러 Port지시문 을 사용하여 여러 포트에서 수신 대기하는 것이 가능하다는 것을 알고 있습니다 . 그러나 포트 당 설정을 독립적으로 조정할 수 있습니까? 특히, 한 포트가 암호 인증을 허용하지만 다른 포트가 허용하지 않도록 할 수 있습니까?
24 ssh 

3
신비한 중국 트래픽 : HTTP 요청에 사용 된 DNS 서버를 어떻게 알 수 있습니까?
지난 주에 저는 광범위한 중국 IP 주소에서 엄청난 양의 트래픽을 받고있었습니다. 이 트래픽은 정상적인 사람에 의한 것으로 보이며 HTTP 요청에 따르면 다음과 같이 생각합니다. 페이스 북 해적 만 다양한 BitTorrent 트래커, 포르노 사이트 사람들이 VPN을 사용하는 것처럼 들립니다. 또는 만리장성을 화나게하는 것들. 사용자 에이전트에는 웹 브라우저, Android, iOS, FBiOSSDK, Bittorrent가 …
24 nginx  vpn  china 

3
Amazon ECS (Docker) : 컨테이너를 특정 IP 주소에 바인딩
Amazon ECS (Docker의 재 패키징)를 사용하고 있는데 ECS가 제공하지 않는 Docker 기능이 하나 있습니다. 즉, 인스턴스에서 여러 컨테이너를 실행하고 IP 주소 1로 들어오는 요청을 컨테이너 1에 매핑하고 IP 주소 2로 오는 요청을 컨테이너 2에 매핑하는 등을 원합니다. Docker에서 컨테이너를 특정 IP 주소에 바인딩하는 것은 다음을 통해 수행됩니다. docker run -p …

1
Linux에서 비 차단 코어 덤프?
Linux에서 실행중인 프로세스의 비 침입 코어 덤프를 수행하는 방법을 찾고 있습니다. gdb 's에 익숙 gcore하지만 gdb프로세스에 연결되어 있고 디버깅을 위해 중지 된 경우에만 실행할 수 있습니다 . 실행이 중단되는 데 몇 초 또는 몇 분이 걸릴 수있는 큰 코어 덤프의 경우. 비 차단 대안이 있습니까? Linux는 COW (Copy-On-Write) 메모리를 지원하며이를 …
24 linux  dump  gdb 

1
nginx가 사용 된 SSL / TLS 프로토콜 및 암호 그룹을 기록하도록하려면 어떻게해야합니까?
내 목표는 내 nginx에 연결하는 클라이언트를 위해 적절한 보안을 유지하는 것입니다. nginx 설치에서 TLS를 올바르게 구성하기 위해 Mozilla 가이드를 따르고 있지만 실제로 사용되는 실제 프로토콜 / 암호 슈트에 대한 개요는 없습니다. 내가 지금 가진 것 : server { listen 443; ssl on; ssl_certificate /path/to/signed_cert_plus_intermediates; ssl_certificate_key /path/to/private_key; ssl_dhparam /path/to/dhparam.pem; ssl_session_timeout 5m; …
24 nginx  security  logging  tls  ssl 

2
Linux 시스템에서 UID / GID를 동기화하면 어떤 이점이 있습니까?
다른 Linux 시스템에서 UID / GID를 동기화하는 방법에 대해 자세히 알아보기 전에 실제로 어떤 이점이 있는지 알고 싶습니다. 소유권이 "자연스럽게"유지되므로 파일 동기화가 비교적 쉽다는 것을 알고 있습니다. 그러나 이것은 전송 서비스에 따라 다르게 달성 될 수도있다. 일관된 UID / GID의 이점이있는 다른 것이 있습니까?

2
여러 PostgreSQL 서버가 설치되어 있습니다. 이전 서버에서 자동 부팅을 비활성화하려면 어떻게합니까?
Oracle VirtualBox에서 Ubuntu 12.04를 실행 중입니다. 몇 달 전에 내 컴퓨터에 PostgreSQL 서버 버전 9.1을 설치했습니다. 최근에 PostgreSQL 서버 9.3이 JSON 데이터 유형을 지원한다는 것을 알았으므로 업그레이드하기로 결정했습니다. 여기 지침에 따라 9.3으로 업그레이드했습니다. https://wiki.postgresql.org/wiki/Apt wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add - sudo apt-get update sudo apt-get upgrade …

7
/etc/nginx/nginx.conf에서 getpwnam (“www”)이 실패했습니다
nginx.conf 샘플을 우분투 12.04 상자에 복사했습니다 (다른 conf 파일을 어디에 둘 지 모르겠습니다. nginx noob입니다). nginx를 시작하려고하면 다음 오류가 발생합니다. abe-lens-laptop@abe:/etc$ sudo service nginx start Starting nginx: nginx: [emerg] getpwnam("www") failed in /etc/nginx/nginx.conf:1 nginx: configuration file /etc/nginx/nginx.conf test failed 이 오류는 무엇을 의미합니까? 어떻게 고칠 수 있습니까? 이 게시물을 찾았지만 …

3
SSD 대 HDD의 신뢰성 (큰 온도 변화에 대한)
야외 환경에서 데이터를 기록해야하는 응용 프로그램이 있는데, 추운 환경 (-20도 이하)과 주변 환경 (+50도)에있을 때 SSD와 HDD의 안정성에 관심이 있습니다. 직감으로 인해 고온을 제외하고 SSD가 더 안정적이라고 믿게되었습니다. 에어컨 인클로저는 옵션이 아닙니다. 이 상황에서 디스크 안정성에 대한 정보가 있습니까?
24 ssd  hard-drive 

2
관리자에 대해 RDP 액세스를 비활성화하는 방법
이 질문은 서버 결함에 대해 답변 할 수 있기 때문에 수퍼 유저로부터 마이그레이션 되었습니다. 5 년 전에 마이그레이션 되었습니다 . RDP를 통해 서버에 직접 액세스하려면 도메인 관리자 계정을 허용하지 않아야합니다. 우리의 정책은 일반 사용자로 로그온 한 다음 관리자 권한으로 실행 기능을 사용하는 것입니다. 우리는 이것을 어떻게 설정할 수 있습니까? 해당 …

1
서버를 실행하는 Docker 컨테이너가 포트가 iptables에 의해 차단되었지만 포트를 외부 세계에 노출시키는 이유는 무엇입니까?
Docker 컨테이너 내에서 MySQL을 실행하는 데 문제가 있습니다. 내 테스트 이미지는 다음 Dockerfile에서 빌드됩니다. # See: https://index.docker.io/u/brice/mysql/ FROM ubuntu:12.10 MAINTAINER Joni Kahara <joni.kahara@async.fi> # Because docker replaces /sbin/init: https://github.com/dotcloud/docker/issues/1024 RUN dpkg-divert --local --rename --add /sbin/initctl RUN ln -s /bin/true /sbin/initctl RUN apt-get update RUN apt-get upgrade -y RUN apt-get -y …
24 iptables  docker 

2
SPF 사양에서 10-DNS 조회 제한이 일반적으로 적용됩니까?
SPF 사양은 전자 메일 수신자가 발신자에게 허용 된 모든 IP를 수집하기 위해 10 개 이상의 DNS 조회를 수행하지 않아야한다고 지정합니다. 따라서 SPF 레코드가 있고이 include:foo.com include:bar.com include:baz.com3 개의 도메인에 각각 3 개의 include항목 이있는 SPF 레코드가있는 경우 이제 최대 3 + 3 + 3 + 3 = 12 DNS 조회입니다. …
24 spam  spf  email 

8
Linux 사용자를 자신이 소유 한 파일로 제한
여러 (~ 100) 고객이 단일 서버에 쉘 액세스 할 수있는 공유 웹 호스팅 회사의 서버 설정을 상상해보십시오. 많은 웹 "소프트웨어"는 파일 0777 을 chmod 할 것을 권장합니다 . 이 자습서를 따르지 않고 고객에게 파일을 열어 다른 고객에게 현명하게 신경을 씁니다. (필자 cmod 0777는 자신 을 불필요하게 사용하고 있지 않습니다 !) …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.