서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
Nginx 구성 : 다른 포트에 대한 프론트 엔드 리버스 프록시
포트 5010에서 80이 아닌 요청을 제공하는 작은 웹 서버가 있습니다. nginx를 프런트 엔드 프록시로 사용하여 포트 80에서 요청을 수신 한 다음 해당 요청을 포트 5010에서 처리하도록하고 싶습니다. nginx를 성공적으로 설치했으며 Ubuntu Karmic에서 원활하게 실행됩니다. 그러나 기본 nginx.conf를 재구성하려는 시도는 성공하지 못했습니다. 서버 지시문에 포트 5010의 청취 인수를 포함 시키려고했습니다. 또한 …

4
MySQL이 64GB RAM을 효과적으로 활용할 수 있습니까?
약 5 천만 개의 행이 있고 인덱스 크기가 4GB (테이블 크기가 약 6GB) 인 테이블을 쿼리하면 데이터베이스 서버가 메모리를 스왑하고 속도가 크게 저하되는 문제가 발생했습니다. 나는 이것이 임시 테이블 크기를 초과하고 디스크로 교체되는 것과 관련이 있다고 확신합니다. 데이터베이스 서버를 32GB RAM에서 64GB RAM으로 업그레이드 한 경우 MySQL 데이터베이스가이 추가 메모리를 …

2
Windows 7에서 재귀 적으로 권한 설정
최근에 Windows 7을 설치했으며 내 홈 네트워크의 모든 사람이 액세스 할 수 있도록 네트워크 공유를 설정하려고합니다. XP에 익숙하기 때문에 폴더를 공유하고 7의 권한을 설정하는 새로운 방법에 익숙해지는 데 시간이 조금 걸립니다. 지금까지 나는 할 수 있었다 : 네트워크에서 디렉토리를 공유 사용자가 실제로 내용을 볼 수 있도록 디렉토리에 대한 권한 변경 …
22 windows-7 

3
Windows 7에서 OpenVPN을 사용하여 여러 VPN을 동시에 연결하는 방법은 무엇입니까?
나는 대부분의 시간을 집에서 퇴근으로 일합니다. SSH를 통해 다른 서버에 액세스하려면 OpenVPN을 사용해야합니다. 한 번에 모두 (3 개, 4 개) 연결하고 싶습니다. 항상 전환 할 필요는 없습니다. 내 설정은 Windows 7 및 NIC가 하나만있는 PC입니다. 여러 VPN을 한 번에 연결할 수 있습니까 (그렇다면 어떻게됩니까?) (어떤 종류의 가상 네트워크 장치 일 …


5
console-kit-daemon-중지 할 수 있습니까?
Ubuntu 9.04 서버 설치에 60 개의 콘솔 키트 데몬 인스턴스가 있습니다. 이러한 프로세스를 중지하거나 중지하는 것이 안전합니까? 그들은 각각 RAM의 약 20 %를 차지하는 것 같습니다 (htop 참조).
22 ubuntu  daemon 

6
네트워크 오류 : 사용 가능한 버퍼 공간이 없습니다.
어느 정도 시간이 지나면 Windows XP SP3 컴퓨터 중 하나가 더 이상 새로운 TCP / IP 연결을 열지 않습니다. 퍼티는 Network Error: no buffer space availableIE는 새로운 연결을 열지 않지만 네트워크 드라이브 매핑은 여전히 ​​작동하지만 새로운 연결도 구축 할 수 있다고 말한다. netstat는 평소보다 더 열린 연결을 표시하지 않으므로 ping …

4
ExecutionPolicy 설정 방법 : 레지스트리 키에 대한 액세스가 거부되었습니다.
Windows Server 2008을 관리자로 실행하고 있으며 다음과 같이 PowerShell v2에 대해 ExecutionPolicy를 Remotesigned로 설정하려고했습니다. Set-ExecutionPolicy RemoteSigned 하지만이 오류가 발생했습니다. Set-ExecutionPolicy : Access to the registry key 'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\ShellIds\Microsoft .PowerShell' is denied. At line:1 char:20 + Set-ExecutionPolicy <<<< RemoteSigned + CategoryInfo : NotSpecified: (:) [Set-ExecutionPolicy], UnauthorizedAccessException + FullyQualifiedErrorId : System.UnauthorizedAccessException,Microsoft.PowerShell.Commands.SetExecutionPolicyComma nd 이 …

6
헤드리스 Linux 용 디스크 사용량 트리 맵 소프트웨어
Windows 용 WinDirStat 및 KDE / Linux 용 KDirStat와 같은 트리 맵을 사용하여 사용 된 디스크 공간을 표시 할 수있는 일부 프로그램이 있습니다 . 비슷한 것을 찾고 있지만 헤드리스 Linux 상자를 찾고 있습니다. (예 : 서버에서 콘솔 데이터 수집 프로그램을 실행 한 후 GUI 환경에서 그래픽 프로그램으로 파일을로드하십시오.) 또는 SSH …

1
OpenSSL : 타사 인증서를 확인하기 위해 OCSP 서버를 설정하는 방법은 무엇입니까?
이 질문은 서버 오류에 대해 답변 할 수 있기 때문에 수퍼 유저로부터 마이그레이션 되었습니다. 9 년 전에 이주했습니다 . CMTS 장치의 인증서 해지 기능을 테스트하고 있습니다. 이를 위해서는 OCSP 응답자를 설정해야합니다. 테스트에만 사용되므로 OpenSSL에서 제공하는 최소 구현으로 충분하다고 가정합니다. 케이블 모뎀에서 인증서를 추출하여 내 PC로 복사하여 PEM 형식으로 변환했습니다. 이제 …
22 openssl  ocsp 

9
동일한 파일 목록을 사용하여 여러 대상으로 재 동기화합니까?
rsync가 하나의 디렉토리를 여러 원격 대상으로 한 번에 또는 병렬로 복사 할 수 있는지 궁금합니다. (필요하지는 않지만 유용합니다.) 일반적으로 다음과 같은 것이 정상적으로 작동합니다. $ rsync -Pav /junk user@host1:/backup $ rsync -Pav /junk user@host2:/backup $ rsync -Pav /junk user@host3:/backup 그리고 이것이 유일한 옵션이라면, 그것을 사용할 것입니다. 그러나 / junk는 상당히 …
22 backup  rsync 

3
Postfix를 사용하여 발신 SMTP에 대한 암호화 강제
누구든지 Postfix에게 발신 메일을 암호화하도록 지시하는 방법을 알고 있습니까? 수신시 암호화를 사용하도록 구성했지만 발신 메일로는 암호화를 수행 할 수 없습니다. 이것은 내 main.cf파일입니다. smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination smtpd_sasl_auth_enable = yes smtpd_sasl_path = smtpd transport_maps = hash:/etc/postfix/transport # tls config smtp_use_tls = yes smtpd_use_tls = yes smtp_tls_note_starttls_offer = yes smtpd_tls_key_file …
22 smtp  postfix 

6
Linux 디스크에서 읽을 수없는 단일 블록을 쉽게 복구하려면 어떻게합니까?
Linux 시스템이 syslog에 SMART 오류를 발생시키기 시작했습니다. 나는 그것을 추적하고 문제가 디스크의 단일 블록이라고 생각합니다. 디스크가 한 블록을 재 할당하도록하려면 어떻게해야합니까? 프로세스에서 어떤 파일이 손상되었는지 알고 싶습니다. (디스크에서 하나의 블록이 고장 나면 다른 블록이 뒤따를 수 있다는 것을 알고 있습니다. 백업이 잘 진행 중이며이 디스크를 계속 작동 시키려고합니다.) 웹을 검색하면 …

11
포트가 열려 있는지 여부를 어떻게 알 수 있습니까?
Windows 7 컴퓨터에 Apache 서버를 설치했습니다. 브라우저의 주소 표시 줄에 http : // localhost / 를 입력하여 기본 index.php를 표시 할 수있었습니다 . 그러나 여전히 내 컴퓨터의 IP 주소를 입력해도 (같은 컴퓨터에서 로컬로 또는 전역으로 인터넷에 연결된 다른 컴퓨터에서) IP 주소를 입력해도이 페이지를 볼 수 없습니다. 포트 80을 열어야한다는 말을 …

3
IIS7에서 특정 IP 및 IP 범위를 어떻게 차단합니까?
Windows 2008 및 IIS7을 실행하는 서버에서 호스팅 한 모든 사이트에서 다양한 IP 주소를 차단하려고합니다. IIS7 관리자의 기능보기 ( http://technet.microsoft.com/en-us )의 "IPv4 주소 및 도메인 이름 거부 규칙 (IIS 7)"에서 거부 규칙을 사용하여이를 수행하는 방법에 대한 다양한 정보를 찾았습니다. /library/cc733090(WS.10).aspx )이지만 그와 비슷한 아이콘이 없습니다. IIS 관리자에서 해당 UI를 어떻게 얻습니까?

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.