서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

3
CentOS 7 방화벽 구성
CentOS 6에서는 setup명령 행에서 입력 할 수 있으며 도구 세트 중 하나가 표시됩니다 Firewall configuration. 목록이 더 이상 Firewall configuration옵션으로 포함되지 않는 것을 제외하고 CentOS 7에서 여전히이 작업을 수행 할 수 있습니다 . 아무도 내가 지금 어디에서 찾을 수 있고 왜 옮겨 졌는지 알고 있습니까? 여기에서 HTTP와 를 통해 들어오는 …
22 centos  firewall  http  https 

2
Amazon EC2 사용자는 sudo 권한을 얻는 방법
기본 Amazon AMI Linux 이미지가 기본 ec2-user계정에 대한 권한을 설정하는 위치를 찾고 있습니다. 이 계정으로 로그인 한 후 sudo를 성공적으로 사용할 수 있습니다. visudo를 실행하여 열린 sudoers 파일을 통해 확인하면 (다른 옵션은 사용하지 않음) root ALL ALL에 대한 몇 가지 기본 설정 및 권한이 표시됩니다 그렇다면 ... ec2-user에 대한 권한은 …
22 amazon-ec2  sudo 

3
SSH를 사용한 인증 순서
ssh를 통해 로그인하면 -vssh가 다음과 같은 방식으로 인증되고 있음을 알 수 있습니다 debug1: Authentications that can continue: publickey,gssapi-with-mic,password,hostbased 순서를 변경하고 싶습니다 ... 어떻게 생각하십니까? 내 큰 문제는 계정이 잠긴 사용자가 여전히 공개 키를 통해 로그인 할 수 있다는 것입니다. "ssh-locked"그룹에 사용자를 추가하여 sshing에서 해당 그룹을 거부 할 수 있음을 발견했지만 …

5
rsyslogd가 짧은 호스트 이름 대신 서버의 FQDN을 기록하도록하려면 어떻게해야합니까?
우분투 10.04 LTS에서 주식 rsyslogd (4.2.0-2ubuntu8.1)를 사용하여 간단한 중앙 집중식 syslog 서버를 구현하려고합니다. 이 시점에서 모든 클라이언트 노드가 중앙 서버에 로그를 전송하지만 클라이언트는 FQDN 대신 짧은 호스트 이름이 포함 된 로그 메시지를 전송합니다. 우분투 rsyslogd 맨 페이지에 따라 : 원격 호스트가 호스트와 동일한 도메인에 있고 rsyslogd가 실행 중이면 전체 fqdn …

5
cron.daily가 리눅스에서 실행되는 시간을 변경하는 방법
이 질문은 서버 오류에서 응답 할 수 있기 때문에 스택 오버플 로 에서 마이그레이션 되었습니다. 7 년 전에 이주했습니다 . cron.daily에는 매일 아침 특정 시간에 실행되는 스크립트가 있습니다. 실행 시간을 변경해야합니다. cron.daily가 스크립트를 실행하는 시간을 어떻게 변경합니까?
22 linux  cron  redhat 

6
로그 파일을 일종의 순환 버퍼로 바꾸기
여러분, 로그 파일을 순환 버퍼로 작동시키는 * nix 솔루션이 있습니까? 예를 들어, 최대 1Gb의 데이터를 저장하고 한도에 도달하면 이전 항목을 삭제하기 위해 로그 파일을 원합니다. 전혀 가능합니까? 로그 파일을 일종의 특수 장치로 바꿔야한다고 생각합니다 ... 추신 : 나는 기타 회전 도구를 알고 있지만 이것이 필요한 것은 아닙니다. 로그 회전에는 많은 …
22 logging 

5
CentOS 7에 최신 버전의 Git 설치
CentOS 7 서버에서 Git "Push to Deploy"를 활성화하고 싶습니다. 현재 yum을 통해서만 Git 1.8.3.1을 얻을 수 있습니다. 최신 버전이 필요합니다. 소스에서 빌드해야합니까, 아니면 사용할 수있는 저장소가 있습니까? EPEL 과 elrepo를 이미 추가 했지만 yum은 여전히 ​​Git 1.8.3.1을 제공합니다.
22 git  centos7 

3
NGINX에서 TLS 1.0 비활성화
우리 사이트의 리버스 프록시 역할을하는 NGINX가 있으며 매우 잘 작동합니다. 필요에 SSL이 사이트를 위해 나는 다음 raymii.org을 SSLLabs 가능한 점수의 확인 강한로 가질 수 있도록. 사이트 중 하나가 PCI DSS를 준수해야하지만 TLS 1.0을 사용하도록 설정했기 때문에 최신 TrustWave 스캔을 기반으로 실패했습니다. nginx.conf의 http 수준에는 다음이 있습니다. ssl_protocols TLSv1 TLSv1.1 TLSv1.2; …
22 nginx  tls  pci-dss 


6
Nginx 설정 server_names_hash_max_size 및 server_names_hash_bucket_size
우리는 Nginx를 자신의 웹 사이트를 제공하는 서비스에서 Apache의 리버스 프록시로 사용하고 있습니다. 계정 생성시 시스템은 포트 80에 대한 항목과 443에 대한 항목 두 개를 사용하여 도메인에 대한 새 nginx conf 파일을 생성합니다. 30 개 정도의 도메인마다 오류가 발생합니다. Restarting nginx: nginx: [emerg] could not build the server_names_hash, you should increase …
22 nginx 

2
다른 네트워크에서 MX를 선언하는 것은 나쁜 습관입니까?
거래 서비스 이메일을 전송하기 위해 타사 서비스 제공 업체를 사용하고 있습니다. 최근에 특정 수신 도메인의 실패율이 증가한 것으로 나타났습니다. "498 No MX for example.com"오류와 함께 전송이 실패합니다. 주어진 지연 후에 전송이 재 시도되고 일반적으로 몇 번의 재시도 후에 성공합니다. 그러나 때로는 재시도 한계를 초과하여 영구적으로 삭제됩니다. 제공자의 지원팀에 연락했으며 이는 …

2
IT는 최대 절전 모드로 부팅 로더를 지 웁니다
회사에서 발행 한 랩톱은 Windows 7 Professional을 실행하는 Dell Latitude E7450입니다. 시스템을 최대 절전 모드로 전환하면 부팅시 빈 화면이 표시되고 입력에 응답하지 않습니다. 후속 재부팅으로 다른 결과가 나오지 않습니다. IT 부서에서 Windows 최대 절전 모드가 Dell에 문제가 있으며 최대 절전 모드로 전환하면 부팅 파티션이 손상된다고 말합니다. 그들은 부트 로더를 재 …

2
작은 파일 시스템에서 매우 이상한 파일 크기 (600 PB 이상)
크기가 약 200GB 인 XFS 파일 시스템에 파일이 있습니다. KVM 기반 가상 머신의 가상 디스크를 포함하는 QCOW2 이미지입니다. 무언가 잘못되었습니다 (아마도 qemu-kvm의 결함 일지 모르겠지만 확실하지 않습니다). 가상 컴퓨터가 추락하여 이제 다음과 같은 파일이 생겼습니다. 191090708 -rwxr--r--. 1 root root 737571587400425984 Oct 10 10:03 973d10e0-a5e3-4a59-9f98-4b9b9f072ade 따라서 여전히 191090708 블록을 차지하지만 …

7
실행중인 Linode 서버를 백업하는 방법은 무엇입니까?
우리는 데비안 서버에서 모든 것을 백업하고 싶습니다. 데비안 서버는 종료하지 않고 세계 반대편 (리 노드에서 호스팅)에서 원격으로 실행됩니다. 이 시스템은 간단한 nginx 설정으로 쉘, 이메일, XMPP / prosody 및 웹을 실행합니다. 우리는 안전을 위해 그와 관련된 파일을 백업하고 싶습니다. 예를 들어, 사용자가 홈 디렉토리에 저장 한 파일입니다. 매번 / etc …


당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.