서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

1
기본 장치보다 DM 다중 경로 장치의 대기 시간이 더 높은 이유는 무엇입니까?
우리는 Hitachi HNAS 3080 스토리지에 연결된 CentOS 6.4 기반 서버를 가지고 있으며 커널이 파일 시스템을 읽기 전용 모드로 다시 마운트하는 것을 관찰했습니다 : 5 월 16 일 07:31:03 GNS3-SRV-CMP-001 커널 : [1259725.675814] EXT3-fs (dm-1) : 오류 : 읽기 전용 파일 시스템 마운트 이것은 여러 I / O 오류와 장치의 모든 …

3
/ etc / shadow에서 비밀번호를 암호화하지 않는 useradd
vsftpd의 새 FTP 사용자를 만들려고 할 때이 문제가 발생했습니다. 다음 명령으로 새 사용자를 생성하고 FileZilla로 로그인을 시도하면 "잘못된 비밀번호"오류가 발생합니다. useradd f -p pass -d /home/f -s /bin/false 이 작업을 수행 한 후 / etc / shadow 에 f:pass:1111:0:99:2::: 다음 명령을 실행하고 동일한 패스 패스를 제공하면 passwd f / etc …

3
NFS 쓰기 성능 저하
10Gbit 이더넷으로 연결된 두 대의 컴퓨터가 있습니다. 그중 하나는 NFS 서버이고 다른 하나는 NF 클라이언트입니다. TCP를 통한 네트워크 속도 테스트 iperf는 양방향에서 ~ 9.8Gbit / s 처리량 을 보여 주므로 네트워크는 정상입니다. NFS 서버의 디스크 성능 테스트 : dd if=/dev/zero of=/mnt/test/rnd2 count=1000000 결과는 ~ 150 MBytes / s이므로 디스크 쓰기에 …

3
access.log 대신 access.log.1에 nginx 로깅을하면 logrotate가 실패합니까?
nginx 인스턴스가 /var/log/nginx/access.log에 대한 액세스 및 /var/log/nginx/errors.log에 대한 오류를 기록하도록 설정되어 있지만 매주 logrotate가 실행되면 파일이 * .log.1 및 새 * .log 파일이 작성되지만 nginx는 새 .log 파일 대신 log.1 파일에 계속 로그합니다 (아무 것도 지워지지 않음). 내가 이것을 처음 발견했을 때, 로그 교체 이후 3 주가 지났고 로그가 커지고있었습니다. …

1
다른 장치와 함께 시스템 장치를 시작하고 중지하는 방법은 무엇입니까?
CoreOS를 사용하여 시스템 단위를 플릿으로 예약합니다. 나는 두 단위가 ( firehose.service그리고 firehose-announce.service내가 얻을 노력하고 있어요. firehose-announce.service시작과 함께 중지 firehose.service여기에 대한 유닛 파일입니다. firehose-announce.service: [Unit] Description=Firehose etcd announcer BindsTo=firehose@%i.service After=firehose@%i.service Requires=firehose@%i.service [Service] EnvironmentFile=/etc/environment TimeoutStartSec=30s ExecStartPre=/bin/sh -c 'sleep 1' ExecStart=/bin/sh -c "port=$(docker inspect -f '{{range $i, $e := .NetworkSettings.Ports }}{{$p := index …
20 systemd  coreos 

3
Ubuntu 14.04.1에서 작동하는 공개 키 (암호 없음) + Google 인증기로 SSH를 가져 오려고합니다.
Ubuntu 14.04.1 (OpenSSH 6.6 및 libpam-google-authenticator 20130529-2 사용)을 사용하고 있습니다. 공개 키가 인증없이 (암호없이) SSH 로그인을 설정하려고하는데 사용자에게 Google OTP의 코드를 입력하라는 메시지가 표시됩니다. 다음 안내에 따라 Google Auth 프롬프트와 함께 비밀번호 프롬프트를 받았습니다. https://scottlinux.com/2013/06/02/use-google-authenticator-for-two-factor-ssh-authentication-in-linux/ http://www.howtogeek.com/121650/how-to-secure-ssh-with-google-authenticators-two-factor-authentication/ https://wiki.archlinux.org/index.php/Google_Authenticator 및 https://wiki.archlinux.org/index.php/SSH_keys#Two-factor_authentication_and_public_keys https://www.digitalocean.com/community/tutorials/how-to-protect-ssh-with-two-factor-authentication 나는 패키지를 설치 한 내 편집 한 /etc/ssh/sshd_config및 /etc/pam.d/ssh파일 에서 …

4
거대한 환경에서 사용할 수있는 IPtables 관리
한 지점에서 iptables를 관리하고 로컬 서버에서 무언가를 편집 할 수있는 가장 좋은 방법은 무엇입니까? 모든 서버에 중앙 집중식으로 규칙을 추가해야하지만 고유 한 규칙 세트를 가져야하는 특정 요구 사항이있는 특정 서버가 있습니다. 나는 여러 개의 include를 가진 bash 스크립트에 대해 생각했다. 좋은 접근입니까? 아니면 더 좋은 것이 있습니까? 특정 호스트간에 차이가 …
20 iptables  ansible 


4
중간 SSL 인증서 받기
하위 도메인 인증서에 서명하기 위해 중간 인증서를 구매할 수 있습니까? 브라우저에서 인식해야하며 와일드 카드 인증서를 사용할 수 없습니다. 검색은 지금까지 아무것도 나타나지 않았습니다. 그런 인증서를 발행 한 사람이 있습니까?
20 ssl 

8
Apache Tomcat에서 SSLv3 지원을 비활성화하려면 어떻게합니까?
TLSv1 만 사용하도록 Apache Tomcat 서버를 재구성하려고합니다. 그러나 여전히 특정 브라우저를 사용하여 SSLv3으로 폴백합니다. <connector> 태그를 다음 설정으로 설정했습니다. <Connector ... enableLookups="true" disableUploadTimeout="true" acceptCount="100" maxThreads="200" scheme="https" secure="true" SSLEnabled="true" clientAuth="false" sslProtocol="TLS" ciphers="TLS_RSA_WITH_AES_128_CBC_SHA, TLS_DHE_RSA_WITH_AES_128_CBC_SHA, TLS_DHE_DSS_WITH_AES_128_CBC_SHA" sslEnabledProtocols="TLSv1" /> 구성 설정이 누락되었거나 존재하지 않아야 할 내용이 있습니까?

2
GELF TCP 12201 포트를 통해 graylog2에 에코 메시지 보내기
시설의 % {@ type}이 (가) 현재인지 테스트하기 위해 echo를 통해 graylog2 서버에 메시지를 보내야하지만 GELF 지원의 에코가 graylog2 서버에 도착하지 않는 경우. graylog2를 다시 시작하면 시작에 대한 메시지가 graylog2 서버에 도착합니다. 에코 메시지의 예 : echo '{"version": "1.1","host":"example.org","short_message":"A short message that helps you identify what is going on","full_message":"Backtrace here\n\nmore stuff","level":1,"_user_id":9001,"_some_info":"foo","_some_env_var":"bar"}' …
20 netcat  echo  graylog 

8
ssh는 더 이상 ~ / .ssh / config를 사용하지 않습니다
내가 할 수있는 것은 ssh 수 없습니다. 약간의 파기 후에 나는 내 홈 디렉토리에서 ssh 구성을 읽지 않는다는 것을 알았습니다. $ ssh -xvvv server OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011 debug1: Reading configuration data /etc/ssh_config (...) 모든 것이 작동하는 친구의 동일한 컴퓨터에서 다음과 같이 보입니다. $ ssh -xvvv server OpenSSH_6.2p2, …
20 ssh 

4
소스 코드 라인에 커널 스택 추적
아래와 같이 커널 스택 추적이 주어지면 문제가 발생한 특정 코드 줄을 어떻게 결정합니까? kernel: [<ffffffff80009a14>] __link_path_walk+0x173/0xfb9 kernel: [<ffffffff8002cbec>] mntput_no_expire+0x19/0x89 kernel: [<ffffffff8000eb94>] link_path_walk+0xa6/0xb2 kernel: [<ffffffff80063c4f>] __mutex_lock_slowpath+0x60/0x9b kernel: [<ffffffff800238de>] __path_lookup_intent_open+0x56/0x97 kernel: [<ffffffff80063c99>] .text.lock.mutex+0xf/0x14 kernel: [<ffffffff8001b222>] open_namei+0xea/0x712 kernel: [<ffffffff8006723e>] do_page_fault+0x4fe/0x874 kernel: [<ffffffff80027660>] do_filp_open+0x1c/0x38 kernel: [<ffffffff8001a061>] do_sys_open+0x44/0xbe kernel: [<ffffffff8005d28d>] tracesys+0xd5/0xe0 함수 호출을 찾는 데 …

4
새로운 환경을보다 쉽게 ​​설정하기 위해 id_rsa.pub를 게시 하시겠습니까?
새로운 시스템과 환경에서 비밀번호없는 SSH를 쉽게 설정하기 위해 id_rsa.pub파일 (키 쌍의 공개 절반 만)을 웹 어딘가에 게시 할 수없는 이유가 있습니까? 예를 들어 도트 파일 GitHub 리포지토리에서. 나는 알고있다 : id_rsa파일합니다 (키 쌍의 개인 절반은) 신중하게 보호되어야하며, 키 쌍은 암호로 보호해야합니다 그러나 내 검색에서 이것이 허용되거나 권장된다는 명시적인 조언을 얻지 …

6
Linux의 ZFS에서 arc_max 설정이 적용되지 않는 이유는 무엇입니까?
Ubuntu 12.04 의 PPA 에서 ZoL 0.6.2를 실행 하고 있습니다. KVM / Libvirt를 사용하여 일부 VM을 실행하도록 16GB의 메모리가있는 호스트에 있습니다. 얼마 후 ZoL은 엄청난 양의 메모리를 사용하여 일부 VM이 실행 중일 때 RAM 사용량의 98 %에 도달했습니다. 이로 인해 새로운 프로세스가 "메모리를 할당 할 수 없음"을 시작하지 않습니다. ZFS를 …
20 zfsonlinux 

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.