서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

3
수신 후 후크로 Gitlab을 설정하는 방법은 무엇입니까?
한 서버에서 Gitlab을 사용하고 있으며 마스터 브랜치를 커밋 할 때 git 리포지토리를 다른 웹 서버로 푸시하고 싶습니다. 따라서 새 버전의 웹 사이트를 푸시하면 프로덕션 서버가 업데이트됩니다. 나는 이것이 gitlab 내부의 후크로 가능해야한다는 것을 알고 있지만 얼마나 정확하게 찾을 수는 없습니다. 다음 가이드 http://danielmiessler.com/study/git/#website를 시도 했지만 gitlab과 함께 사용하도록 작성되지 않았으므로 …
19 git  hook  gitlab 

2
UsePAM이 "no"로 설정된 경우 SSH 공개 키 인증이 실패합니다.
비밀번호 인증을 사용 중지하려면 다음 값을 설정했습니다. sshd_config ChallengeResponseAuthentication no PasswordAuthentication no UsePAM no 개인 키로 로그인하려고하면 Permission denied (publickey). 그런 다음로 변경 UsePAM하면 yes개인 키를 사용하여 로그인 할 수 있습니다. 왜? OSX에서 Ubuntu 12.04 64 비트 호스트에 연결하고 있습니다 ssh -i ~/.ssh/deploy -l deploy localhost -p 2222 -v 자세한 …
19 linux  ssh 


1
파티션되지 않은 Hitachi HDS5C3020 드라이브가 부팅 15 분 후에 50 % 더 많은 전력을 소비하기 시작하는 이유는 무엇입니까?
데비안 6.0.6 시스템에는 2TB Toshiba DT01ABA200 드라이브 74 개가 있습니다. 이 드라이브는 펌웨어 개정판 MZ4OAAB0을 실행하는 Hitachi HDS5C3020BLE630 드라이브로 식별됩니다. HP SAS 확장 카드를 통해 LSI 2008 SAS 컨트롤러에 연결된 64 개의 드라이브, 다른 5 개의 드라이브는 메인 보드에 직접 연결되어 있으며, 4 개의 드라이브는 Sil 기반 PCI 컨트롤러에 연결되어 …

1
CNAME 레코드로 인해 두 번째 DNS 조회가 발생합니까?
foo.bar.cc를 가리키는 CNAME 레코드가있는 www.foo.com이라는 하위 도메인이 있다고 가정합니다. Foo.bar.cc는 IP 주소 1.2.3.4를 가리키는 A 레코드를가집니다. 이제 www.foo.com의 DNS 조회를 수행하면 다음과 같은 답변을 얻을 수 있습니다. www.foo.com. IN CNAME foo.bar.cc. foo.bar.cc. IN A 1.2.3.4 내 질문은 foo.bar.cc는 어떤 단계에서 해결됩니까? 응답이 클라이언트로 다시 전송되기 전에 재귀 DNS 서버에 의해 …

2
50 * 페이지 용 Nginx add_header
나는 현재 일종의 50 * 오류를 보낼 때 응답에 헤더를 추가하기 위해 nginx를 얻으려고합니다. 이미 http 블록에 add_header 지시문이 있으며 오류를 제외하고 모든 요청에 ​​대해 존중됩니다. 또한 내 호스트 중 하나에서 다음을 시도했습니다. location /mediocregopheristhecoolest { add_header X-Test "blahblahblah"; return 502; } 해당 페이지로 이동하면 502가 표시되지만 헤더는 없습니다. 이것은 …

3
EC2 Elastic Load Balancer DNS 및 라우팅 관련 문제
Amazon EC2 (Amazon Elastic Load Balancer (ELB) 뒤에있는 여러 HTTP 서버)에서 Amazon EC2에 대해 매우 간단한 설정을 실행하려고합니다. 도메인은 Route53에서 관리되며 ELB를 가리 키도록 설정된 CNAME 레코드가 있습니다. 일부 위치 (일부는 아니지만)가 간헐적으로로드 밸런서에 연결할 수없는 문제가 발생했습니다. 이것이 ELB 도메인 이름의 확인 일 수 있습니다. Amazon 지원팀은로드 밸런서의 기본 …

2
ia32-libs : 종속 : ia32-libs-i386 그러나 설치할 수 없습니다
ia32-libs내 Debian x86_64 상자에 (VirtualBox 소스를 빌드하기위한 종속성) 설치하려고 하는데 오류가 발생합니다. The following packages have unmet dependencies: ia32-libs : Depends: ia32-libs-i386 but it is not installable E: Unable to correct problems, you have held broken packages. 당연히 시도하고 설치하려고 ia32-libs-i386했지만 다른 오류가 발생했습니다. Package ia32-libs-i386 is not available, but …

2
IIS의 ".NET Framework 버전"설정은 실제로 무엇을합니까?
이것은 명백한 질문처럼 보이지만 최상위 IIS 구성 패널의 ".NET Framework 버전 변경"단추가 실제로 어떻게 변경되는지 확인하려고합니다. 모든 서버에서 항상 v2.0으로 유지되었습니다. 내 응용 프로그램 풀은 v2.0과 v4.0이 혼합되어 있으며 모든 v4.0 응용 프로그램이 올바르게 작동합니다. 이 버전 번호는 무엇을 제어합니까? 응용 프로그램 풀에 할당되지 않은 이것에 의존하는 것은 무엇입니까? 이상해 …
19 iis  asp.net  .net 

5
SSL 지원으로 nginx를 컴파일 할 수 없습니다. OpenSSL을 찾을 수 없습니다
SSL 모듈이 활성화 된 소스에서 nginx를 컴파일하려고합니다. 이 명령을 실행할 때 : ./configure --with-http_ssl_module 모든 것이 올바르게 설치되었는지 확인하기 위해 일반적인 검사를 수행 한 다음 팝업이 표시됩니다. OpenSSL 라이브러리 확인 중 ... 찾을 수 없음 ./configure : 오류 : SSL 모듈에는 OpenSSL 라이브러리가 필요합니다. --with-openssl = 옵션을 사용하여 모듈을 활성화하거나 …
19 ubuntu  nginx  openssl 


3
HAProxy와 함께 TCP로드 밸런싱을 사용할 때 모든 아웃 바운드 트래픽이 LB를 통과합니까?
HTTP로드 밸런싱과 많은 수의 지속적인 TCP 연결 (가능한 경우 50k 정도)을 필요로하는 VM을 사용하여 호스팅되도록 앱을 설정하고 있습니다 (아마 아마존이지만 돌로 설정되지는 않음). 데이터 양이 많지는 않지만 업데이트가 자주 발생합니다. 지금은로드 밸런서를 평가하고 있으며 HAProxy 아키텍처에 대해 약간 혼란스러워합니다. HAProxy를 사용하여 TCP 연결의 균형을 조정하면 모든 결과 트래픽이로드 밸런서를 통과해야합니까? …

1
SFTP / FTP 액세스 권한이있는 사용자를 Amazon EC2 Centos의 '/ var / www / html / website_abc'폴더에 추가하는 방법은 무엇입니까?
가능한 중복 : Linux 디렉토리 권한 일부 타사 개발자와 함께 일하고 있으며 SFTP (또는 FTP)에 작업중인 웹 사이트의 루트 폴더에 대한 액세스 권한을 부여하려고합니다. 즉 '/var/www/html/website_abc', 파일을 업로드 할 수 있습니다. 동일한 EC2 인스턴스에서 다른 웹 사이트를 호스팅하고 '/var/www/html/website_xyz'있습니다. 하나의 단일 EC2 인스턴스에서 여러 웹 사이트를 사용하고 있음을 강조하기 위해 …


5
sshd 구성 확인
구성을 sshd어떻게 확인할 수 있습니까? 예를 들어, 이러한 설정을 설정하고 적용하고 싶습니다. AllowUsers user1 user2 PasswordAuthentication no PermitRootLogin no 파일의 내용을 수동으로 확인하는 유일한 방법입니까 sshd_config, 아니면 확인할 수 sshd있습니까?

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.