서버 관리자

시스템 및 네트워크 관리자를위한 Q & A



2
systemctl로 중지 한 후 서비스는 실패 상태로 유지됩니다
서비스 방식으로 MineCraft 서버를 시작하는 간단한 시스템 스크립트가 있습니다. SO는 CentOS 7입니다. 스크립트는 다음과 같습니다. [Unit] Description=Minecraft Server After=syslog.target network.target [Service] Type=simple WorkingDirectory=/root/Minecraft ExecStart=/bin/java -Xmx1024M -Xms1024M -jar minecraft_server.jar nogui Restart=on-failure [Install] WantedBy=multi-user.target 서비스 시작은 정상적으로 작동하지만 중지하면 서비스는 실패 상태로 유지됩니다. 보다: systemctl status minecraftd.service minecraftd.service - Minecraft Server Loaded: …

2
nginx는 upstream_http_ 변수에 조건부로 헤더를 추가합니다
nginx에 리버스 프록시가있어 꽤 많은 사이트를 프록시합니다. 최근에 모든 SSL 지원 웹 사이트에 대해 HTTP Strict Transport Security를 ​​활성화했습니다. 이 기능을 사용하지 않으려는 사이트가 하나 있습니다. 내 업스트림에서 이미 Strict-Transport-Security헤더를 보냈다면 간단하게 확인 하고 그렇지 않은 경우 하나만 추가한다고 생각했습니다 . 이렇게하면 업스트림 max-age=0에서 프록시로 HSTS를 사용하지 않도록 STS 헤더를 …

1
$ BASH_ENV는 일반적으로 어디에 설정됩니까?
트윈 Linux 서버는 동일하게 구성해야하지만 그중 하나에 대한 ssh 명령은 ~ / .bashrc에 지정된 경로가 필요한 명령에 실패합니다. 예를 들어 pwd대화식 및 ssh와 같은 명령을 사용할 수 있지만 응용 프로그램 저장소 폴더에있는 프로그램을 실행하려고하면 서버 중 하나에 대한 대화 형 셸에서만 작동합니다. 두 서버의 / etc / profile 및 / …
19 linux  bash 

1
oom-killer syslog 메시지를 읽는 방법?
우분투 12.04 서버가 있는데 때로는 SSH, 핑, 물리적으로 재부팅 될 때까지 아무것도 완전히 죽지 않습니다. 재부팅 후, syslog에서 oom-killer가 거의 모든 것을 죽였다는 것을 알 수 있습니다. 여기에는 자세한 메모리 사용 정보가 많이 있습니다. OOM 문제의 원인을 확인하려면이 로그를 어떻게 읽습니까? 서버에 필요한 것보다 훨씬 많은 메모리가 있으므로 메모리가 부족하지 …

3
Centos 5의 아파치 사용자 / 그룹이란 무엇입니까?
닫은. 이 질문은 주제에 맞지 않습니다 . 현재 답변을받지 않습니다. 이 질문을 개선하고 싶습니까? 서버 결함에 대한 주제가 되도록 질문을 업데이트하십시오 . 휴일 칠년 전에 . 안녕하세요, 이것이 기본적이라는 것을 알고 있지만 누구나 centos 5/6의 아파치 2에 대한 기본 사용자 / 그룹 이름을 알려주십시오. 구글은 나에게 쓰레기를주고있다.

4
줄 길이로 텍스트 파일을 필터링하는 Linux 쉘 명령
dd if=/dev/sda1 of=diskimage텍스트 파일을 복구 해야하는 borked 파티션 (생각 ) 의 30GB 디스크 이미지가 있습니다. 데이터 조각 도구 foremost는 잘 정의 된 헤더가있는 파일, 즉 일반 텍스트 파일이 아닌 파일에서만 작동하므로 좋은 친구가되었습니다 strings. strings diskimage > diskstrings.txt 실제로 쓸모없는 텍스트와 혼합 된 많은 문자열, 주로 쓸모없는 것들을 포함하는 3GB …
19 sed  filter  awk  strings 

3
공유 액세스 전용 Windows 계정 만들기
도메인이 아닌 작업 그룹에서 Windows Server 2008 R2를 실행하고 있으며 동일한 작업 그룹의 다른 컴퓨터가 해당 서버의 파일 공유에 액세스 할 수 있도록하는 로컬 계정 만 만들고 싶습니다. 고객이 연결하면 사용자 이름 / 암호를 입력하라는 메시지가 표시되며이 계정은 고객이 액세스 할 수있는 방법으로 사용됩니다. 이 계정에 프로필이 있거나 서버 자체에 …

4
wget이 SSL 인증서를 확인하지 않는 이유는 무엇입니까?
Fedora 8 설치에 문제가 있습니다. 그것은 그 보이는 wget더 이상 SSL 인증서를 확인하는 방법을 알고하지 않습니다. 구성이 동일하고 작동한다고 생각되는 다른 Fedora 8 상자 가 있기 때문에 이상 합니다! --no-check-certificate스위치 를 사용하지 않고 어떻게 작동시킬 수 있습니까? 다음은 샘플 출력입니다. wget https://www.google.com --2011-09-23 00:11:13-- https://www.google.com/ Resolving www.google.com... 74.125.230.146, 74.125.230.147, 74.125.230.148, …
19 linux  ssl  wget  fedora 

1
Linux 시스템에 PECL을 설치하는 방법
http://pecl.php.net/ 에 PECL 확장에 대한 다운로드 섹션이 있지만 PECL * itself **에 대한 설치 단계를받지 못했습니다. 다음 명령이 작동하지 않습니다- yum intall pecl 내 시스템에는 PECL이 설치되어 있으므로 다음과 같이 PECL 확장을 설치할 수 있습니다. pecl install mailparse 그러나 pecl명령 실행 이 동일하게 인식되지 않는 시스템에서는 Fedora 7 시스템 (이전 …
19 php  pecl 

4
`crontab -e` 명령에 대한“허가 거부”의 원인은 무엇입니까?
도움이 되길 바라는 결과는 다음과 같습니다. nick@home-sv-1:~$ crontab -e /var/spool/cron/crontabs/nick: Permission denied nick@home-sv-1:~$ echo $EDITOR emacs nick@home-sv-1:~$ ls /var/spool/cron/crontabs ls: cannot open directory /var/spool/cron/crontabs: Permission denied nick@home-sv-1:~$ sudo ls -al /var/spool/cron/crontabs total 12 drwx-wx--T 2 root crontab 4096 2009-10-25 20:45 . drwxr-xr-x 3 root root 4096 2009-05-18 01:19 .. -rw------- …
19 cron 


3
PHP7을 사용하는 fastcgi_pass에 대한 권한 거부
PHP7.0에서 LEMP를 실행하고 있습니다. 내 서버 블록에 이것을 가지고 있습니다. fastcgi_pass unix:/var/run/php/php7.0-fpm.sock; 그러나 사이트를 열면 502 Bad Gateway가 반환됩니다. 아래는 오류 로그입니다. *1 connect() to unix:/var/run/php/php7.0-fpm.sock failed (13: Permission denied) while connecting to upstream, client: xxx.xxx.xxx.xxx, server: example.com, request: "GET / HTTP1.1", upstream: "fsatcgi://unix:/var/run/php/php7.0-fpm.sock:", host: "example.com" Permission Denied 라고 합니다. …
19 nginx  php  php7 


당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.