서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
"그런 개정 없음"으로 서브 버전로드 실패
Subversion 저장소를 마이그레이션하는 방법을 배우려고하는데 이해가되지 않는 문제가 발생합니다. 내가 사용했습니다 svndumpfilter하위 프로젝트를 분할하고, 어떤 경로 접두사를 제거했습니다. 수백 개의 커밋이 이제 올바르게 가져 오지만 다음과 같은 오류가 발생합니다. <<< Started new transaction, based on original revision 19190 * editing path : branches/features/DynamicSource ... done. * editing path : branches/features/DynamicSource/src/build.properties …
18 svn 

3
EC2 기존 AMI 업데이트
Elastic Load Balancing 을 사용하여 Auto Scaling Group의 로드 밸런싱 을 사용하고 있는데 , 애플리케이션 서버 (Tomcat)를 보유하고 있는 프라이빗 AMI 와 내 웹 앱을 전쟁으로 배포 한 프라이빗 AMI 를 보유하고 있습니다. 이제 모든 것이 잘 작동합니다. 나는 내 바람둥이 구성을 변경해야하는 경우 AMI . 내 AMI를 시작하지 않아도됩니다-> …

4
rw로 마운트 된 nfs 서버가 읽기 전용 파일 시스템 오류를 리턴하는 이유
우분투 서버 64 비트에서 일하고 있습니다. nfs를 rw로 마운트했지만 문제의 마운트 지점에서 아무것도 편집하려고 할 때 읽기 전용 파일 시스템 오류가 발생합니다. 내 etc/fstab읽은 내용 : # <file system> <mount point> <type> <options> <dump> <pass> proc /proc proc nodev,noexec,nosuid 0 0 /dev/mapper/product-root / ext4 errors=remount-ro 0 1 UUID=1cae6948-ca9d-4f0b-aec6-9e7a60bbbad8 /boot ext2 …

2
다른 사람이 공개적으로 라우팅 할 수있는 IPv4 주소를 로컬로 사용하면 어떤 이점이 있습니까?
전체 주에 걸쳐 있고 매우 복잡한 내 10000+ 사용자 네트워크에는 "이상한"주소 지정 체계가 있습니다. PC는 인터넷에 직접 연결 / 노출되지 않지만 네트워크 설계자는 "일반적인"IANA 예약 개인 IPv4 네트워크 범위 (10.0.0.0-10.255.255.255, 172.16.0.0-172.31)와 다른 범위에서 IP 주소를 할당했습니다. .255.255, 192.168.0.0-192.168.255.255). 인트라넷에 사용 된 IP 주소가 범위 내에 있다고 가정합니다. 20.*.*.* 즉, 공식적으로 …
18 networking 

7
Homebrew에서 설치 한 PHP에 Postgres 지원을 추가하는 방법은 무엇입니까?
MySQL 지원 및 XDebug를 포함하여 Homebrew와 함께 새로운 버전의 PHP를 이미 설치하고 구성했습니다. 잘 작동합니다. 그러나 PostgreSQL에 대한 지원도 설치해야합니다. 어떻게하니? 옵션을 추가하여 PHP를 처음 설치할 때 쉽다는 것을 알았습니다. homebrew install php53 --with-pgsql PHP가 이미 설치되어있을 때 PHP를 완전히 다시 설치하지 않고 어떻게 비슷한 것을 얻을 수 있습니까? 또는 …
18 php  mac-osx 

2
열린 인터넷에서 RFC 1918 주소?
Cisco ASA 5520 방화벽으로 페일 오버 문제를 진단하기 위해 www.btfl.com에 대한 추적 경로를 실행했으며 놀랍게도 일부 홉은 RFC 1918 주소로 돌아 왔습니다. 분명히하기 위해이 호스트는 내 방화벽 뒤에 있지 않으며 VPN이 없습니다. 거기에 가려면 열린 인터넷을 통해 연결해야합니다. 이것이 어떻게 / 왜 가능합니까? asa# traceroute www.btfl.com Tracing the route to …
18 routing  rfc 

8
Windows 2012 Server 핵심 식별
2012 서버가 WMI를 사용하여 핵심 설치로 설정되어 있는지 확인하고 싶습니다. 이전 질문 은 Win32_OperatingSystem 에서 OperatingSystemSKU를 얻을 수 있음을 나타냅니다 . 내 Windows 2012 코어 시스템에서 OperatingSystemSKU가 7 로보고 됩니다. 다른 질문 의 기사 는 PRODUCT_STANDARD_SERVER이며, 코어 설치가있는 경우 PRODUCT_STANDARD_SERVER_CORE 대신 0x0000000D의 값이 표시 될 것으로 예상됩니다. 내가 여기서 잃어버린 …

1
가상화 된 MS-DOS 컴퓨터가 IPX를 통해 통신 할 수 없음
2 개의 MS-Dos 6.22 머신을 가상 머신으로 변환했습니다. 두 컴퓨터에는 NETBEUI 및 IPX를 통해 통신하는 소프트웨어가 있습니다 (autoexec.bat를 검사 한 후 결론에 도달했습니다-IPX 스택을로드 함). 이 Vmware 포럼 게시물 을 따라 DOS amd_pcnet 드라이버를 설치하고 구성한 다음 필요한 프로토콜에 바인딩했습니다. 또한 IPX / SPX 용 ODI 드라이버를 설치하여 위와 동일한 …

3
nginx가 HTTP_X_FORWARDED_PROTO 헤더를 전달하는 방법은 무엇입니까?
에서 설정을 연결하고 있습니다. nginx > apache/php 에 haproxy > nginx > apache/php (ssl 지원으로 컴파일 된 haproxy 1.5-dev18 사용) nginx와 haproxy는 HTTP_X_FORWARDED_PROTO 헤더를 설정하도록 올바르게 설정되어 있습니다. 그러나 nginx는 haproxy에서 SSL 트래픽을 가져 오면 연결을 http로보고 헤더를 설정합니다. HTTP_X_FORWARDED_PROTO 헤더가있는 경우 nginx를 설정하여 연결에 따라 계속 설정하려면 어떻게해야합니까?
18 nginx 

3
일반적으로 프로덕션 서버에서 "apt-get upgrade"(안정성 측면에서)를 실행하는 것이 안전합니까?
필자는 종종 Ubuntu 12.04.2 서버 (Postgres 9.2.4에서 라이브 프로덕션 데이터로 실행)에 로그인하여 다음과 유사한 것을 보았습니다. 4 packages can be updated. 4 updates are security updates. 물론 이것은 며칠마다 발생합니다. 자동 업데이트에는 관심이 없지만 (자고있을 때 변경할 수있는 것이 적을수록 좋습니다.) 항상 서버를 최신 상태로 유지하는 데 관심이 있으니 질문은 …

4
합법적 인 이유 SMTP "MAIL FROM :"이 DATA의 "From :"헤더와 일치하지 않습니다.
SMTP“MAIL FROM :”필드가 메일 링리스트 외에 메시지의 DATA 섹션에있는“보낸 사람 :”필드와 일치하지 않는 합당한 이유가 있습니까? 에서 /programming/1750194/smtp-why-does-email-needs-envelope-and-what-does-the-envelope-mean : 그러나 달팽이 메일 은유를 계속하기 위해 대부분의 전문 서신에는 서신 자체에 인쇄 된 발신자 및 수신자의 주소가 포함됩니다. 이러한 주소는 우편 배달부에는 필요하지 않지만 대신 수령인의 호의입니다. 따라서 이메일이 같은 방식으로 …
18 email  smtp  rfc 

3
Server Core에서 PowerShell 자동 사용
Server 2012 Core 설치에 로컬로 로그인하면 일반 ol 'cmd 대신 PowerShell 명령 줄 에 입력해야 할 때마다powershell 입력합니다. PowerShell Windows 기능을 절대 제거하지 않는다고 가정하면 cmd 대신 PowerShell 프롬프트로 바로 연결되도록 서버를 어떻게 구성 할 수 있습니까?

7
응용 프로그램이 실행되는 동안 .dll 파일을 교체 하시겠습니까?
특정 .dll 파일을 사용하여 실행하는 여러 게임 서버가 있습니다. 때로는 게임 서버를 업데이트해야하지만 이미 실행중인 게임을 중단하고 싶지 않습니다. .dll 파일을 교체하는 방법이 있습니까 (Windows에 의해 잠겨 있음) 해당 파일을 사용하는 게임 서버의 다음 인스턴스가 새 버전을 열고 이전 버전의 .dll을 다시 시작할 때까지 계속 사용하십시오. ? 그렇게하는 도구 중 …

4
RHEL에서 특정 네트워크 인터페이스를 "다시 시작"하는 방법은 무엇입니까?
RHEL에서 service network restart명령 을 사용하는 대신 특정 네트워크 인터페이스를 다시 시작하는 방법은 하나의 명령으로 "eth1"이라고 말합니다. "하나의 명령 만"이것이 저의 ssh작업중인 유일한 인터페이스이기 때문입니다 . 따라서 사용하려고하는 경우 : ifdown및 ifup, ifup명령 ssh후 한 번 종료되면 명령 을 칠 수 없습니다 ifdown eth1. 따라서 현재 ssh연결을 제공하는 인터페이스를 모두 …

6
AWS Elastic Beanstalk에서 최신 AMI로 업그레이드하는 방법은 무엇입니까?
AWS Elastic Beanstalk에서 애플리케이션을 실행하고 있으며 최신 AMI를 사용하려면 새로운 환경을 만들어야하는 것처럼 보입니다. 최신 AMI ID가 무엇인지 알면 환경 구성에서 업데이트 할 수 있습니다. 최신 Elastic Beanstalk AMI의 ID를 찾을 수있는 곳이 있습니까? 아니면 새 버전이 출시 될 때마다 인스턴스를 새 버전으로 자동 교체 할 수 있습니까?

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.