서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

4
한 풀에서 다른 풀로 ZFS 파일 시스템 이동
루트 rpool 외에 추가 저장 영역 풀로 Solaris 10 U8 서버를 확장하고 있습니다. 특정 ZFS 파일 시스템을 rpool에서이 새로운 스토리지 풀로 이동하는 가장 효과적이고 간단하며 안정적인 방법은 무엇입니까? 온라인으로 할 수 있습니까? 아니면 먼저이 풀을 사용하여 서비스를 종료해야합니까?
18 solaris  zfs 

2
mySQL에서 table_cache 조정 및 이해
우수한 MySQL 성능 조정 스크립트 를 실행하고 제안을 진행하기 시작했습니다. 내가 만난 것은 TABLE CACHE 현재 table_cache 값 = 4096 테이블 총 1073 개의 테이블이 있습니다. 열린 테이블이 3900 개 있습니다. 현재 table_cache 적중률은 2 %이며 테이블 캐시의 95 %가 사용 중입니다. 아마도 table_cache를 증가시켜야합니다 table_cache를 읽기 시작했지만 MySQL 설명서 …


4
IIS7-잠금 위반 오류, HTTP 처리기, 모듈 및 <clear /> 요소
자체 HTTP 처리기 집합을 사용하는 ASP.NET 사이트가 있으며 모듈이 필요하지 않습니다. 따라서 IIS6에서는 web.config 에서이 작업 만 수행했습니다. &lt;httpModules&gt; &lt;clear /&gt; &lt;/httpModules&gt; 그러나 system.webServerIIS7 영역 에서 동일한 작업을 수행 하려고하면 사이트를 보려고 할 때 500 오류가 발생하고 IIS 관리자에서 처리기 매핑을 보려고하면 메시지와 함께 팝업 상자가 나타납니다. 이 작업을 수행하는 …

2
"apt-get purge"에 해당하는 yum
CentOS에 패키지를 다시 설치하고 처음부터 시작하고 싶습니다. 데비안에서는 a를 할 수 있으며 apt-get purge foofoo에 대한 모든 설정 파일을 제거합니다. yum remove foo구성 파일을 제거하지 않습니다. apt-get purge fooyum을 사용 하는 방법이 있습니까?


5
AD에 대해 Linux 서버를 인증하는 것이 얼마나 실용적입니까?
우리는 소프트웨어 개발 회사에서 Windows와 Linux 서버를 모두 사용합니다. 이 설정의 단점 중 하나는 싱글 사인온 솔루션이 없다는 것입니다. 우리는 AD에 대해 인증하려는 Linux보다 Microsoft 상점보다 더 많습니다. 온라인에서 몇 가지 기사를 읽었으며 이것이 가능하다는 것을 이해합니다. 현재 Linux에서 인증이 필요한 다음 서비스를 사용하고 있습니다. -git 서버 (SSH를 통해) -Sendmail- …


1
FreeBSD Jails 또는 Docker 인스턴스
FreeBSD의 감옥과 Linux의 Docker의 주요 차이점은 무엇입니까? 하나는 다른 것보다 훨씬 안전하거나 성능이 좋습니까? 감옥은 Docker 인스턴스보다 오래되어 코드 자체가 더 안전하다고 간주 될 수 있습니다. 그러나 감옥은 결코 "잡히지"않았으므로 아마도 Docker 인스턴스만큼 좋지 않을까요? 아니면 Linux가 FreeBSD보다 훨씬 더 인기가 있기 때문입니까?
18 docker  freebsd  jail 

5
Terraform-개수와 함께 중첩 루프 사용
테라 폼에서 중첩 루프를 사용하려고합니다. 두 개의 목록 변수가 list_of_allowed_accounts있고 list_of_images목록 list_of_images을 반복 한 다음 목록을 반복하려고 합니다 list_of_allowed_accounts. 여기 내 테라 폼 코드가 있습니다. variable "list_of_allowed_accounts" { type = "list" default = ["111111111", "2222222"] } variable "list_of_images" { type = "list" default = ["alpine", "java", "jenkins"] } data "template_file" …
18 terraform  count 

2
손상된 XFS 파일 시스템을 처리하는 올바른 방법
최근에 정전으로 인해 XFS 파일 시스템이 손상되었습니다. (CentOS 7 시스템). 시스템이 제대로 부팅되지 않았습니다. 복구 CD로 부팅하고을 시도했는데 xfs_repair로그를 처리하기 위해 파티션을 마운트하라는 메시지가 표시되었습니다. 파티션을 마운트하고 ls예를 확인했습니다. 파티션을 마운트 해제하고 xfs_repair다시 시도했는데 같은 메시지가 나타납니다. 이 상황에서 어떻게해야합니까? 복구 CD (System Rescue CD, 버전 4.7.1)에 문제가 있습니까? 사용해야 …

2
NFS 및 SMB는 스파 스 파일을 지원합니까?
이 질문은 이전에 스택 오버플로로 요청되었지만 좋은 사람들은 대신 커뮤니티를 사용해 볼 것을 권장했습니다. 다양한 파일 시스템과 관련하여 스파 스 파일을 연구 중이며 스파 스 파일이 NFS (Network File Systems) 또는 SMB (Server Message Block)에서 지원된다는 구체적인 내용을 찾으려고합니다. SMB는 Windows에서 널리 사용되며이 항목 에 따르면 기본 파일 시스템이 아닌 …

7
기본 CA 인증서 번들 위치
기본 CA 인증서 번들에 .pem 인증서 파일을 추가해야하지만 기본 CA 인증서 번들이 어디에 보관되어 있는지 알 수 없습니다. 이 기본 번들에 새 .pem 파일을 추가해야합니다. --capath를 사용하여 내 위치를 지정하는 것보다 cURL은 어디를 볼지 명확하게 알고 있지만 위치를 나타내는 cURL 명령은 표시되지 않습니다. 이 위치를 알려주는 명령이 있습니까? 어떻게 찾을 …

6
LVM에 파티션 테이블이 필요합니까?
파티션 테이블을 만드는 단계를 거치지 않고 원시 블록 장치 위에서 pvcreate를 성공적으로 수행 할 수있는 것으로 보입니다. 그런 다음 볼륨 그룹, 논리 볼륨 및 파일 시스템을 생성하고 마운트 한 다음 dd를 통해 테스트 할 수 있습니다. 작동하는 것 같지만 위생 검사가 필요합니다. 이것은 나쁜 생각입니까? 원시 블록 장치 위에 GPT …
18 lvm  parted 

4
'server.host.name:0'에 대한 RSA 또는 DSA 서버 인증서를 찾을 수 없습니까?
사이트 당 하나의 구성 파일로 Apache 2.2.22를 사용하여 Ubuntu 12.4에서 12 개의 가상 호스트를 호스팅하는 새 웹 서버를 설정하고 있습니다. 모든 구성 파일을 한 번에 생성 a2ensite *하고 한 번에 모두 사용하도록 실행 했습니다. 구성을 다시로드 할 때 구성이 실패하고 아파치를 다시 시작한 후 error.log에서 다음 오류 메시지를 발견했습니다. 'server.host.name:0'에 …
18 apache-2.2  ssl 

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.