서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
일부 AAAA 쿼리에 대해 SERVFAIL을 반환하는 Server 2012R2 DNS 서버
(많은 나의 원래 테스트는 새로운 정보에 비추어지지 않기 때문에이 질문의 대부분을 다시 작성하십시오) Server 2012R2 DNS 서버에 문제가 있습니다. 이러한 문제의 가장 큰 부작용은 Exchange 전자 메일이 통과하지 않는 것입니다. A 레코드를 시도하기 전에 AAAA 레코드를 쿼리합니다. AAAA 레코드에 대한 SERVFAIL이 표시되면 A 레코드도 시도하지 않고 그냥 포기합니다. 일부 도메인의 …

5
구성 관리자 (예 : Puppet / Chef / Ansible)를 사용하는 것이 언제 적절한가요?
현재 직장에서는 2 개의 VMware 호스트 시스템, OpenBSD 물리적 시스템, 3 개의 데비안 VM 및 6 개의 Windows Server VM (2008/2012)을 살펴 봅니다. Puppet 또는 Chef와 같은 구성 관리 도구를 구현하려고합니다. 이것이 합리적입니까, 아니면 도구 학습의 오버 헤드가 이점을 능가합니까? 관리 효율성과 구현 비용의 전환점은 어디입니까?

4
이미 네트워크에 연결된 네트워크 케이블 추적
내가 일을하지 않는 동안 약간의 개조가 이루어졌고 RJ45 키스톤 모듈로 끝나는 레이블이없는 cat5 케이블이 몇 개 남았습니다. 다른 쪽 끝에서 모든 케이블은 서버 실의 패치 패널에서 종료됩니다. 일부 케이블은 스위치에 연결되어 있으며 활성 데이터 라인입니다. 랩탑을 키스톤 모듈에 연결하여 회선이 활성화되어 있는지 확인할 수 있습니다. DCHP 서버가 주소를 할당하고 있습니다. …
17 networking  cable  cat5 


1
다운 타임없이 Docker 컨테이너 업데이트
웹 서버 (Apache 2와 같은)가있는 Docker 컨테이너가 있다고 가정 해 봅시다. 이제 OS를 업데이트하고 싶습니다. 이 SF 답변 은 가장 좋은 방법은 기본 이미지와 내 Apache 이미지를 다시 작성하는 것입니다. 그러나 이미지를 배포하면 새 컨테이너를 생성하기 전에 이전 컨테이너를 삭제해야하므로 다운 타임이 발생하므로 포트 80/443에 바인딩하는 컨테이너는 하나뿐입니다. 그러나 다운 …
17 docker  uptime  coreos 

7
자주 사용하는 Windows Server 2008R2 원격 데스크톱 서버 (VM)를 얼마나 자주 다시 시작합니까?
참고 : Windows 서버를 얼마나 자주 다시 시작해야합니까?를 읽었습니다 . 그러나이 질문은 특히 원격 데스크톱 서버와 관련이 있습니다. 원격 데스크톱 서비스 용으로 라이센스가 부여 된 Windows Server 2008R2 서버 (VMware ESX VM)와 RRAS (SSTP)를 수행하는 25 명의 사용자가 있습니다. 평균 주중에는 근무 시간 동안 추가로 4-6 명의 "연결이 끊어진"사용자가있는 8 …


2
PowerShell의 OneGet 저장소 소스를 Chocolatey로 수동 설정하는 방법
OneGet PowerShell 모듈은 기본 저장소가 Chocolatey 인 상태로 제공되어야합니다. 이 문서는 여기에 있습니다 . 그러나 Get-PackageSource를 실행하면 PSGallery와 MSPSGallery가 소스로 반환됩니다. 패키지 소스를 Chocolatey로 수동 설정하려면 어떻게해야합니까? 나는 달리기를 시도했다. Register-PackageSource -Name chocolatey -ProviderName Chocolatey -Location http://chocolatey.org/api/v2/ 그러나 다음과 같은 경고를 반환합니다. 패키지 제공 업체 '초콜릿'을 찾을 수 없습니다
17 powershell 

5
prod 서버에 액세스하는 이유를 기록하기 위해 시스템 관리자를 강제하는 기술이 필요합니다
회사에서는 사용자가 프로덕션 서버에 로그인 할 때마다 사용자가 로그인 한 이유와 사용자가 변경하려는 변경 사항을 기록해야합니다. 우리 팀은 이것을 원하지만 잊기 쉽습니다. 나는 그들이 기억하도록 도와주고 싶다. 나는 motd를 고려했지만 조금 더 강한 것을 원합니다. 내 첫 번째 생각은 사용자의 쉘을 다음과 같은 스크립트로 변경하는 것이 었습니다. vim /logs/logindate.txt bash …
17 linux  logging 

3
HTTP GET 방법은 DNS 프로토콜과 관련하여 어떻게 작동합니까?
TCP / IP 스택의 응용 프로그램 계층 프로토콜을 이해하려고합니다. HTTP와 DNS 프로토콜이 모두 최상위 계층 (응용 프로그램 계층)에 있다는 것을 알고 있습니다. 따라서 브라우저가 리소스에 액세스하려면 다음과 같이 HTTP 서버에 요청을 보내야합니다. GET www.pippo.it/hello.htm HTTP/1.1 이 요청은 HTTP 프로토콜 규칙에 따라 IP 주소가 아닌 페이지 URL을 사용합니다. URL을 IP로 변환하려면 …

6
RAID 1 + 6이 더 일반적인 레이아웃이 아닌 이유는 무엇입니까?
중첩 된 RAID 레벨 1 + 5 또는 1 + 6이 거의 알려지지 않은 이유는 무엇입니까? 중첩 RAID 레벨 위키 백과 문서는 현재 자신의 섹션이 없습니다. RAID 1 + 0 트리플 미러링과 비교할 때 RAID 1 + 0보다 일반적이지 않은 이유를 이해하지 못합니다. 드라이브 용량이 성능이나 안정성보다 빠르게 증가함에 따라 …
17 raid  raid1  raid6 

2
OCSP 유효성 검사-로컬 발급자 인증서를 가져올 수 없음
처음부터 SSL을 처음 사용하고 첫 단계를 수행했습니다. 내 도메인의 RapidSSL에서 SSL 인증서를 구입 한 후 인증서 설치 단계를 수행했습니다. 일반적으로 인증서는 유효하며 웹 서버 (nginx v1.4.6-Ubuntu 14.04.1 LTS)에서 작동하지만 OCSP OCSP를 활성화하려고하면 nginx error.log에 다음 오류가 발생합니다. 인증서 상태를 요청하는 동안 OCSP_basic_verify () 실패 (SSL : 오류 : 27069065 : …

2
HAProxy HTTP 및 TCP
HAProxy는 모드를 TCP 또는 HTTP로 설정하는 옵션을 제공합니다. 또한 포트를 설정할 수 있습니다. 포트를 선택할 수있게한다면 왜 HTTP와 TCP를 선택할 수 있습니까? HTTP를 원한다면 TCP와 포트 80을 선택할 수 있습니까? 왜 TCP와 HTTP 만? HTTP가 TCP가 아님을 암시하는 것 같습니다. TCP, HTTP, SNMP, FTP 등이없는 이유는 무엇입니까? 왜 HTTP와 TCP입니까? …
17 haproxy 

2
Office 365 Pro Plus를 배포 할 때 레거시 버전의 Office 제거
볼륨 라이선스가 부여 된 Office 버전 (MSI 배포가 포함 된 버전)에서는 OCT 를 사용하여 새 버전이 배포 될 때 이전 버전의 Office를 제거 할 패키지를 만들 수 있습니다 . Office 365 Pro Plus는 간편 실행이므로 OCT와 작동하지 않습니다. ODT 는 Office 365 Pro Plus의 일부 사용자 지정을 허용하지만 이전 버전의 …


당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.