서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

4
리눅스에서 반복 가능한 디렉토리 순서 보장
나는 실행 호스팅 지속적인 통합 회사, 우리는 리눅스에 대한 고객의 코드를 실행합니다. 코드를 실행할 때마다 별도의 가상 머신에서 코드를 실행합니다. 자주 발생하는 문제는 VM에서 코드를 체크 아웃 한 디렉토리 순서로 인해 고객의 테스트가 실패하는 경우가 있습니다. 좀 더 자세히 살펴 보겠습니다. OSX에서 HFS + 파일 시스템은 디렉토리가 항상 동일한 순서로 …


2
ext4 파일 시스템 최대 inode 제한-누구든지 설명해 주시겠습니까?
최근에 우리는 more than 6mln in this case충분한 공간 이 있어도 ext4 파일 시스템 중 하나가 매우 많은 수의 파일을 처리 할 수없는 것처럼 보였습니다 . 그것은이다 6mlnext4 파일 시스템은 기본 설정 모든으로 포맷 한 때, 최대 수? Google에 시도했지만 확실한 답변을 얻지 못했습니다. 여기 누군가가 이것에 약간의 빛을 비출 …

4
하드웨어 방화벽과 VMware 방화벽 어플라이언스
사무실에서 VMWare 클러스터에 하드웨어 방화벽을 설치하거나 가상 방화벽을 설정해야하는지에 대한 토론이 있습니다. 우리의 환경은 iSCSI 공유 스토리지 어레이가있는 2 개의 1GB 스위치를 통해 3 개의 서버 노드 (각각 64GB RAM에 16 개의 코어)로 구성됩니다. VMWare 어플라이언스에 리소스를 전용으로 사용한다고 가정하면 가상 방화벽 대신 하드웨어 방화벽을 선택하면 어떤 이점이 있습니까? 하드웨어 …

2
프록시를 통한 mosh 터널
나는 성장하는 mosh 팬이며 신뢰할 수없는 wifi 링크가있을 때 점점 더 많이 사용하고 있습니다. 내가 알아 내려고하는 것은 DMZ (인터넷 및 방화벽 네트워크에 연결된)에있는 서버를 통해 터널을 만드는 방법입니다. ssh를 사용하는 현재 솔루션은 다음과 같은 줄을 포함하도록 .ssh / config 를 편집하는 것입니다. Host server-behind-firewall ProxyCommand ssh server-in-dmz nc %h …
16 ssh  tunneling 

9
300 회 연결 후 Apache Tomcat이 질식
EC2에서 호스팅되는 Tomcat 앞에 Apache 웹 서버가 있으며 인스턴스 유형은 34GB 메모리로 매우 큽니다. 우리의 응용 프로그램은 많은 외부 웹 서비스를 다루며 피크 시간 동안 요청에 응답하는 데 거의 300 초가 걸리는 매우 거친 외부 웹 서비스가 있습니다. 사용량이 많은 시간 동안 서버는 약 300 개의 httpd 프로세스에서 질식합니다. ps …

5
Linux에서 프로세스를 종료하고 강제로 0을 반환합니까?
Linux 환경에서 프로세스에 리턴 신호를 보내면서 프로세스에 종료 신호를 보내려면 어떻게해야합니까? 이것을 위해 멋진 GDB 마술을해야합니까, 아니면 내가 알지 못하는 멋진 킬 신호가 있습니까? 테스트 사례 : cat; echo $? killall cat 다양한 kill 신호를 시도하면 129, 137 및 143과 같은 다른 리턴 신호 만 제공됩니다. 제 목표는 스크립트가 실행되는 …
16 linux  process  kill 

3
VM에서 가상 IPMI를 지원합니까?
이것은 어리석은 질문 일 수도 있지만 ... 가상 머신에 대한 "가상 IPMI"를 지원하는 하이퍼 바이저 또는 기타 가상화 솔루션이 있습니까? 즉, 전원 제어, LAN을 통한 직렬 콘솔 등의 가상 머신에 액세스 할 수 있습니다. 이것은 실제로 가상 머신을 관리하는 올바른 방법이 아닙니다. 우리는 시스템 관리에 IPMI를 많이 사용하고 VM을 동일한 …

1
Windows IIS 인증이 FQDN과 함께 작동하지 않지만 인증되지 않은 경우
인터넷이 아닌 인트라넷 웹 사이트를 가지고 있습니다. http://mysite 웹 사이트는 IE를 통해 컴퓨터 / 클라이언트에서 로그인 한 사용자의 통합 인증을 수락합니다. FQDN에 가면 http://mysite.something.com 사용자 이름과 비밀번호를 묻는 메시지가 나타납니다. 그들은 같은 사이트와 웹 페이지입니다. IE / 로그인 한 사용자의 자격 증명을 모두 수락하려면 어떻게해야합니까?

1
시작 : 일반 사용자가 내 사용자 지정 서비스를 중지하고 시작하도록 허용
upstart를 사용하여 부팅시 웹 서버 응용 프로그램을 시작했습니다. 이것은 시작 스크립트입니다. # web app node upstart file at /etc/init/webapp.conf description "web application" start on started mongodb stop on runlevel [06] respawn respawn limit 10 100 env NODE_ENV=production pre-start script ulimit -n 2048 end script exec start-stop-daemon --start -c mainuser --exec …

4
세계 반대편에 지사 설립
가능한 한 다양한 솔루션을 사용하고 있으므로이 질문에 대한 요점을 바로 잡으려고하므로 질문에 대한 의견에 너무 많은 영향을 미치고 싶지 않습니다. 클라이언트는 영국 기반 회사입니다. AD가있는 95 %의 Windows 조직 그들은 모든 서버 인프라를 수용하는 데이터 센터에 1Gbps 라인을 가지고 있기 때문에 가능한 한 "온-프레미스"인프라를 유지하는 IT 정책을 가지고 있습니다. 고속 …

6
4GB에서 VHD 네트워크 파일 전송이 일관되게 실패
네트워크를 통해 Windows 7 시스템에서 데이터 센터의 물리적 Windows Server 2008 시스템으로 대용량 VHD (가상 하드 디스크) 파일을 전송할 때 Windows 파일 전송이 4GB로 일관되게 실패합니다. 본사에서 데이터 센터로 100mbit를 직접 연결합니다. 전송이 실패하면 다음과 같은 오류 메시지가 나타납니다. There is a problem accessing \\server-name\d$ Make sure you are connected …

3
로컬 호스트 포트에서 Apache 프록시가 작동하지 않습니다
포트 80에서 Apache 2.2.15를 실행 중이고 localhost 포트 8983에서 서블릿 엔진을 프록시하려고합니다. 다른 서버에서 설정을 실행하고 있지만 CentOS 6 시스템으로 이동했습니다. 새 컴퓨터에서는 작동하지 않습니다. 내 가상 호스트 구성 : ProxyRequests 끄기 <프록시 *> 주문 거부, 허용 모두 허용 </ Proxy> ProxyPass / http : // localhost : 8983 / …

5
DNS 정보가 전파되었는지 테스트하는 방법?
하위 도메인 중 하나에 대해 새로운 DNS 항목을 설정했습니다 (아파치 가상 호스트 또는 이와 유사한 것을 아직 설정하지 않았습니다). DNS 정보가 전파되었는지 어떻게 확인할 수 있습니까? 나는 간단하게 ping my.subdomain.com해결할 수 있다고 가정하고 해결할 수 있다면 A 레코드에 지정한 IP 주소를 표시한다고 가정합니다. 그러나 올바르게 가정하고 있는지 모르겠습니다. 이 정보를 …

9
공개 원격 데스크톱 서버를 보호하는 방법은 무엇입니까?
네트워크 외부에서 액세스 할 수 있도록 원격 데스크톱 서버 (터미널 서비스)를 공개해야합니다. 현재는 네트워크 내부에서만 액세스 할 수 있습니다. 방화벽을 열고 포트를 전달하는 것이 쉽다는 것을 알고 있습니다. 그러나 머신 자체를 어떻게 보호하고 이에 대한 모범 사례는 무엇입니까? 내 관심사는 해커가 침입 할 수 있다는 것입니다. 모범 사례 지침 / …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.