서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
리버스 프록시로 사용될 때 nginx가 https에서 http로 트래픽을 리디렉션하지 못하도록 방지
축약 된 nginx vhost conf는 다음과 같습니다. upstream gunicorn { server 127.0.0.1:8080 fail_timeout=0; } server { listen 80; listen 443 ssl; server_name domain.com ~^.+\.domain\.com$; location / { try_files $uri @proxy; } location @proxy { proxy_pass_header Server; proxy_redirect off; proxy_set_header Host $http_host; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto https; proxy_set_header X-Real-IP $remote_addr; …
16 nginx  ssl  https 


3
배치 파일에서 로케일을 모르는 % DATE % 및 % TIME %?
%DATE%및 %TIME%환경 변수는 명령 행 및 배치 파일 내부 Windows 시스템에 현재 날짜와 시간을 제공합니다. 안타깝게도 그 값은 로케일을 인식합니다! 즉, 독일 기계에서는 26.1.2011 대신에 2011-26-01 파일 이름 에이 변수를 사용하려는 경우 정렬이 방해됩니다. YYYY-MM-DDWindows 배치 파일에서 로캘 인식 날짜 문자열을 쉽게 얻을 수있는 방법이 있습니까? 현재로서는 다소 번거로운 해결 …

4
Windows AD DC의 도메인 관리자 및 관리자
여기에 무엇이 요청되는지 말하기가 어렵습니다. 이 질문은 모호하거나 모호하거나 불완전하거나 지나치게 광범위하거나 수사적이며 현재 형태로 합리적으로 대답 할 수 없습니다. 다시 열 수 있도록이 질문을 명확하게 설명 하려면 도움말 센터를 방문하십시오 . 휴일 9 년 ago . Microsoft Docs 기사 기본 그룹 에서 다음 두 그룹에 대한 설명 을 읽었습니다 …

4
포트 전달 취소
포트 80에 대한 모든 요청을 8020으로 전달해야합니다. Google에서 요청한 결과는 다음과 같습니다. iptables -t nat -I PREROUTING --source 0/0 --destination 0/0 -p tcp --dport 80 -j REDIRECT --to-ports 8020 이제 나중에 시스템을 다시 시작하지 않고 어떻게해야합니까?

5
MySQL DB에서 와일드 카드 (%) 액세스를 허용하고 " '<user>'@ 'localhost'에 대한 액세스가 거부되었습니다."오류가 발생 함
데이터베이스와 사용자를 만들었으며 다음을 통해 액세스를 허용했습니다. create user 'someuser'@'%' identified by 'password'; grant all privileges on somedb.* to 'someuser' with grant option; 그러나 MySQL에 연결하려고하면 다음 오류가 발생합니다. $ mysql -u someuser -p &gt; Enter Password: &gt; ERROR 1045 (28000): Access denied for user 'someuser'@'localhost' (using password: YES) "%"가 …
16 mysql 


3
Linux에서 인터페이스 통계를 지우는 방법
따라서 내 클라이언트 중 하나가 스위치 중 하나를 구성했으며 그 결과 구성으로 인해 스위치와 Linux 호스트간에 이중 불일치가 발생했습니다. 이중 불일치를 수정했지만 시스템을 다시 시작하지 않고 인터페이스의 오류 카운터를 쉽게 지우는 방법이 있습니까? eth0 Link encap:Ethernet HWaddr 00:nn:nn:nn:nn:nn inet addr:192.168.97.166 Bcast:192.168.97.167 Mask:255.255.255.252 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:630331763 …
16 linux  networking 

4
Windows 10-GPO를 통해 비활성화 된 방화벽에 대한 경고 알림 비활성화
알림 영역에 표시되는 경고를 비활성화하여 Windows 방화벽이 비활성화되었음을 알리는 방법이 있습니까? 편집 : 우리는 특히 수동 프로세스가 아닌 그룹 정책을 통해이를 달성하고자합니다. GPO를 통해 도메인 방화벽 프로필을 비활성화합니다. 즉, Windows 10 컴퓨터는 이에 대한 알림 영역에 지속적으로 경고 알림을 보냅니다. 경고에 대한 내용을 묻는 사용자 호출이 생성됩니다. 사용 중지되어 있으므로 …

1
존재하지 않는 도메인 예가 있습니까?
예제에서 도메인 이름을 사용하고 싶습니다. 나는 example.com이것이 목적을 위해 존재 한다는 것을 알고 있지만 도메인 이름이 존재하지 않기를 원합니다 (그리고 나중에 존재하지 않기를 바랍니다). 존재하지 않는 도메인 이름의 정식 예가 있습니까?

3
비표준 포트에서 nginx SSL을 실행하는 방법
나는 이것이 적어도 몇 가지 다른 질문의 복제본처럼 보이지만 각 질문을 여러 번 읽었으며 여전히 잘못하고 있습니다. 다음은에 위치한 myexample.com nginx 구성 파일의 내용입니다 /etc/nginx/sites-available. server { listen 443 ssl; listen [::]:443 ssl; server_name myexample.com www.myexample.com; add_header Strict-Transport-Security "max-age=31536000; includeSubDomains"; ssl_certificate /etc/letsencrypt/live/myexample.com/fullchain.pem; ssl_certificate_key /etc/letsencrypt/live/myexample.com/privkey.pem; #Configures the publicly served root directory …
16 nginx  ssl 

5
다시 가져온 도커 이미지 / 컨테이너에서 "지정된 명령이 없습니다"
한 컴퓨터에서 도커 컨테이너를 가져 와서 다른 컴퓨터에서 실행하려고 시도하고 다음 오류가 발생했습니다. " 데몬의 오류 응답 : 명령이 지정되지 않았습니다 ". 아래는 문제를 보여주는 간단한 예입니다. docker --version Docker version 1.10.1, build 9e83765 docker pull ubuntu docker run --name u1 -dit ubuntu:latest docker export -o exported u1 docker stop …
16 docker 

6
S3 파일을 일괄 삭제하는 가장 효율적인 방법
S3에서 한 번에 수천 또는 수만 개의 파일을 일괄 적으로 삭제할 수 있기를 원합니다. 각 파일은 1MB에서 50MB 사이입니다. 당연히, 나는 파일이 삭제되는 동안 사용자 (또는 내 서버)가 대기하는 것을 원하지 않습니다. 따라서 질문 : S3는 특히 많은 수의 파일을 삭제할 때 파일 삭제를 어떻게 처리합니까? 이를 수행하고 AWS가 대부분의 …

2
AWS Postgresql 인스턴스에서 수퍼 유저를 생성 할 수없는 이유는 무엇입니까?
RDS 인스턴스 (Postgresql)에 연결하는 AWS EC2 인스턴스가 있습니다. RDS 인스턴스를 만들 때 DB 루트의 사용자 이름은 다음 my_user1과 같으며 비밀번호는 password1입니다. 이제 역할과 수퍼 유저를 만들려고합니다. 그러나 실패합니다. $ createuser -P -d -s -e my_user2 --host myhost.com -U my_user1 Enter password for new role: XXXYYYZZZ Enter it again: XXXYYYZZZ Password: …

1
Apache와 DFOREGROUND에 대해 혼동
그래서 Yum을 사용하여 새로운 CentOS 7 서버에 Apache를 설치했습니다. 나는 아파치를 여러 번 설치했지만 이것을 본 적이 없다. 지금 ps aux를 실행 하면 항상 보여진다. / usr / sbin / httpd -DFOREGROUND 구글은 프로세스가 포 그라운드에서 실행되고 쉘에서 분리되지 않는다는 것을 의미하지만 실제로 쉘이 닫히면 아파치가 죽을 것인가? 나는 정상적인 …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.