서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
내 Ubuntu Amazon EC2 인스턴스에서 시간이 잘못되었습니다
Amazon AWS (EU / 아일랜드)에 Ubuntu EC2 인스턴스가 3 개 있는데 모두 웹 서버로 설정되어 있습니다. 두 시스템 에서 시스템 날짜 / 시간이 올바르지 않은 것으로 나타났습니다 (표준 시간대는 항상 UTC로 설정되어 있음). 다음은 date -R내 PC (EU / 이탈리아, UTC보다 2 시간 빠름) 및 서버의 출력입니다. lorenzo@LOCALPC ~ $ …
15 amazon-ec2  ntp 

2
보조 IP 주소의 특정 포트에서 수신 대기하도록 netcat (또는 다른 주식 Linux 유틸리티)을 구성하려면 어떻게해야합니까?
CentOS 5.9 테스트 목적으로 CentOS 서버가 보조 가상 IP (eth0 : 0)에서 수신 대기하고 싶습니다. 나는 잘 알고 nc -l -p <port>있지만 기본에 귀를 기울입니다. 리스너가 사용할 특정 IP를 지정할 수있는 방법이 있습니까? 그렇지 않은 경우 CentOS 5.9에이를 수행 할 수있는 다른 "스톡"유틸리티가 있습니까?
15 linux  centos5  netcat 

1
파일에 추가하기 위해 cron 로그 가져 오기
첫째, 이것이 이것이 잘못된 스택 교환인지 유감이지만, 올바른 것으로 보입니다. 이것은 지금 내 crontab입니다. MAILTO=****@gmail.com 10,30,50 * * * * ~/webapps/****/apache2/bin/start */10 * * * * /usr/local/bin/python2.7 ~/webapps/****/WR/cron.py > ~/webapps/****/WR/cron.log 2>&1 그러나 출력이 cron.log 파일에 배치 될 때마다 모든 이전 컨텐츠가 대체됩니다. 어떻게 막을 수 있습니까? 또는 가능하지 않은 경우 …
15 linux  ssh  cron 

4
Linux 박스에서 동일한 스위치에 연결된 NIC를 식별하는 방법은 무엇입니까?
초기 설정 Linux 관리자는 6 개의 NIC eth0 ~ eth5를 가진 새로운 Linux 박스를 설치했습니다. eth0 인터페이스가 올바르게 구성되었고 다른 모든 인터페이스는 현재 작동하지만 IP 주소는 없습니다. 네트워크 담당자는이 상자에 케이블 4 개를 간단히 연결했습니다. 상자를 프로덕션 네트워크에 연결하는 데 2 ​​개의 LAN 케이블이 사용되고 상자를 개인 네트워크에 연결하는 데 …

2
Strongswan VPN 터널이 연결되었지만 트래픽이 라우팅되지 않음
방금 strongswan (4.5)으로 사이트 간 VPN 터널을 설정했습니다. 터널이 잘 보이고 다른쪽에 연결되어 있지만 터널을 통해 트래픽을 라우팅하는 데 문제가있는 것 같습니다. 어떤 생각? 감사! 네트워크 다이어그램 +----------------------------------+ |Dedicated server: starfleet | +-----------------+ | | | CISCO ASA | | +-------------------------| internet | | | |eth0: XX.XX.XX.195/29 +-------------------| YY.YYY.YYY.155 | …

1
Windows Server 2012 Standard에서 둘 이상의 원격 Windows 세션을 허용하는 방법은 무엇입니까?
최근에 새 2012 서버를 설정하십시오. 관리자가 아닌 일반 사용자 계정을 사용하여 서버에 2 개의 원격 Windows 연결을 만든 후에 세 번째 연결을 만들려고하면이 오류가 발생합니다. Select a user to disconnect so you can sign in There are too many users signed in 두 개의 관리자 연결 (실제 및 가상 하나) …

2
파일이 존재하는 IIS 404 오류
공급자 (Windows 2008 R2, IIS 7.5)에서 새로 VPS를 설치했습니다. 기본 웹 사이트는 정상적으로 작동합니다. http://5.9.251.167/ 새 웹 사이트를 만들고 http://new.ianquigley.com에 바인딩합니다. 해당 서버 및 도메인이 IP 주소에 매핑되는 다른 모든 서버에서. (예 : ping new.ianquigley.com). 하위 폴더 c:\inetpub\wwwroot\com.ianquigley를 만들고 index.html콘텐츠 " <html>cake</html>"를 사용하여 HTML 파일 을 만들었습니다. 웹 사이트의 기본 …

1
Amazon EC2 인스턴스에 mod_ssl 설치 및 구성
내 웹 사이트에서 mod_ssl 모듈로 HTTPS 트래픽을 지원하려고합니다. 내 서버에 Amazon EC2 인스턴스를 실행하고 있습니다. 기본 LAMP 패키지를 설치하고 구성했습니다. 내 아파치 설정 파일에 SSL 특정 명령에 넣어 갈 때 (즉. SSLEngine, SSLCertificateFile등)은 오류를 뱉어 내가 구문 오류가 있다고 말한다 또는 모듈이로드되지 않습니다. 나의 다음 단계는 시도했다 $ sudo yum …

1
iptables를 사용하면 IPSEC 터널을 통해 일치하는 패킷이 도착합니다.
터널 모드에서 IPSEC를 사용하고 있습니다. IPSEC 터널을 통해 도착한 패킷 만 일치하는 iptables 규칙을 만드는 방법 (예 : IPSEC가 해독 한 후 - 도착할 때와 해독 전에 IPSEC 패킷이 아님 ) 요점은 IPSEC를 통해서만 액세스 할 수 있고 다른 국가에서는 액세스 할 수없는 특정 포트를 갖는 것입니다.
15 linux  iptables  ipsec 

2
재부팅 후 PHP-FPM이 자동으로 시작되지 않습니다
PHP-FPM과 Nginx를 실행하고 있습니다. 때로는 어떤 이유로 든 서버를 재부팅해야합니다. 서버가 다시 실행되면 nginx 서비스가 자동으로 시작되지만 PHP-FPM은 그렇지 않습니다. 이것은 sudo /etc/init.d/php-fpm restart재부팅 직후 명령을 실행 하고 결과를 얻을 때 볼 수 있습니다 . $ sudo /etc/init.d/php-fpm restart Stopping php-fpm: [FAILED] Starting php-fpm: [ OK ] 이것이 예상되는 행동입니까? …

1
모든 MySQL 데이터베이스가 밤새 손실 됨
고객으로부터 웹 사이트가 다운되었다고 요청한 후 RackSpace Cloud Windows 2008 서버에서 MySQL이 실행되고 있지 않은 것으로 나타났습니다. MySQL을 다시 시작했지만 MySQL 데이터베이스가있는 모든 웹 사이트의 브라우저에서 '사용자가 액세스 거부되었습니다'오류가 발생했습니다. MySql Server 5.5 / data를 보면 mysql 및 performance_schema 이외의 폴더가 없습니다. 모든 데이터베이스와 데이터가 지워진 것 같습니다. 아무도 무슨 …
15 mysql5.5 

4
CentOS 6.x에서 Kernel 3.4로 업그레이드하려면 어떻게해야합니까?
커널 버전 2.6.32로 CentOS 6.2를 실행하는 서버가 있지만 애플리케이션 성능을 높여야합니다. 커널 버전 3.4에는 x32abi가있어 성능을 향상시킬 수 있으므로 3.4로 업그레이드하고 싶습니다. 가능합니까? 커널 컴파일 및 설치를 시도했지만 여전히 동일한 커널 버전이 표시됩니다. 무엇이 잘못 되었나요? 아래 링크에 언급 된 절차를 따랐습니다. http://www.tecmint.com/kernel-3-5-released-install-compile-in-redhat-centos-and-fedora/

3
꼭두각시와 출시 된 서비스?
Puppet으로 구성된 프로덕션 환경이 있으며 개발 시스템에서 Red Hats, Ubuntus 및 OSX를 혼합하여 유사한 환경을 설정할 수 있기를 원합니다. 예상대로 OSX는 여기서 이상한 사람이며 슬프게도이 작업을 수행하는 데 많은 문제가 있습니다. 첫 번째 시도는 macports다음 선언을 사용하여을 사용하는 것입니다. package { 'rabbitmq-server': ensure => installed, provider => macports, } 그러나 …
15 mac-osx  puppet 

2
sftp를 통한 심볼릭 링크 및 filezilla
데비안을 처음 접했고 서버를 설정하려고합니다. 폴더 /home/username와 하위 디렉토리 에만 액세스 할 수있는 사용자를 만들었습니다 . 이제 내가 설정 한 웹 서버에 해당 사용자를 사용하고 싶습니다. 액세스 권한을 부여 /var/www했지만 /var/wwwsftp를 통해 볼 수 없으며 다음과 같은 기호 링크를 수행했습니다. root@server:/home/username# ln -s /var/www www root@server:/home/username# cd www root@server:/home/username/www# chown …

1
Server 2012 Core에서 Powershell을 사용하여 파일 압축 해제
powershell을 사용하여 파일의 압축을 풀어야합니다. 내가 모든 사람이 이것을하는 것을 본 전형적인 방법은 스크립트로 쉘을 자동화하는 것입니다. $shellApplication = new-object -com shell.application $zipPackage = $shellApplication.NameSpace($zipfilename) $destinationFolder = $shellApplication.NameSpace($destination) $destinationFolder.CopyHere($zipPackage.Items()) Server Core에는 셸이 없으므로 자동화해야 할 것이 없기 때문에 이것은 작동하지 않습니다. E_FAIL COM 오류가 발생합니다. Powershell은 자체적으로 할 수없는 것처럼 …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.