서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

1
Linux : 로그 회전으로 생성 된 새로 생성 된 로그에 특정 권한을 적용하는 방법은 무엇입니까?
나는 생성되고있는 메일 로그 /var/log가 루트 (사용자와 그룹)에 의해 생성되고 소유되고 있음을 알아 차렸다 . 로그를 모니터링하는 Nagios 검사를 작성했으며 Nagios 사용자가 액세스 할 수 있도록 other그룹에 읽기 권한을 부여했습니다. chmod o+r /var/log/maillog 이제 내가 생각할 때 이것은 하나의 로그 파일입니다. 로그 파일이 채워지면 로그 회전 메커니즘 이이 파일의 이름을 …

6
활성 OpenVPN 클라이언트가있는 서버에서 SSH 허용
SSH로 연결하는 CentOS 7을 실행하는 VPS가 있습니다. 인터넷 트래픽이 VPN을 통해 라우팅되도록 SSH를 통해 서버에 연결할 수 있도록 VPS에서 OpenVPN 클라이언트를 실행하고 싶습니다. OpenVPN을 시작하면 SSH 세션 연결이 끊어지고 더 이상 VPS에 연결할 수 없습니다. 들어오는 SSH (포트 22) 연결을 VPS의 실제 IP (104.167.102.77)에서 열 수 있지만 VPN을 통해 나가는 …
15 ssh  openvpn 

3
Windows Server 2012에서 휴지통을 숨기려면 어떻게해야합니까?
Windows 8에서는 참 메뉴 표시 줄 > 설정 > 개인 설정 에 따라 휴지통 (및 바탕 화면의 다른 아이콘)을 숨길 수 있습니다 . 그러나 Server 2012에서는 "이 버전의 Windows에서는이 페이지를 사용할 수 없습니다"라는 메시지와 함께 빈 창이 나타납니다. Windows Server 2012에서 휴지통을 숨길 수 있습니까? 내가 찾은 대부분은 찾을 수없는 …

1
logrotate로 인해 Apache가 매번 결함을 일으키는 이유는 무엇입니까?
logrotateApache / 2.4.7 (Ubuntu)을 실행할 때마다 세그먼트 오류가 발생하고 다시 시작되지 않습니다. [Wed Sep 10 06:35:54.266018 2014] [mpm_event:notice] [pid 20599:tid 140630283466624] AH00493: SIGUSR1 received. Doing graceful restart [Wed Sep 10 06:35:54.885118 2014] [core:notice] [pid 20599] AH00060: seg fault or similar nasty error detected in the parent process 내 아파치 logrotate …

1
"낮은 주소 비트는 의미가 없습니다"는 무엇을 의미합니까?
인터넷에서 내 블로그의 로그인 페이지로 액세스를 제한하고 인트라넷에서만 사용할 수 있도록 노력하고 있습니다. 따라서 다음 위치를 정의했습니다. location ~/ghost/signing { allow 192.168.0.1/24; deny all; } 낮은 주소 비트 : 나는 다시 시작하면 Nginx에 나는 다음과 같은 경고를 얻을 수 192.168.0.1/24있는 의미가/etc/nginx/sites-enabled/site 또한 인트라넷에서 위치에 액세스 할 수 없습니다. 따라서 allow …
15 nginx 

1
nginx 구성 파일에서 긴 줄 나누기
쓰레기를 백엔드로 전달하지 않기 위해 location지시문에 대한 엄격한 정규식이 있습니다. 다음과 같이 보입니다 : location ^~ "/(some|stuff|more|bar|etc(-testing)?)/[a-zA-Z0-9]+/...(more|restrict).ext { # other directives } 80 자로 줄을 접고 싶습니다. 구성을 분할하는 방법이 있습니까? 다음과 같은 구문 오류가 발생하지만 찾고 있습니다. location ^~ "/(some|stuff|more|bar|etc(-testing)?)/[a-zA-Z0-9]+/"\ "...(more|restrict).ext" { # results in a literal newline (%0A) …

4
curl을 사용하여 파일에 나열된 URL을 다운로드 하시겠습니까? [닫은]
닫은. 이 질문은 주제에 맞지 않습니다 . 현재 답변을받지 않습니다. 이 질문을 개선하고 싶습니까? 서버 결함에 대한 주제가 되도록 질문을 업데이트하십시오 . 휴일 2 년 전 . 다운로드해야 할 모든 URL이 포함 된 파일이 있습니다. 그러나 한 번에 하나의 다운로드를 제한해야합니다. 즉, 다음 다운로드는 이전 다운로드가 완료된 후에 만 ​​시작해야합니다. …
15 curl 

1
어떤 크론 작업이 / usr / lib / sa / sa1입니까
컴퓨터에 로그 워치를 활성화했습니다. 갑자기 내 로그 워치에이 줄이 보입니다. /usr/lib64/sa/sa1 1 1 : 4297 times /usr/lib64/sa/sa2 -A : 29 times run-part /etc/cron.hourly : 716 crontab -e를 시도했지만 항목이 표시되지 않습니까?
15 centos  cron 

5
내 공개 웹 사이트 이름과 AD 도메인 이름이 동일합니다. 네트워크 내부에서 외부 웹 사이트에 접속하려면 어떻게해야합니까?
example.org회사에서 도메인 을 사용하고 있습니다 . www.example.org웹 사이트를 보는 데 사용할 수 있습니다 . http://example.org회사 외부에서 시도해 도 문제는 없지만 내부에서 시도하면 Windows DNS 서버가 도메인 컨트롤러의 IP를 제공합니다. 이 문제를 어떻게 해결할 수 있습니까? 내 DC example.org가 내 DNS에 등록되는 것을 막을 수 있습니까? 이것이 환경에 문제가됩니까?

8
Windows 2012의 명령 줄에서 서버 다시 시작을 예약하려면 어떻게해야합니까?
예를 들어 아침 일찍 업데이트 설치를 마치기 위해 일회성 서버 다시 시작을 예약하고 싶습니다. Windows 2012의 명령 줄에서 어떻게해야합니까? Windows 2008에서는 at명령 을 사용했을 것입니다 . at 2am shutdown -r -f -c "restart" 나머지 오후를 쉬었습니다. 그러나 Windows 2012에서이 명령을 실행하면 The AT command has been deprecated. Please use schtasks.exe …

2
IIS 8 asp.net mvc HTTP 오류 500.19
안녕하세요, 내 asp.net mvc 프레임 워크에 대해 서버를 이동했습니다. 그러나 이제 다음과 같은 오류 메시지가 표시되고 정직하게 말하면 무엇이 잘못되었는지 알 수 있습니까? 모듈 IIS 웹 코어 알림 시작 요청 처리기가 아직 결정되지 않았습니다 오류 코드 0x80070021 구성 오류이 구성 섹션은이 경로에서 사용할 수 없습니다. 이것은 섹션이 부모 수준에서 잠겨있을 …

2
리눅스에서 들어오고 나가는 대역폭과 레이턴시 제한
비슷한 질문이 많이 있었지만 지금까지 내 문제에 대한 해결책을 찾지 못했습니다. 나는 웹 사이트의로드 시간 증가 및 감소를 측정하기 위해 웹 사이트 속도 테스트에 사용하는 가상 Linux 서버 (Debian Squeeze 실행)를 가지고 있습니다. 웹 사이트에서 실제로드 시간에 근접 할 수 있도록이 서버의 대역폭과 대기 시간을 제한하려고했지만 지금까지 실패했습니다. 내가 구체적으로 …

4
SMART 자체 테스트는 불량 블록과 어떤 관련이 있습니까?
smartctl 도구를 사용하면 긴 자체 테스트 ( smartctl -t long /dev/sda)를 시작할 수 있습니다 . 그러나 badblocks드라이브에서 실행할 수도 있습니다. 두 사람은 어떻게 관련되어 있습니까? 불량 블록이 불량 블록을 감지하면 드라이브가 자동으로 SMART 값을 업데이트합니까 (예 : 재배치 된 섹터 수를 업데이트하여)? 배드 블록이를 대체 할 수 있습니까 smartctl -t …

3
nginx 대소 문자 구분 재 작성
내 nginx 리디렉션을 최대한 깨끗하게하려고합니다. ~ *는 대소 문자를 구분하지 않지만 예제 2에서만 작동하도록 이해할 수 있습니다. 실시 예 1 rewrite ^/foobar http://www.youtube.com/watch?v=oHg5SJYRHA0 redirect; 예 2-이 방법은 작동하지만 위의 줄만큼 효율적이지 않습니다. if ( $request_filename ~* foobar ) { rewrite ^ http://www.youtube.com/watch?v=oHg5SJYRHA0 redirect; } 너무 번거롭지 않고 예제 1로 대소 …
15 nginx  rewrite 

1
이 SSD 드라이브가 불량 섹터에서 실패하는 이유는 무엇입니까?
참고 :이 질문은 이전에 주제를 벗어난 것으로 마감되었습니다. 토론을 읽을 수 있습니다 . 여기에 묻는 나의 이유는 다음과 같습니다. 이 드라이브는 잠비아 시골의 학교를위한 오프라인 콘텐츠 캐시 서버에 있습니다. 서버는 디스크 이미지로 작성되며 모든 컨텐츠를 교체 할 수 있습니다. 잠비아의 학교는 예산이 제한되어 있고 많은 학교가 있기 때문에 저렴해야합니다. 또한 …
15 linux  hard-drive  ssd 

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.