서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
SQL Server 인스턴스 란 무엇입니까?
SQL Server 2008 Express를 설치할 때 인스턴스를 만들라는 메시지가 표시되고 인스턴스가 없으면 중단됩니다. 그런 다음 SQL Server 서비스의 Sql Server 구성 관리자 항목에 해당 정보가 표시됩니다. SQL Server 인스턴스 란 무엇입니까?


3
Kubernetes Pod에서 특정 UID로 볼륨을 마운트하는 방법은 무엇입니까?
따라서 Kubernetes 에서이 이미지를 기반으로 Nexus를 실행하려고 하지만 실패합니다. mkdir: cannot create directory '../sonatype-work/nexus3/log': Permission denied mkdir: cannot create directory '../sonatype-work/nexus3/tmp': Permission denied Java HotSpot(TM) 64-Bit Server VM warning: Cannot open file ../sonatype-work/nexus3/log/jvm.log due to No such file or directory 문서에서 프로세스는 UID 200으로 실행되며 볼륨은 해당 권한으로 마운트되어야합니다. A …

8
도커 풀 : TLS 핸드 셰이크 시간 초과
나는 이것을 꾸준히 얻습니다 (Ubuntu 16.04 LTS). $ docker pull nginx Using default tag: latest Error response from daemon: Get https://registry-1.docker.io/v2/: net/http: TLS handshake timeout 그러나 curl TLS는 제대로 작동합니다 (인증 오류 제외). $ curl https://registry-1.docker.io/v2/ {"errors":[{"code":"UNAUTHORIZED","message":"authentication required","detail":null}]} 그리고 작은 golang 프로그램 (도커를 모방 한)조차도 잘 작동합니다. package main import …

2
ECS의 역할 요구 사항과 혼동 됨
ECS를 설정하려고했지만 지금까지이 포럼에서 이미 몇 가지 질문을 작성한 권한 문제가 발생했습니다. 솔직히 말해서 이러한 역할 요구 사항을 모두 한곳에서 찾을 수 없기 때문에 지금까지 갇혀 있다고 생각합니다. 적어도 두 가지 역할을 정의해야합니다. 1) ECS 컨테이너 http://docs.aws.amazon.com/AmazonECS/latest/developerguide/instance_IAM_role.html 2) ECS 작업 http://docs.aws.amazon.com/AmazonECS/latest/developerguide/task-iam-roles.html#enable_task_iam_roles 맞습니까? 내가 놓친 것이 있습니까? 특별한 IAM 요구 사항이 …

4
정확히 URE 란 무엇입니까?
최근 RAID5 Vs RAID6을 살펴 보았으며 URE 등급과 드라이브 크기 증가로 인해 RAID5가 더 이상 충분히 안전하지 않다는 것을 계속 알고 있습니다. 기본적으로 내가 찾은 대부분의 내용은 RAID5에서 디스크 장애가 발생했을 때 나머지 어레이가 12TB 인 경우 거의 100 %의 확률로 URE를 충족시키고 데이터를 잃을 수 있다고 말합니다. 12TB 수치는 …

5
Rabbitmq-> epmd 보고서 : 노드 '토끼'가 전혀 실행되지 않습니까?
ubuntu@ip-172-31-21-62:~$ sudo service rabbitmq-server start * Starting message broker rabbitmq-server [ OK ] ubuntu@ip-172-31-21-62:~$ sudo service rabbitmq-server stop * Stopping message broker rabbitmq-server * message broker already stopped [ OK ] ubuntu@ip-172-31-21-62:~$ sudo service rabbitmq-server status Status of node 'rabbit@ip-172-31-21-62' ... Error: unable to connect to node 'rabbit@ip-172-31-21-62': nodedown DIAGNOSTICS …
14 ubuntu  rabbitmq 

2
컬 : 로컬 발급자 인증서를 가져올 수 없습니다. 디버깅하는 방법?
이상한 문제가 있습니다. LAMP dev 시스템 (Debian)을 PHP 7로 업데이트했습니다. 이후 Curl을 통해 특정 TLS 암호화 API에 더 이상 연결할 수 없습니다. 해당 SSL 인증서는 thawte에 의해 서명됩니다. curl https://example.com 나에게 준다 curl: (60) SSL certificate problem: unable to get local issuer certificate 이므로 curl https://thawte.com 물론 Thawte의 작품에도 서명되어 …

3
전달 메일 서버에 SRS 재 작성이 절대적으로 필요합니까?
내 도메인의 Postfix 이메일 서버를 운영하고 있습니다 (예 : mydomain.com). 대부분 전자 메일 전달 서버 역할을합니다. 사용자는 전자 메일 주소 @ mydomain.com을 받지만 일반적으로 외부받은 편지함 (Gmail, Yahoo 등)으로 주소를 전달하도록 선택합니다. 수천 개의 주소가 전달되므로 서버는 상당히 많은 양의 메일 트래픽을 처리합니다. 과거에는 서버가 SRS 재 작성을 사용하지 않았습니다. …

3
Apache 2.4는 URL을 특정 IP로 제한
특정 URL을 네트워크 외부에서 특정 IP 주소로만 사용할 수 있도록 제한하려고합니다. 외부 사용자가 IP 목록이 아닌 해당 URL에 액세스하려고하면 홈페이지로 리디렉션되어야합니다. 이것이 운없이 지금까지 시도한 것입니다. 마지막 부분은 IP에 관계없이 모든 사람을 홈페이지로 리디렉션합니다. <Location "/secret"> # <If "%{REMOTE_ADDR} != -ipmatch '123.123.123.123/255.255.255.255'"> # Redirect 303 "/secret" / # </If> RewriteCond …

2
패키지를 사용할 수 없으면 yum 오류
최근에 스크립트에서 버그가 발생하여 다음을 시도했습니다. yum -y install another_package.x86_64 some_package.x86_64 && run_my_script 이 스크립트는 최신 CentOS에서 잘 실행되었지만 Cent OS 5에서 실행하려고 시도했을 때 some_package.x86_64사용할 수 없었습니다. 그러나 오류와 중지 대신 yum메시지가 인쇄되었습니다. No package some_package.x86_64 available. yum스크립트를보다 강력하게 만들기 위해 이러한 상황 (기본값은 어떤 IMO)에서 오류를 강제 로 …
14 centos  yum  centos5 

2
HAProxy가 백엔드 서버에 대한 DNS를 찾도록 강제
나는 haproxy 1.5.8을 가지고 있는데, 그것은 우리가 통제 할 수없는 제 3 자에게 경로를 기반으로 일부 요청을 프록시합니다. 백엔드 서버의 IP는 시작시 한 번 확인되므로 IP가 변경되면 중단됩니다. 그 해결 방법이 있다면? nginx에서는 내부 변수를 선언하고 X 초 동안 캐시 할 수 있습니다. HAProxy에 대한 비슷한 솔루션을 찾지 못했습니다.

2
일부 SSL 오류로 인해 새 서버가 Puppetmaster에서 구성을 가져올 수 없습니다.
프로덕션 환경에있는 세 대의 컴퓨터에 일부 하드웨어 문제가있어 폐기되었습니다. 인프라 팀이이를 다시 설치하고 동일한 호스트 이름과 IP 주소를 제공했습니다. 목표는 이러한 시스템에서 Puppet을 실행하여 다시 시운전 할 수 있도록하는 것입니다. 시도 1) 다음 명령을 실행하여 이전 Puppet 인증서가 Puppetmaster에서 제거되었습니다. puppet cert revoke grb16.company.com puppet cert clean grb16.company.com 2) 이전 …

2
Nginx의 위치에 여러 프록시 엔드 포인트 제공
하위 경로 /api가 다른 끝점으로 이동 하는 단일 위치에서 서비스하려는 API 끝 점이 몇 개 있습니다 . 특히 webdis를에서 사용할 수 /api있고 독점 API를 에서 사용할 수 있기를 원합니다 /api/mypath. redis 명령 이름과 충돌하지 않을 가능성이있는 하위 경로를 사용하고 충돌을 피하기 위해 API 디자인을 완전히 제어 할 수 있기 때문에 …


당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.