서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
RSA 키를 푸른 키 저장소에 놓기
Azure Key Vault에 키 페어 (일반적으로 id_rsa 및 id_rsa.pub)를 저장하는 방법 공개 키를 내 GIT 서비스에 넣고 가상 머신이 Azure 키 저장소에서 개인 키를 다운로드하도록 허용하고-> GIT에 안전하게 액세스 할 수 있습니다. 한 쌍의 PEM 파일을 만들어 pfx에 결합하고 비밀 부로 업로드하면 파일이 pem 파일과 완전히 다른 것처럼 보입니다. 또한 …

9
OpenVPN 문제-60 초 내에 TLS 키 협상이 실패했습니다
Windows 2012 서버에서 OpenVPN (버전 2.3.10) 서버를 구성하고 있지만 작동시킬 수 없습니다. 서버는 라우터 뒤에 있으며 1194 포트를 열고이 포트의 트래픽을 서버로 전달하는 규칙을 만들었습니다. 클라이언트에서 연결을 시도 할 때 서버에 표시되는 로그는 다음과 같습니다. Mon Mar 21 11:11:47 2016 XX.XX.XX.XX:57804 TLS: Initial packet from [AF_INET]XX.XX.XX.XX:57804, sid=fdf7a7ac 0264c7f3 Mon Mar …
14 openvpn 

4
"RTNETLINK 답변 : 파일이 있습니다"/ etc / network / interfaces 2 개의 게이트웨이가 포함되어 있지 않습니다. 무엇이 잘못 되었습니까?
이것은 내 /etc/network/interfaces파일 내용입니다 이것이 적용되는 유일한 방법은 시스템을 재부팅 할 때입니다. 수동으로 적용하려고합니다. 아래의 나의 시도. auto eth0 iface eth0 inet static address 192.168.1.57 netmask 255.255.255.0 gateway 192.168.1.1 up ip addr add 192.168.0.57/24 dev eth0 label eth0:1 down ip addr del 192.168.0.57/24 dev eth0 label eth0:1 up ip route …

1
특정 위치에서만 클라이언트 인증서를 확인하는 Nginx
우리는 Nginx를 웹 애플리케이션 서버에 대한 리버스 프록시로 사용합니다. Nginx는 SSL을 처리하지만 그렇지 않으면 리버스 프록시 역할을합니다. 요청에 유효한 클라이언트 인증서가 /jsonrpc필요하지만 다른 곳에서는 요구하지 않습니다. 우리가 찾은 가장 좋은 방법은 server { listen *:443 ssl; ssl on; ssl_certificate /etc/nginx/server.crt; ssl_certificate_key /etc/nginx/server.key; ssl_client_certificate /etc/nginx/client-ca.crt; ssl_verify_client optional; location /jsonrpc { if …

1
대상의 IP 필터링을 기반으로 openVPN을 통해 특정 openVPN 트래픽 만 라우팅하는 방법은 무엇입니까? [닫은]
폐쇄되었습니다 . 이 질문은 더 집중되어야 합니다. 현재 답변을받지 않습니다. 이 질문을 개선하고 싶습니까? 이 게시물 을 편집 하여 한 가지 문제에만 집중할 수 있도록 질문을 업데이트하십시오 . 휴일 오년 전에 . 내가 본 DNS 프록시 서비스는 openvpn을 사용하고 VPN을 통한 DNS 트래픽으로 만 VPN의 위치 정보 사용자를 마스킹하고 사용자 …
14 openvpn  traffic 

3
전체 디스크 또는 파티션으로 ZFS zpool을 만들어야합니까?
FreeBSD 컴퓨터에서 zpool을 만들고 있습니다. zpool을 만드는 동안 다음 두 가지 경우를 관찰합니다. 내가 가져 와서 raw disks만들면 zpoolzpool을 형성 할 수 있으며 완벽하게 작동합니다. 내가 사용하는 디스크를 포맷하는 경우 gpart에 freebsd-zfs포맷을하고 다음 또한 완벽하게 작업은 zpool합니다. 내가 혼란스러워하는 것은 zpool을 만드는 데 어떤 접근법이 더 낫습니까?
14 unix  freebsd  partition  zfs  bsd 

4
nginx가있는 URL에서 후행 슬래시 제거
내 사이트의 다음 URL이 동일해야합니다. /foo/bar /foo/bar/ /foo/bar/index.html 또한 두 번째 두 양식이 첫 번째 양식으로 HTTP 301 리디렉션을 발행하고 싶습니다. 나는 단지 정적 페이지를 제공하고 있으며 세 번째 양식에 따라 정렬됩니다. 즉, 사용자가 요청 /foo/bar하면에 파일을 받아야합니다 /usr/share/.../foo/bar/index.html. 내 nginx.conf현재는 다음을 포함합니다 : rewrite ^(.+)/$ $1 permanent; index index.html; …
14 nginx 

5
/get/resolv.conf의 두 번째 네임 서버가 wget에 의해 선택되지 않았습니다
내 resolv.conf는 다음과 같습니다. ; generated by /sbin/dhclient-script search mcdc nameserver 10.0.4.48 nameserver 8.8.8.8 내가 nslookup www.google.com작동하면 nslookup www.google.com ;; Got SERVFAIL reply from 10.0.4.48, trying next server Server: 8.8.8.8 Address: 8.8.8.8#53 Non-authoritative answer: www.google.com canonical name = www.l.google.com. 그러나 www.google.com을 말리면 호스트를 확인할 수 없습니다. strace에서 curl을 실행하려고 시도했지만 …

2
tarball이 아닌 소스 디렉토리를 사용하여 RPM 빌드
조직에서는 RPM을 사용하여 모든 소프트웨어를 프로덕션 시스템에 배포합니다. 우리의 빌드 프로세스 (자동화 됨)는 버전 제어에서 소스를 체크 아웃하고 소스 디렉토리를 압축 해제 한 다음 해당 소스 tarball을 사용하여 rpmbuild를 실행합니다. rpmbuild는 해당 tarball 만 사용하여 소스를 untar하여 작업합니다. 따라서 전체 테이킹 및 언 타링 비즈니스는 빌드 프로세스에서 불필요한 추가 단계 …
14 rpm 

4
username @ domain 형식을 사용하면 Dovecot 사용자 조회가 실패합니다
FreeBSD 서버에 Dovecot v2.0.11이 설치되어 있으며 수신 이메일 주소에 대한 사용자 조회는 실패하지만 시스템 사용자에 대한 조회는 성공적입니다. Dovecot은 시스템 사용자를 사용하도록 설정되어 있으므로 dovecot.conf는 userdb { driver = passwd } 과 passdb { driver = passwd } 인증 디버그를 사용하도록 설정했습니다. 예를 들어, webmaster라는 사용자가 있으며 "webmaster"에 doveadm user를 …

2
scp가 대상 파일을 덮어 쓰지 않는 이유는 무엇입니까?
명령을 통해 파일을 백업하려고합니다. scp /tmp/backup.tar.gz 호스트 이름 : /home/user/backup.tar.gz 그것을 실행하면 scp 진행률 표시 줄이 나타나고 파일을 전송하는 것처럼 보이지만 대상 서버에 로그인하여 파일을 확인하면 타임 스탬프와 파일 크기가 이전 버전에서 변경되지 않았으므로 scp는 이전 파일을 전혀 덮어 쓰지 않았습니다. 대상 서버에서 파일을 수동으로 삭제할 때만 작동합니다. 우분투를 실행 …


2
쿠키에 대한 정보를 어떻게 기록합니까?
쿠키 정보를 Apache 액세스 로그에 추가하고 싶습니다 (예 : 이메일, 사용자 이름 (쿠키는 Apache가 아니라 php 파일로 생성됨)). 나는 뭔가를 추가 할 수 log.conf에 유사한 파일 : \"%{cookieName}i\"에 LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined 그래도 작동하지 않으면 쿠키 로그를 사용하여 액세스 로그와 결합하는 방법은 무엇입니까?
14 apache-2.2 


4
systemctl이 내 서비스를 인식하지 못합니다 : Default-Start에 런레벨이 없습니다.
우분투 서버 16.10에서 부팅 할 때 시작되는 간단한 서비스를 정의하고 싶습니다. 그래서 나는/etc/init.d/mydaemon 나는 어떻게 든 upstart와 systemd를 엉망으로 만들었습니다. 처음에는 upstart 서비스를 설정해야한다고 생각했습니다. 따라서 파일을 시작 구문으로 변환 한 후을 실행했습니다 update-rc.d mydaemon defaults. 내 오류를 파악하고 실행 update-rc.d mydaemon remove하여 시스템 구문으로 변환하고 실행 systemctl enable mydaemon했지만 …
14 ubuntu  systemd 

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.