서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

1
OpenSSH SFTP 서버는 put 명령 (chrooted environment) 후에 umask를 사용하거나 클라이언트 측 권한을 유지합니까?
나는이 질문이 이미 논의되었다는 것을 알고 있지만, 게시물을 읽음으로써 일부 답변은 "예 umask는 작동 할 수있다"고 말하고 다른 사람들은 "OpenSSH put 명령은 항상 권한을 유지한다"고 대답합니다. 무엇보다도 정확하게 : RHEL 6.2에서 OpenSSH 5.9를 사용합니다. umask internal-sftp와 함께 서브 시스템을 사용하여 chroot 된 SFTP 서버를 구성했습니다.-u 0002 나는 -p또는 -P옵션을 사용하지 …
13 ssh  sftp  umask 

4
자바 프로세스로 높은 CPU / IO에 매달려있는 PS AUX
Java 프로세스 및 nrpe 확인에 문제가 있습니다. 32 코어 시스템에서 때때로 1000 % CPU를 사용하는 일부 프로세스가 있습니다. 당신이 할 때까지 시스템은 꽤 반응합니다 ps aux 또는 / proc / pid #에서 무언가를 시도하십시오. [root@flume07.domain.com /proc/18679]# ls hangs.. ps aux의 strace stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2819, ...}) = 0 stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2819, …

4
단일 VirtualHost (푸들)에 대해 Apache에서 SSLProtocol을 설정할 수 있습니까?
웹 서버에서 SSLv3를 비활성화 하는 푸들 취약점에 대한 패치를 테스트하려고 합니다. 프로덕션 환경이 아닌 환경에서이를 먼저 테스트하기 위해 다른 테스트 서버의 VirtualHost에서 SSLProtocol을 설정합니다. 내 구성은 다음과 같습니다. <VirtualHost *:443> SSLEngine On SSLProtocol All -SSLv2 -SSLv3 ServerName test.mysite.com # bunch of other stuff omitted </VirtualHost> 그러나 아파치를 다시 시작한 후에도 …

1
콘솔에 이름을 입력하는 PuTTY
Putty를 사용하여 SSH를 통해 MySQL 덤프를하고 있었고 지금은 콘솔에 PuTTY를 반복해서 입력하고 있으며 Ctrl + C는 아무것도하지 않습니다. 왜 이런 일이 일어나는지 아십니까?
13 mysql  ssh  terminal  putty 

1
MDT 작업 순서 중 Powershell AD 모듈 가져 오기
이 짧은 powershell 스크립트를 작성하여 MDT 작업 순서의 일부로 컴퓨터의 이름을 바 꾸었습니다. Import-Module ActiveDirectory $AdminUsername = 'domain.com\administrator' $AdminPassword = 'password' | ConvertTo-SecureString -asPlainText -Force $cred = New-Object System.Management.Automation.PSCredential -ArgumentList $AdminUsername, $AdminPassword $Domain = Get-ADDomainController –DomainName domain.com -Discover -NextClosestSite $Site = $Domain.Site $DomainComputer = Get-WmiObject Win32_BIOS $Serial = $DomainComputer.SerialNumber $Computername …

2
DHCP에서 항상 DNS를 업데이트하는 데 단점이 있습니까?
DNS 및 DHCP 서버를 실행하는 Windows 2012 도메인 컨트롤러가 있습니다. 기본 설정 은 DHCP 클라이언트가 요청한 경우에만 DNS A 및 PTR 레코드를 동적으로 업데이트 하는 것으로 나타납니다 . (이것은 Scope Properties-> 아래에 있습니다 DNS) DNS A 및 PTR 레코드를 항상 동적으로 업데이트 를 선택하면 단점이 있습니까? 업데이트를 요청하지 않는 DHCP …

3
페도라와 우분투에서 다르게 행동하는 grep
Fedora에서 이것을 실행하면 다음과 같이 보입니다. $ ls hmm_data/indivA12_AATAAG/refs/par1/ 2R-orths.alleles 2R-ref.alleles $ ls hmm_data/indivA12_AATAAG/refs/par1/ | grep -F '-ref.alleles' 2R-ref.alleles 그러나 우분투 (동일한 데이터)를 실행할 때 grep에서 결과를 얻지 못합니다. $ ls hmm_data/indivA12_AATAAG/refs/par1/ 2R-orths.alleles 2R-ref.alleles $ ls hmm_data/indivA12_AATAAG/refs/par1/ | grep -F '-ref.alleles' 무슨 일이 벌어 질지 알아? 두 시스템에서 동일하게 작동하는 …
13 ubuntu  bash  fedora  grep 



2
New-ADUser-이름 길이가 너무 깁니다
AD의 OU에 약 500 명의 사용자를 추가해야합니다. 필요한 모든 것을 스크립트로 작성했지만 오류가 발생합니다. the name provided is not a properly formed 여기 스크립트가 있습니다 New-ADUser -Name C080CAB1-9756-409F-914D-AE3971F67DE7 -Path "OU=Staging,DC=domain,DC=local" -accountPassword (convertto-securestring "zagreb+scotch8355" -asplaintext -force) -PasswordNeverExpires $True -CannotChangePassword $false -Enabled $true 문제가 무엇인지 자백하기 위해 몇 가지 테스트를 실행했습니다. New-ADUser …

5
Apache 2.4 proxy_balancer 및 lbmethod_byrequest
정적 모듈로 Apache 서버를 빌드하려고합니다. 그러나 proxy_balancer 모듈에 문제가 있습니다. 오류가 발생합니다. [ssl:info] [pid 11863] AH01876: mod_ssl/2.4.10 compiled against Server: Apache/2.4.10, Library: OpenSSL/1.0.1i [proxy:crit] [pid 11868] AH02432: Cannot find LB Method: byrequests [proxy_balancer:emerg] [pid 11868] (22)Invalid argument: AH01183: Cannot share balancer [:emerg] [pid 11868] AH00020: Configuration Failed, exiting 내가 사용하는로드 …


4
Java ON A SERVER 자체가 안전하지 않다는 것을 관리자에게 알리는 방법은 무엇입니까?
신청 우리는 일부 Camel 경로를 사용하여 웹 서버에서 업로드 된 파일을 가져 와서 처리하고 결과가 담긴 전자 메일을 보내는 작은 Java 응용 프로그램이 있습니다. 이 애플리케이션이 실행중인 서버가 폐기되었습니다. 지금은 웹 서버 (실제로는 다목적 서버)에 JRE를 설치하도록 관리자를 설득 할 수 없기 때문에 저전력 하드웨어에서이를 실행해야합니다. 공포 저는 Java Application …

3
“스도 수-”가 나쁜 습관으로 간주됩니까?
배경 나는 그 차이를 알고있는 사이 su -, sudo su -및 sudo <command>: su - -사용자를 루트로 전환하고 루트 암호가 필요합니다 sudo su - -사용자를 루트로 전환하고 현재 사용자의 비밀번호 만 필요 sudo <command>-특정 명령에 대해서만 루트 액세스 권한을 부여합니다. 현재 사용자의 비밀번호 만 필요 제 질문은 sudo su -프로덕션 …
13 linux  unix  sudo  su 

1
CentOS 7에서 systemctl이 redis-server를 시작하지 않는 이유는 무엇입니까?
새 CentOS 7 상자에 redis를 설치했지만 systemctl을 사용하여 시작할 수 없습니다. 다음과 같이 설치되었습니다. rpm -i http://dl.fedoraproject.org/pub/epel/beta/7/x86_64/epel-release-7-0.2.noarch.rpm yum install redis 다음과 같이 시작하려고 시도하면 자동으로 실패한 것 같습니다 (출력이 없음). systemctl start redis-server # also tried redis-server.service 연결하려고 할 때 발생하는 상황은 다음과 같습니다. redis-cli Could not connect to Redis …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.