서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

3
재부팅시 ZFS 데이터 세트가 사라짐
Centos 7에 ZFS (0.6.5)를 설치했으며 zpool도 만들었습니다. 재부팅시 데이터 세트가 사라진다는 사실과는 별개로 작동합니다. 다양한 온라인 리소스와 블로그를 사용 하여이 문제를 디버깅하려고했지만 원하는 결과를 얻지 못했습니다. 재부팅 후, 나는이 실행할 때 zfs list명령을 내가 얻을 "사용 가능한 데이터 셋" 하고 zpool list있습니다 "아니오 풀 가능" 온라인으로 많은 연구를 수행 한 …


5
동적 IP를 사용하는 Amazon EC2 보안 그룹 인바운드 규칙
EC2 보안 그룹의 잠재적 문제로 보이는 사항에 대한 설명을 찾고 있습니다. 리눅스 인스턴스에 연결하기 위해 보안 그룹을 설정하고 있습니다. HTTP 및 HTTPS 액세스에 대한 "어디서나"규칙을 만들었습니다. SSH 규칙의 경우 Amazon 자습서에서는 공개 IP 주소에 대한 인바운드 액세스를 제한 해야한다고 말합니다 . 내가 얻지 못하는 것은 공용 IP 주소가 동적 인 …

1
LUKS로 주문형 암호화 볼륨 생성
Linux에서 필요에 따라 암호화되고 필요에 따라 파일 시스템을 만들려고합니다. LUKS와 cryptsetup에 익숙합니다. 빈 파일을 만들 수 있습니다. fallocate -l 512M /root/image LUKS 컨테이너를 만들 수 있습니다. cryptsetup -y luksFormat /root/image 그런 다음 "열기": cryptsetup luksOpen /root/image luksvolume 이 시점에서 파일 시스템을 만들 수 있습니다. mkfs.ext4 -j /dev/mapper/luksvolume 이것은 모두 훌륭하고 …

2
Nginx 다중 뿌리
요청을 특정 하위 디렉토리, 다른 루트 위치로 전환하고 싶습니다. 어떻게? 내 기존 블록은 다음과 같습니다 server { listen 80; server_name www.domain.com; location / { root /home/me/Documents/site1; index index.html; } location /petproject { root /home/me/pet-Project/website; index index.html; rewrite ^/petproject(.*)$ /$1; } # redirect server error pages to the static page /50x.html …

4
Linux에서 KVM 장치 패스 스루를 어떻게 활성화합니까?
MSI-GD65 게임 마더 보드와 Intel i7 4790이 있습니다. BIOS의 CPU 기능 섹션에서 VT-D를 사용할 수 있습니다. Ubuntu 14.04.1 LTS를 실행 중이며 장치를 분리하려고 할 때 다음 메시지가 나타납니다. # virsh nodedev-detach pci_0000_00_1f_2 오류 : 장치를 분리하지 못했습니다. pci_0000_00_1f_2 오류 : 지원되지 않는 작업 : 현재이 시스템에서 VFIO 또는 KVM 장치 …

1
t-online.de 블랙리스트 "호스트가 나에게 말을 거부했습니다"(BL)
서버가 t-online.de의 emailadress로 메시지를 보내려고 며칠 동안 다음과 같은 오류 메시지가 나타납니다. host mx02.t-online.de[194.25.134.9] refused to talk to me: 554 IP=xx.xx.xx.xx - A problem occurred. (Ask your postmaster for help or to contact tosa@rx.t-online.de to clarify.) (BL) 여러 포럼 에서 (BL) 부록이 없는 이 문제 는 하루에 100 개 이상의 …
13 email  postfix 

6
MySQL은 원격 연결을 거부합니다
방금 mysql (percona 5.5)으로 새로운 우분투 서버를 설치했지만 원격 호스트의 연결을 수락하지 않습니다. 이 서버에 원격으로 연결하려고하면 어떻게됩니까? mysql -h10.0.0.2 -uroot -pmypassowrd ERROR 2003 (HY000): Can't connect to MySQL server on '10.0.0.2' (111) telnet 10.0.0.2 3306 Trying 10.0.0.2... telnet: Unable to connect to remote host: Connection refused mysql이 원격 연결을 …
13 mysql 

4
모든 가상 호스트에 대해 nginx에서 robots.txt를 전역으로 설정하는 방법
robots.txtnginx http 서버 아래의 모든 가상 호스트 를 설정하려고 합니다. 나는 다음을 main에 두어 Apache에서 할 수있었습니다 httpd.conf. <Location "/robots.txt"> SetHandler None </Location> Alias /robots.txt /var/www/html/robots.txt 아래의 (a) nginx.conf 및 (b) conf.d / robots.conf를 포함하여 nginx와 비슷한 작업을 시도했습니다. location ^~ /robots.txt { alias /var/www/html/robots.txt; } 나는 '='로 시도했고 심지어 …
13 nginx  robots.txt 


3
로드 밸런서 뒤에 ngnix를 사용하여 http를 https로 다시 작성
Rackspace로드 밸런서를 사용하여 관리자 패널 내에서 SSL 키 / pem을 설정할 수 있습니다. 모든 것이 잘 작동합니다 .http 및 https 프로토콜을 모두 사용할 수 있습니다. 그러나 다음을 사용하여 http를 https로 리디렉션하려고하면 : server{ listen *:80; server_name mydomain.com www.mydomain.com; rewrite ^ https://mydomain.com$request_uri? permanent; ... 리디렉션 루프가 발생합니다. 포트 443을 듣고 있지 …

2
할당되지 않은 파티션없이 USB 드라이브 이미지 생성
내 시스템에 다음과 같은 8GB USB 드라이브가 연결되어 있습니다. [root@host]# fdisk -l /dev/sdb Disk /dev/sdb: 8462 MB, 8462008320 bytes 255 heads, 63 sectors/track, 1028 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 …
13 clone  dd 

6
이 서버가 해킹되었거나 로그인 시도입니까? 로그 참조
누군가 이것이 무엇을 의미하는지 말할 수 있습니까? lastb마지막 사용자 로그인을 보는 것과 같은 명령을 시도했지만 중국에서 이상한 로그인이 발생했습니다 (서버는 EU, EU에 있습니다). 이것이 로그인 시도 또는 성공적인 로그인이 될 수 있는지 궁금합니다. 이들은 매우 오래된 것으로 보이며 일반적으로 포트 22를 내 IP에만 고정합니다. 포트를 잠시 동안 열어 놓았다고 생각합니다. …
13 ssh  log-files  login  hacking 

4
명령 줄에서 파일 범위 복사 (ZSH / BASH)
연속 번호가 접미사로 포함 된 파일 목록이 있습니다. 이 파일들 중 일부만 복사하고 싶습니다. 내 cp 명령의 일부로 범위를 지정하는 방법 $ls P1080272.JPG* P1080273.JPG* P1080274.JPG* P1080275.JPG* P1080276.JPG* P1080277.JPG* P1080278.JPG* P1080279.JPG* P1080280.JPG* P1080281.JPG* P1080282.JPG* P1080283.JPG* P1080275.JPG에서 P1080283.JPG로 파일을 복사하고 싶습니다. $cp P10802[75-83].JPG ~/Images/. 이것을 할 수있는 방법이 있습니까?
13 linux  bash  copy  zsh 

3
긴 배치 파일 또는 프로그램을 실행할 때 키를 누를 때까지 Windows 명령 프롬프트가 중단되는 이유
명령 프롬프트 / powershell에서 Enter 키를 누를 때까지 두 번의 Windows 7 실행이 중단되었습니다. 이후 실행은 예상대로 계속되는 것 같습니다. 먼저 다음과 같은 복사 명령의 배치 파일이었습니다 copy //host/file2010-1*xml localfolder/01/ copy //host/file 2010-2*xml localfolder/02/ 파일 하나가 오래 걸리는 것 같습니다. 폴더를 확인한 후 폴더가 완성되었고 Enter 키를 누르고 갑자기 나머지 …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.