서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

1
소프트웨어 종속성 문제를 도와 줄 수 있습니까?
이것은이다 캐 노니 컬 질문 컴파일 종속성 및 패키지 관리에 대한. 포트 / 소프트웨어 컴파일 또는 * nix 서버에 RPM 설치에 관한 질문이 있습니다. 이 작업을 시도하면 누락 된 종속성에 대한 많은 메시지가 나타납니다. 서버 결함 커뮤니티가 도움을 줄 수 있습니까?
12 unix  dependencies  rpm 

1
nginx가 SNI로 먼저 보내는 SSL 인증서를 정의하는 방법은 무엇입니까?
약 30 개의 도메인에 대해 Debian Squeeze에서 OpenSSL 0.9.8o와 함께 nginx 1.2.7을 사용합니다. 그중 두 가지에서 SSL을 사용하도록 설정했습니다. SSL 구성은 두 도메인 모두에 사용됩니다. listen 443 ssl; ssl_certificate /etc/nginx/ssl/example.org-unified.crt; ssl_certificate_key /etc/nginx/ssl/example.org.key; ssl_protocols TLSv1 TLSv1.1 TLSv1.2; ssl_ciphers AES128-GCM-SHA256:ECDHE-RSA-AES128-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH; ssl_prefer_server_ciphers on; ssl_session_cache shared:SSL:10m; ssl_session_timeout 10m; add_header Strict-Transport-Security max-age=600000; ssllabs.com checker로 두 …
12 nginx  ssl  sni 

2
"sys"및 "adm"그룹의 정식 사용은 무엇입니까?
초창기 이후 (또는 어쨌든 내가 기억하는 한) 리눅스 시스템은 "sys"와 "adm"그룹을 가지고있다. 그것들을 정식으로 사용하는 것은 무엇입니까? "슈퍼 사용자"그룹 중 하나를 사용하는 것이 적절합니까? (디렉토리, sudoers 등의 그룹 권한).

1
MSIZAP이 여전히 유용합니까, 아니면 더 이상 사용되지 않습니까?
그룹 정책으로 설치된 MSI 파일을 사용하여 플래시를 업데이트합니다. 그러나 모든 업데이트에서 약 3 분의 1의 워크 스테이션이 업데이트되지 않습니다 (Windows Vista 및 Windows 7 32/64 비트 버전). 이벤트 로그에이 메시지가 나타납니다. "Adobe Flash Player 11 ActiveX-오류 1714. 이전 버전의 Adobe Flash Player 11 ActiveX를 제거 할 수 없습니다. 기술 지원 …

3
net.netfilter.nf_conntrack_buckets를 설정하는 올바른 장소는 어디입니까?
현재 부팅시 net.netfilter.nf_conntrack_buckets를 설정하려고합니다. 처음에는 이것이 sysctl.conf를 통해 수행 될 수 있다고 가정했지만 net.netfilter.nf_conntrack_buckets (및 기타 net.netfilter 구성)는 전혀 적용되지 않았습니다. sysctl -p를 rc.local에 추가하면 net.netfilter.nf_conntrack_buckets를 제외한 모든 net.netfilter 구성을 적용 할 수있었습니다. 또한 sysctl -w를 사용하여 터미널에서 이것을 설정하면 '오류 : 키'net.netfilter.nf_conntrack_buckets에서 권한이 거부되었습니다 '가 발생합니다. # This should …

2
iptables는 몇 개의 규칙을 지원할 수 있습니까?
누군가 최근에이 질문을했는데 답이 없었습니다. 나는 이것이 일종의 개방형 질문이라는 것을 알고 있지만 테이블 / 체인에 설치할 수있는 규칙의 수에 제한이 있습니까? 그렇다면 어떻게 알 수 있습니까? 기계마다 다를 것 같아요.
12 iptables 

5
Amazon EC2 인스턴스를 종료 한 후 다시 시작하면 모든 것이 정상입니까?
Amazon EC2 Linux 기반 인스턴스에서 실행되는 웹 사이트가 있으며 일반 도메인 이름 (x.com)에 매핑되어 있습니다. 이 사이트는 두 번째 EC2 인스턴스의 데이터베이스와 통신합니다. 이 인스턴스를 종료하고 그 뒤에 컴퓨팅 성능을 높여야합니다. 그렇게하면 시간이 얼마나 걸리고 컴퓨터를 다시 가동 할 때 내 사이트가 온라인으로 돌아 오게됩니까? IP 주소, DNS 정보 등이 …

7
"장치에 공간이 남아 있지 않은"다른 이유가 있습니까?
HD를 외장 USB 3.0 드라이브에 백업하기 위해 Ubuntu 서버 시스템에서 Dirvish를 사용하고 있습니다. 며칠 전까지는 모든 것이 제대로 작동했지만 이제 모든 장치에 "공간이 남아 있지 않습니다 (28)"및 "파일 시스템이 가득 찼습니다"라는 오류로 모든 백업이 실패합니다. 불행히도 그렇게 간단하지 않습니다. 장치에 500GB가 넘는 여유 공간이 있습니다. 세부: rsync_error : rsync: write …

2
도메인 컨트롤러가 라우터로 인해 고유 한 로컬 주소에 대한 광고를 보내 게되는 이유는 무엇입니까?
저는 현재 소규모의 이기종 Linux 및 Windows 워크 스테이션 및 서버 네트워크에서 도메인 컨트롤러 역할을하기 위해 Server 2012를 평가하고 있습니다. 이것은 100 % 듀얼 스택 네트워크입니다. 모든 장치에는 IPv4 및 IPv6 연결이 있습니다. 라우터는 radvd 1.9.1을 실행하는 Linux 서버 및 기타 다양한 필수 요소입니다. 방금 첫 번째 도메인 컨트롤러를 설치했습니다. …

4
yumdownloader vs repotrack
CentOS 6.3에서 일하고 있습니다. 최근에에서 repotrack왔습니다 yum-utils. yumdownloader --resolve그리고 repotrack외모와 매우 유사하지만, 보이는 yumdownloader다운로드 의존성의 일부분 만, repotrack모든 종속성. 단지 시도 yumdownloader --destdir=/tmp/download --assumeyes --resolve parted 대 repotrack parted 차이점은 무엇이며 yumdownloader --resolve그리고 repotrack?
12 centos  redhat  yum 

4
kdump / crash를 사용하여 OOM 문제를 조사하는 방법은 무엇입니까?
문제 여러 개의 "메모리 부족"메시지가 나타난 후 서버가 충돌하여 범인을 정확히 찾아 내려고합니다. 그것이 userland에 있다면-어느 프로세스. 그것이 커널에 있다면-어떤 커널 모듈. 세부 충돌 유틸리티를 사용하여 서버에서 OOM을 트리거 한 원인을 조사 하는 방법을 찾으려고 합니다. 새로운 서버 쌍을 설치하는 과정에서 14TB DRBD 장치 의 초기화를 시작했습니다 . 그 당시 …

7
권한을 문서화 / 추적하는 방법
저는 Windows 관리자이므로 Windows와 통합 된 사람들이 가장 도움이 될 것입니다. 이 시점에서 나의 주된 과제는 파일 공유에 관한 것이지만 SharePoint 사용이 증가함에 따라이를 어렵게 만들뿐입니다. 모든 디렉토리를 설정했으며 필요한 최소 액세스 정책으로 설정된 많은 보안 그룹이 허용됩니다. 내 문제는 HR 및 규정 준수 이유로 모든 것을 추적하는 것입니다. 사용자 …

2
Linux에서 클라이언트 측 NFS 장애 조치를 수행하는 방법
NFS 스토리지에 액세스해야하는 CentOS 6.3 클라이언트가 있습니다. 클러스터 된 파일 시스템을 사용하여 SAN에 저장된 동일한 컨텐츠를 제공하는 두 개의 NFS 서버가 있습니다. 필요한 경우 CentOS를 백업 NFS 서버로 장애 조치하도록 설정하려면 어떻게해야합니까? Google에서 Linux를 지원하지 않는다는 것을 계속 읽었지만 클러스터 Linux NFS 서버 팜을 설정하는 방법에 대한 많은 정보가 있기 …

2
왜 chroot가 안전하지 않은 것으로 간주됩니까?
나는 몇 년 동안 CentOS 상자를 가지고 놀았습니다. 그래서 나는 터미널에 꽤 편안합니다. 그러나 chroot가 안전하지 않다고 주장하는 블로그 게시물을 많이 읽었습니다. 정말 그래요? 왜? 나는 chroot를 사용하여 쉘이나 명령없이 SFTP 전용 사용자를 특정 컨텍스트에서 잠급니다. 실제로 보안 문제는 무엇입니까? 질문이 StackOverflow 에서 추방되었습니다 .

1
ProxyPass에서 Apache httpd 오류“proxy : ap_get_scoreboard_lb”
Tomcat의 프록시로 아파치를 설정했지만 페이지를 타겟팅 할 때 다음 오류가 발생합니다. 때때로 빈 페이지 나 503이 나타납니다. [오류] [Mon Dec 03 04:58:16 2012] [error] proxy: ap_get_scoreboard_lb(2) failed in child 29611 for worker proxy:reverse [Mon Dec 03 04:58:16 2012] [error] proxy: ap_get_scoreboard_lb(1) failed in child 29611 for worker https://localhost:8443/ [Mon Dec …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.