서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
현재 보류중인 섹터 및 오프라인 수정할 수없는 원인 증가 후 0으로 감소
일주일 동안 3TB Seagate 드라이브 (ST3000DM001-1CH166)의 경우 smartd는 오프라인으로 수정할 수없고 현재 읽을 수없는 (보류중인) 섹터 수가 느리게 증가하는 것으로보고했다가 마지막으로 카운트가 0이되고 오류 상태가 될 때까지 감소하는 숫자를보고했습니다 초기화. 로그에서 (변경 사항 만 표시) : Jul 6 18:04:57 x smartd[462]: Device: /dev/sdb [SAT], 8 Currently unreadable (pending) sectors Jul …
12 smart  seagate 

5
GRUB“일부 모듈에 코어 이미지가 누락되었을 수 있습니다”경고
하나의 HDD가 RAID에서 충돌하여 새 HDD를 추가했습니다. 이제 GRUB을 새 HDD에 설치하고 싶습니다 grub-install /dev/sdb. 이 경고가 나타납니다. Installing for i386-pc platform. grub-install: warning: Couldn't find physical volume `(null)'. Some modules may be missing from core image.. grub-install: warning: Couldn't find physical volume `(null)'. Some modules may be missing from …
12 ubuntu  kernel  grub  grub2 

1
x86, i386, i686, amd64, i5, i7, 아키텍처, 프로세서 혼란 [폐쇄]
닫은. 이 질문은 주제에 맞지 않습니다 . 현재 답변을받지 않습니다. 이 질문을 개선하고 싶습니까? 서버 결함에 대한 주제가 되도록 질문을 업데이트하십시오 . 휴일 오년 전에 . 나는 x86, i386, i686, amd64, i5, i7, 아키텍처 , 웹 프로세서 , 내 노트북, 책 읽기에서 이러한 항목을 발견했습니다 . 그러나 나는 그 용어에 …

4
왜 mtr이 traceroute보다 훨씬 빠릅니까?
에서 mtr맨 페이지, 그것을 읽 mtr은 단일 네트워크 진단 도구에서 추적 경로 및 핑 프로그램의 기능을 결합합니다 나는 mtr많이 사용 하고보다 훨씬 빠릅니다 traceroute. 본능적으로, 매 초마다 각 IP 주소 mtr를 traceroute나열 하면서 나에게 정중하게 대답 합니다. 내 컴퓨터에서 나는을 사용 time mtr www.google.com했고 time traceroute www.google.com결과는 21.9s VS 6.1s입니다. …
12 networking  mtr 

3
nginx에 대해 요청 당 고유 ID를 기록하는 방법이 있습니까?
이것에 대한 몇 가지 타사 모듈이있는 것으로 보입니다 https://github.com/newobj/nginx-x-rid-header https://github.com/hhru/nginx_requestid 그러나 가능하다면 nginx를 다시 빌드하고 싶지 않습니다.이 두 모듈을 모두 사용해야합니다. 내 초기 시도는 작동하지 않았지만 $msec함께 사용하려고 $pid했습니다 (프로세스는 동일한 밀리 초에 두 개의 요청을 처리했습니다). 나는 읽었 $connection으며 그와 함께 작동하는 것 같습니다 $msec. 타사 모듈을 사용하지 않고도 …
12 ubuntu  nginx 

4
프라이빗 VPC 서브넷에서 Amazon S3에 액세스
VPC가 실행 중이고 Amazon S3에서 파일을 다운로드하여 백엔드 처리를 수행하는 해당 서버의 개인 부분에 일부 서버가있는 경우 내부적으로 S3에 액세스하여 해당 파일을 가져올 수 있습니까? 아니면 NAT를 통해 공용 인터넷에 액세스하고 https를 통해 s3 파일을 다운로드 한 다음 처리해야합니까?

3
IIS가있는 동일한 서버의 SNI 및 와일드 카드 SSL 인증서
IIS 및 SSL을 사용하여 두 번째 수준 도메인 (예 : domain2.com, domain3.com) 바로 아래에있는 여러 웹 사이트와 함께 하위 도메인 (예 : sub.domain.com)을 수신해야하는 웹 사이트를 호스팅하고 싶습니다. 하위 도메인이있는 웹 사이트의 경우 와일드 카드 인증서 (* .domain.com)가 있으며 다른 사이트 (domain2.com 및 domain3.com)에 대한 인증서도 있습니다. 이러한 설정을 동일한 …

1
AMI 복제 인스턴스에서 Cloudwatch mon-put-instance-data가보고되지 않음
호스트 보안 그룹을 변경하기 위해 AMI를 사용하여 EC2 인스턴스를 복제 한 후 Amazon에서 제공 한 mon-put-instance-data.pl 스크립트가보고 한 통계는 CloudWatch에 표시되지 않습니다. 스크립트가 CloudWatch에 데이터를보고하지만 CloudWatch 콘솔에 표시되지 않음을 확인할 수 있습니다. # ./mon-put-instance-data.pl --aws-credential-file=/root/.aws-credentials --mem-util --disk-space-util --disk-path=/ --swap-util Successfully reported metrics to CloudWatch. Reference Id: xxxxxxxx-xxxx-xxxx-xxxx-93f25b4efbc7

1
nginx 요청 행이 너무 큼
오류가 발생했습니다. Bad Request Request Line is too large (6060 > 4094) 다음과 같이 서버의 특정 URL에 액세스하면 /api/categorize?packages=package1,package2,...packageN nginx.conf에는 다음이 있습니다. large_client_header_buffers 8 16k; client_header_buffer_size 8k; 해당 특정 문제에 대한 문서를 찾을 수 없습니다. large_client_header_buffers에 대한 문서는 400 잘못된 요청을 언급하지만 "large_client_header_buffers"를 4 8k에서 변경합니다. 또는 8 8k; 또는 …
12 nginx  http  web  400 

3
Intel EFI 셸에서 USB 드라이브가 감지되지 않습니다
Intel S3420GPLC 보드를 업데이트해야합니다. BIOS, BMC, FRU / SDR, 모든 것. 모든 것은 인텔 다운로드에서 거의 자동화되어 있습니다. 통합 EFI 셸로 부팅하고 USB 디스크 / 키를 마운트 한 startup.nsh다음 다운로드에 포함 된 스크립트를 시작해야합니다 . 나는 4GB USB 키와 더 큰 60GB USB 디스크를 모두 사용해 보았지만 결과는 좋지 않습니다. …
12 mount  usb  intel  bios  uefi 

2
일부 nginx 리버스 프록시 구성이 하루에 한 번 작동을 멈춤
외부 아마존 ELB에서 내부 ELB로 요청을 프록시하는 nginx 리버스 프록시가 있습니다. 요청을 처리하는 6 개의 백엔드 인스턴스가 있습니다. 사이트 사용 구성은 다음과 같지만 포트 번호와 proxy_pass가 다릅니다. 다른 모든 것은 동일합니다. server { listen 3000; location / { proxy_pass http://internal-prod732r8-PrivateE-1GJ070M0745TT-348518554.eu-west-1.elb.amazonaws.com:3000; include /etc/nginx/proxy.conf; } } 약 24 시간마다 구성 중 하나가 …

1
계속 다시 시작되는 강제 종료 프로세스
Jenkins 프로세스를 완전히 종료하는 방법에 대한 조언이 필요합니다. 자체적으로 계속 다시 시작됩니다. Mac OSX에서. $ps -eaf 216 1143 1 0 0:01.65 ?? 0:04.03 /usr/bin/java -jar /Applications/Jenkins/jenkins.war 프로세스를 죽이려고 ... kill 1143 프로세스는 여전히 다른 pid로 존재합니다. $ps -eaf 216 1175 1 0 0:00.16 ?? 0:01.44 /usr/bin/java -jar /Applications/Jenkins/jenkins.war 부모 프로세스가 …

2
CentOS 시스템 클럭 수정
시간 C 기능 (Epoch 이후의 초 수)을 사용하면 현재 CentOS 6 서버의 시간이 다른 서버와 비교하여 정확한 시간을 가진 약 7 시간이 남았습니다. 시스템 시계를 어떻게 수정합니까? 몇 주 전에이 서버를 설정했기 때문에 드리프트라고 생각하지 않지만 가능할 수 있습니다. ntpd를 설정했지만 시간 차이가 너무 커서 도움이되지 않습니다.

2
Fail2ban 로그에 "fail2ban.filter : 경고 DNS 조회를 사용한 IP 결정 : .."이라는 항목이 입력되었습니다.
내 fail2ban 로그 /var/log/fail2ban.log는 다음과 같은 항목으로 완전히 채워져 있습니다. fail2ban.filter : WARNING Determined IP using DNS Lookup: [IP address] 내 ssh 포트를 변경 한 후 이것이 시작되었을 수 있습니다 ... 이 원인의 원인과 중지 방법을 알고 있습니까?


당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.