서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

9
많은 수의 파일을 복사하는 동안 '인수 목록이 너무 깁니다'오류
다음 명령을 사용하고 있습니다. \cp -uf /home/ftpuser1/public_html/ftparea/*.jpg /home/ftpuser2/public_html/ftparea/ 그리고 오류가 발생합니다. -bash: /bin/cp: Argument list too long 나는 또한 시도했다 : ls /home/ftpuser1/public_html/ftparea/*.jpg | xargs -I {} cp -uf {} /home/ftpuser2/public_html/ftparea/ 여전히 -bash : / bin / ls : 인수 목록이 너무 깁니다. 아이디어가 있습니까?
12 linux  bash  unix-shell 

3
VRRP 마스터가 실패한 후 마스터가되지 않도록 방지
가상 IP에 대해 VRPP (keepalived에서)를 실행하는 두 개의 시스템 (A 및 B, A는 마스터)이 있습니다. A가 실패하고 다시 돌아 오면 (어떤 이유로 든) 다시 마스터가되지 않도록하려면 어떻게해야합니까? 나는 두 번째 상자에 대한 단일 장애 조치를 갖기 위해 이것을하고 있으며 정상으로 돌아가려면 수동 개입이 필요합니다.
12 linux  keepalived  vrrp 




5
exim4가 HELO / EHLO를 보낼 때 보내는 호스트 이름을 어떻게 구성합니까?
수신 서버가 HELO 확인을 수행 할 때 시스템의 메일이 거부됩니다. 내 시스템이 잘못된 도메인 이름을 보내고 있다고 생각합니다. exim4를 실행 중입니다. exim4 및 도메인에 대한 검색은 관련없는 결과의 악몽 목록을 생성합니다. 마찬가지로 HELO 거부에 대한 인터넷 검색은 SMTP 인증을 설정해야하는 많은 수의 시야 사용자를 생성합니다. 나는 내 인생 에서이 간단한 …
12 linux  smtp  domain-name  exim 


8
Nagios와 Open NMS의 주요 차이점은 무엇입니까?
관리자에게 포괄적 인 모니터링 시스템을 제공하고 OpenNMS를 고려하고 있습니다. 그러나 나는 여기서 Nagios에 대한 찬사를 보았고 경험이있는 사람이 저에게 중요한 차이점을 설명하는 데 도움이되기를 바랍니다. 그들의 초점이 다르거 나 경쟁자입니까? 일부 배경 지식이 있으면 6 개의 온 사이트 서버 (파일 서버, PBX, 프록시, 애플리케이션 등)와 2 개의 오프 사이트 서버 …

9
괜찮은 국제 키보드를 지원하는 Mac 용 VNC 서버가 있습니까?
독일어 키보드 레이아웃으로 Windows 상자에서 연결할 수있는 Mac OS X 용 VNC 서버를 찾는 데 문제가 있습니다. 내장 데스크톱 공유 및 여러 버전의 Vine을 사용해 보았지만 모두 여러 키에 문제가있었습니다. 클라이언트에서 독일어 키보드 레이아웃을 올바르게 지원하는 Mac OS X VNC 서버와 Windows VNC 클라이언트의 작동 조합에 대해 아는 사람이 있습니까? …
12 windows  mac  vnc 

3
프로세스의 최대 메모리 사용량
top 및 ps 와 같은 도구는 현재 프로세스에 할당 된 메모리 양을 제공 할 수 있지만 프로세스 생성 또는 주어진 시간 간격 동안 프로세스에 할당 된 최대 메모리 양을 측정하는 데 관심이 있습니다. 알아내는 방법에 대한 제안?
12 linux  memory 


16
Windows 디렉토리에서 100,000 개의 파일을 제거하는 가장 좋은 방법은 무엇입니까
단일 디렉토리에 100,000 개가 넘는 파일을 가진 사용자가있었습니다. Explorer가 메모리를 가득 채우면 시스템이 잠기면서 시스템이 잠기고 사용할 수 없게됩니다. 디렉토리와 내용을 덤프하는 간단한 방법이 있습니까? 우리는 커맨드 라인 델 트리를 사용해 보았지만 이것은 훨씬 나아지지 않았습니다. DaveF 추가- 동일한 사용자 (실제로 클라이언트)에서이 문제가 여러 번 발생했습니다. 프로그램은 실행 중에 수십만 …

3
sc 명령을 사용하여 기존 서비스를 삭제할 수 없습니다 : 지정된 서비스가 설치된 서비스로 존재하지 않습니다
삭제 MyNewService하고 싶지만 입력하면 sc delete MyNewService 이러한 서비스가 없기 때문에 단순히 삭제할 수 없습니다. "지정된 서비스가 설치된 서비스로 존재하지 않습니다" 오류 이 문제를 해결하는 방법에 대한 아이디어가 있습니까? 편집 : 서비스 패널과 관련하여 MyNewService 가 항상 있습니다. PC를 몇 번 다시 시작했는데 거기에 있습니다.

2
피어에 의한 도커 떼 데이터베이스 연결 재설정
docker swarm으로 스프링 부트 응용 프로그램을 실행 중이며 데이터베이스에 postgres를 사용합니다. 둘 다 docker 서비스로 실행하면 로그에 표시된 것처럼 데이터베이스 연결이 일관되고 무작위로 (타임 스탬프에서 볼 수 있듯이) 실패합니다. 2017-10-26T 17:14:15 .200415747Z app-db.1.1ayo6h8ro1og@scw-c2964a | LOG : 클라이언트로부터 데이터를 수신 할 수 없음 : 피어에 의한 연결 재설정 2017-10-26T 17시 43분 …

4
Kubernetes는 항상 여러 TLS 수신에서 503 서비스를 일시적으로 사용할 수 없음
Amazon Web Services에서 kops의 kubernetes 클러스터 설정이 있습니다. 2 개의 사이트 설정이 있습니다. 하나는 SSL / TLS / https를 통해 보호되고 다른 하나는 http입니다. 둘 다 Wordpress 사이트입니다. 사이트 ID를 보호하기 위해 도메인이 변경됨 수신 구성 : apiVersion: extensions/v1beta1 kind: Ingress metadata: name: my-rules spec: tls: - hosts: - site1.com …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.