서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
iptables는 하나의 체인 만 보여줍니다
tldr : iptables에 하나의 체인 만 표시하려면 어떻게해야합니까? iptables에 하나의 테이블 만 표시하도록 할 수 있지만 테이블은 여러 체인으로 구성됩니다. 체인 INPUT에서 마지막 규칙이 어디 있는지 찾아야합니다 (일반적으로 항상 모든 규칙 거부). 나는 awk와 심지어 grep을 시도했지만 그 기술에 대한 나의 기술은 약해지고 있어야합니다. awk를 사용하여 단 하나의 단락을 얻으려고 …
12 iptables  firewall  awk 

1
robocopy는 서버간에 파일을 끌어다 놓는 것보다 20 배 느립니다.
두 서버간에 20TB의 파일을 마이그레이션하고 있습니다. 두 시스템 모두 최신 업데이트가 설치된 Windows 2012R2입니다. 둘 다 기가비트 네트워크를 사용합니다. 명령 행으로 새 서버에서 robocopy 사용 robocopy /S /ZB /MOVE /J /DCOPY:A /V /FP \\oldserver\shared\folder X:\folder 약 5-10MB / s로 복사합니다. 탐색기를 사용하여 서버간에 파일을 끌어다 놓으면 약 110MB / s의 …
12 robocopy 

1
Docker 컨테이너가 호스트 터널 인터페이스의 OpenVPN 클라이언트에 연결되도록 허용
다음과 같은 설정이 있습니다. 도커 서비스를 실행하는 CentOS 호스트 사용자 정의 도커 브리지 네트워크 해당 사용자 정의 브리지 네트워크에 연결된 2 개의 Docker 컨테이너 OpenVPN 설치 (현재 호스트에서 실행 중입니다. 도커 컨테이너에서도 실행할 수 있음) OpenVPN에 연결된 일부 클라이언트 도커 브리지 네트워크의 도커 컨테이너가 tun0 네트워크의 openvpn 클라이언트와 통신하도록하려면 어떻게해야합니까? …
12 openvpn  docker 

3
Nginx에서 sendfile을 언제 사용합니까?
우리는이 설정 nginx.conf을 꽤 오랫동안 가지고 있습니다. sendfile on; 파일을 업데이트하고 /js/main.js브라우저 https://test.com/js/main.js?newrandomtimestamp 에서 액세스 할 때 브라우저 에서 완전히 새로 고침 (캐시 지우기)하지 않으면 이전 버전이로드됩니다. 그러나 sendfile에서 설정을 변경하면; 파일을 보내려면; 브라우저는 업데이트 된 파일의 올바른 버전을로드합니다. 프로덕션 웹 서버의 경우 sendfile을 사용해야합니다. 또는 sendfile off ;? sendfile이 …
12 nginx  cache 

2
AWS CLI 명령 줄 :“--query”를 사용하여 여러 소스 행을 출력하는 방법
--query여러 줄에서 파생 된 하나의 레코드를 생성 하기 위해 aws-cli 버전 1.7.8을 사용 하고 있습니다. 이 경우에서 특정 정보를 얻으려고합니다 describe-instances. 이 describe-instances명령 RESERVATIONS에서 INSTANCES,, 및 을 참조하는 행 / 섹션을 얻습니다 TAGS. 새로운 AWS CLI 명령을 간단히 실행하여 세 줄 모두에서 개별적으로 정보를 얻을 수 있습니다. 예약 라인 : …

2
Monit는 404 페이지로 http 상태를 모니터합니다
404 또는 403 페이지로 HTTP 상태를 모니터링하려고합니다. 모두 아시다시피 Monit은 해당 페이지를 연결 실패로 간주하지만 어떻게 변경할 수 있습니까? 404 또는 403 페이지가 표시되는지 모니터링하고 싶습니다. 가능한 경우이 구성으로 확인해야합니다. 이것은 내 확인 구성입니다. check process httpd with pidfile /var/run/httpd.pid start program = "/etc/init.d/httpd start" stop program = "/etc/init.d/httpd stop" …
12 http  monit 

1
OpenSSL : genrsa vs genpkey?
OpenSSL이 두 개의 유틸리티에 겹치는 부분을 제공하는 이유 genpkey: OpenSSL> genpkey - Usage: genpkey [options] where options may be -out file output file -outform X output format (DER or PEM) -pass arg output file pass phrase source -<cipher> use cipher <cipher> to encrypt the key -engine e use engine e, …
12 openssl 

5
Kerberos 사전 인증 오류 (코드 0x18)를 일으키는 프로세스 / 프로그램 추적
서버 2 개 중 1 개를 통해 잠긴 도메인 계정이 있습니다. 내장 감사 기능은 그 정도를 알려줍니다 (SERVER1, SERVER2에서 잠김). 계정은 5 분 내에 잠기 며, 분당 약 1 건의 요청으로 보입니다. 처음에는 sysinternals에서 procmon을 실행하여 계정 잠금을 해제 한 후 새로운 PROCESS START가 생성되는지 확인했습니다. 의심스러운 것은 없습니다. 내 …

5
리눅스에서 ip 명령으로 IP 제거
이처럼 두 개의 IP를 추가하면 : ip addr add 1.1.1.1/24 dev eth2 ip addr add 1.1.1.2/24 dev eth2 그런 다음 다음 중 하나를 삭제하려고합니다. ip addr del 1.1.1.2/24 dev eth2 두 IP가 모두 삭제되며 처리 방법을 모르겠습니다. 아무도 그것을 해결하는 방법을 알고 있습니까?

4
임의의 IP 주소에서 "\ x"로 시작하는 임의의 인코딩 된 문자열로 인한 Nginx 400 오류
나는 이것이 일종의 봇이라고 가정하지만 그들이 내 서버에 무엇을하려고하는지 알고 싶습니다. 문제의 로그는 아래와 같으며 IP 주소가 원본에서 변경되었습니다. 12.34.56.78 - - [18/Oct/2012:16:48:20 +0100] "\x86L\xED\x0C\xB0\x01|\x80Z\xBF\x7F\xBE\xBE" 400 172 "-" "-" 12.34.56.78 - - [18/Oct/2012:16:50:28 +0100] "\x84K\x1D#Z\x99\xA0\xFA0\xDC\xC8_\xF3\xAB1\xE2\x86%4xZ\x04\xA3)\xBCN\x92r*\xAAN\x5CF\x94S\xE3\xAF\x96r]j\xAA\xC1Y_\xAE\xF0p\xE5\xBAQiz\x14\x9F\x92\x0C\xCC\x8Ed\x17N\x08\x05" 400 172 "-" "-" 12.34.56.78 - - [18/Oct/2012:16:58:32 +0100] "g\x82-\x9A\xB8\xF0\xFA\xF4\xAD8\xBA\x8FP\xAD\x0B0\xD3\xB2\xD2\x1D\xFF=\xAB\xDEC\xD5\xCB\x0B*Z^\x187\x9C\xB6\xA6V\xB8-D_\xFE" 400 172 "-" "-" 12.34.56.78 …
12 nginx  logging  hacking 

3
nmap이 ping 스캔을 수행하는 활성 호스트를 찾지 못함
nmap을 사용하여 로컬 네트워크를 ping 스캔하려고 시도하지만 확실하게 살아있는 시스템을 찾지 못하는 것 같습니다. 핑에 응답하지만 핑 스캔에 응답합니다. 핑 결과 : $ ping 192.168.0.2 PING 192.168.0.2 (192.168.0.2): 56 data bytes 64 bytes from 192.168.0.2: icmp_seq=0 ttl=64 time=1.585 ms 그리고 tcpdump의 출력 : $ tcpdump -i fxp0 -n host 192.168.0.2 …
12 networking  ping  nmap 


5
nginx를 설치하고 구성 파일도 설치하는 방법
방금 내 서버 (Ubuntu 11.04)에서 nginx 1.0.6을 완전히 제거했습니다. apt-get remove nginx rm -rf /etc/nginx/ rm -rf /usr/sbin/nginx rm /usr/share/man/man1/nginx.1.gz apt-get remove nginx* 이제 다시 설치하고 싶지만 nginx를 시작할 때 다음과 같은 오류가 발생합니다. nginx 재시작 : nginx : [emerg] open () "/etc/nginx/nginx.conf"실패 (2 : 해당 파일 또는 디렉토리가 없음) …
12 ubuntu  nginx  apt 


3
동일한 Ubuntu 서버에서 여러 버전의 PostgreSQL 실행
PostgreSQL 8.4 및 9.0이 동일한 서버 (Ubuntu Lucid)에서 실행 중입니다. apt-get (기본 패키지 소스가있는 8.4 및 https://launchpad.net/~pitti/+archive/postgresql 에서 ppa를 추가 한 후 9.0)을 통해 둘 다 설치했습니다 . 명령 행에서 "createdb"와 같은 명령을 실행하거나 "psql"쉘을 시작하면 PostgreSQL 버전 8.4가 기본적으로 시스템에 사용됩니다. 그렇다면이 명령이 8.4 대신 PostgreSQL 9.0을 사용하도록하려면 어떻게해야합니까?

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.