서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

4
이메일 헤더에서 apache @ localhost를 제거 하시겠습니까?
내 설정 : Apache 웹 서버가있는 Amazon Linux 서버 (기본적으로 CentOS 인 것)에서 Magento 웹 사이트를 실행하고 있습니다. 또한 mydomain.com의 메일을 관리하기 위해 Google Apps를 사용합니다. 서버에 대한 MX, SPF 및 DKIM 레코드를 성공적으로 설정하고 작동하도록하여 이메일을 보낼 때 SPF와 DKIM 모두에 대한 "비밀"을 수신 할 수있었습니다. 그러나 나는 지나칠 …


1
여러 머신을 원격으로 재부팅
여러 컴퓨터를 원격으로 재부팅해야합니다. 일반적으로 나는 단지 발행 for host in <hostlist>;do ssh ${host} 'sudo shutdown -r now';done 그러나 다시 시작하기 전에 사용자에게 시간을주고 싶습니다. 그러나 ssh 세션은 내가 사용하더라도 연결이 끊어지지 않습니다. ssh -f 'sudo shutdown -r +5 &;disown' 오류 메시지가 나타납니다. bash : -c : line 0 : …
11 ssh  bash 

2
내 서버에 이상한 비트 토렌트 로그온
다음 로그에 내 사이트가 다운되는 것과 관련이 있는지 모르겠습니다. 서버에 많은 웹 사이트가 있으며 다음과 같은 로그가 없습니다. 117.169.1.85 - - [03/Jan/2015:23:21:37 +0800] "GET /announce.php?info_hash=%D0%A2M%CE%13%21H%D4%11%0C%8C%27%22%C83%B4%A3l%92%15&peer_id=%2DSD0100%2D%C50%95xmh%9B%13%7C%D42%F7&ip=39.178.24.33&port=14940&uploaded=3893629&downloaded=3893629&left=1369695469&numwant=200&key=1490&compact=1 HTTP/1.1" 404 162 "-" "Bittorrent" 115.231.228.252 - - [03/Jan/2015:23:21:37 +0800] "GET /announce.php?info_hash=%DE%82%BC%CFBmH%29e%FD%25%ED6b%F2%2DX%EE%BE%21&peer_id=%2DSD0100%2D%BF3%DAG%83%1F%DAGnV%E3%C8&ip=118.134.134.210&port=13567&uploaded=675282944&downloaded=675282944&left=80740352&numwant=200&key=7916&compact=1 HTTP/1.0" 404 162 "-" "Bittorrent" 115.231.228.252 - - [03/Jan/2015:23:21:37 +0800] "GET /announce?info_hash=%DE%82%BC%CFBmH%29e%FD%25%ED6b%F2%2DX%EE%BE%21&peer_id=%2DSD0100%2D%BF3%DAG%83%1F%DAGnV%E3%C8&ip=118.134.134.210&port=13567&uploaded=675282944&downloaded=675282944&left=80740352&numwant=200&key=16205&compact=1 HTTP/1.0" …

2
HIPAA 준수를 위해 BitLocker로 OS 디스크를 암호화해야합니까?
Azure VM에서 HIPAA 호환 웹 응용 프로그램을 호스팅하려고합니다. 데이터베이스의 경우 현재 SQL 2014 Standard Edition에서 VM을 사용하려고합니다. Standard Edition에서는 TDE를 사용할 수 없으므로 BitLocker를 사용하여 전체 드라이브를 암호화하려고합니다. 그러나 내가 읽은 내용에 따르면 CloudLink 와 같은 타사 서비스를 사용하지 않고 Azure VM에서 OS 드라이브를 암호화 할 수는 없습니다 . 그러나 …

1
Windows 유선 네트워크의 Linux 802.1x
회사 네트워크에서 Linux 워크 스테이션을 사용하려고하는데 특히 802.1xi가 믿는 몇 가지 문제가 발생했습니다. 내 컴퓨터와 Windows 도메인 관리자의 루트 이므로이 작업을 수행하는 데 필요한 모든 것에 액세스 할 수 있어야합니다. 현재 내 리눅스 시스템은 연결이 제한되어있어 802.1x가 아닌 클라이언트의 기본 VLAN에 배치되었다고 생각합니다. 내 전반적인 질문은 다음과 같습니다. 내 유선 …

2
Tomcat에서 HTTP 메소드를 허용하지 않는 것은 대소 문자를 구분합니까?
PUT, DELETE 등을 허용하지 않으려 고 응용 프로그램의 web.xml에 다음을 입력했습니다. <security-constraint> <web-resource-collection> <web-resource-name>restricted methods</web-resource-name> <url-pattern>/*</url-pattern> <http-method>DELETE</http-method> <http-method>PUT</http-method> <http-method>SEARCH</http-method> <http-method>COPY</http-method> <http-method>MOVE</http-method> <http-method>PROPFIND</http-method> <http-method>PROPPATCH</http-method> <http-method>MKCOL</http-method> <http-method>LOCK</http-method> <http-method>UNLOCK</http-method> <http-method>delete</http-method> <http-method>put</http-method> <http-method>search</http-method> <http-method>copy</http-method> <http-method>move</http-method> <http-method>propfind</http-method> <http-method>proppatch</http-method> <http-method>mkcol</http-method> <http-method>lock</http-method> <http-method>unlock</http-method> </web-resource-collection> <auth-constraint /> </security-constraint> 좋아, 지금 : 내가 방법으로 요청 DELETE하면 403을 다시 얻습니다. …
11 tomcat 


1
PDF 문제를 일으키는 응용 프로그램 dotdefender ISAPI 필터
최근에 웹 서버 양식 Server 2008 R2를 Server 2012 R2로 마이그레이션했습니다. dotdefender 응용 프로그램 방화벽은 한 가지 문제를 제외하고는 정상적으로 작동합니다. 큰 PDF ~ 15MB 이상에서는 크기에 따라로드하는 데 1-5 분이 걸립니다. ~ 14MB보다 작은 PDF는 전혀 시간이 걸리지 않습니다. procmon을 사용하여 웹 서비스가 파일 캐시를 완료 할 때까지 웹 …

2
Jenkins 및 Sonar 용 SSL을 사용한 올바른 Apache 리버스 프록시 구성
Apache 서버 뒤에서 Jenkins (Port 8080)와 SonarQube (Port 9000)의 두 가지 서비스를 실행하고 있습니다. 내 아파치 구성은 다음과 같습니다. <VirtualHost *:80> ServerName server Redirect permanent / https://server.domain.com/ </VirtualHost> <VirtualHost *:80> ServerName server.domain.com Redirect permanent / https://server.domain.com/ </VirtualHost> <VirtualHost *:443> ServerName server.domain.com SSLEngine on SSLCertificateFile /etc/ssl/certs/server.crt SSLCertificateKeyFile /etc/ssl/private/server.key ProxyPass /jenkins http://localhost:8080/jenkins …

3
Ansible, Chef, Puppet 또는 ____ : 가장 강력한 Windows 지원 및 가장 작은 init 풋 프린트
우리는 주로 (독점적이지는 않지만) 서버에서 승리합니다. 가급적이면 OS를 시작하고 명령을받을 준비를하기 위해 운영 체제를 거의 또는 전혀 수행하지 않을 수 있습니다 (에이전트 또는 ssh 서버로 기본 이미지를 작성해야 할 수도 있음). mongodb, Java 기반 앱, iis 구성 등을 설치할 수 있어야합니다. 창 지원 / 커뮤니티가 가장 강력한 도구와 가장 작은 …

1
Powershell 오류에서 오류 메시지 잘림 방지
다음과 같은 Powershell 오류가 발생합니다. PS C:\mydirectory> $Error[0] Get-WmiObject : At line:143 char:13 + $Disk = Get-WmiObject MSCluster_Disk -ComputerName $Resource.OwnerNode -Auth ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : InvalidOperation: (:) [Get-WmiObject], COMException + FullyQualifiedErrorId : GetWMICOMException,Microsoft.PowerShell.Commands.GetWmiObjectCommand $Disk = Get-WmiObject MSCluster_Disk ...오류 메시지에서 오류 (예 :)가 발생하는 명령을 피할 수있는 방법이 있습니까?

2
Cloudera HBase 클러스터에서 SecondaryName 노드 이동
동일한 이름의 머신에 보조 네임 노드를 배포했습니다. 이는 성능 및 내구성상의 이유로 잘못 되었습니다 (보조 이름 노드는 핫 스페어가 아니지만 필요한 메타 데이터 사본이 있음). namenode 이동 방법에 대한 문서를 찾았 지만 보조 namenode 이동에 대해서는 아무것도 없습니다. 경험이있는 사람이 안전하게하는 방법을 알고 있습니까?
11 hadoop  hbase  cloudera 

2
Windows Server 2012에서 새 사용자 계정을 만들 수 없습니다
에서 작동하는 Windows 도메인 계정을 만들었습니다 MYDOMAIN. 연결된 모든 컴퓨터 MYDOMAIN는 로그온을 위해 생성 한 자격 증명을 제외하고 사용할 수 있습니다. 에 PROBLEMSERVER01나는에 로그인 할 때 MYDOMAIN\ myuser나는 다음과 같은 오류가 발생합니다 (이전에 만든 다른 계정 작업) 수 : User Profile Service 서비스가 로그인에 실패했습니다. 사용자 프로필을로드 할 수 없습니다. …

1
모든 옵션은 + 또는-로 시작해야합니다. 그렇지 않으면 옵션이 닫힐 수 없습니다.
닫은. 이 질문은 주제에 맞지 않습니다 . 현재 답변을받지 않습니다. 이 질문을 개선하고 싶습니까? 서버 결함에 대한 주제가 되도록 질문을 업데이트하십시오 . 휴일 오년 전에 . 이 줄은 .htaccess 파일에 있습니다. Options +SymLinksIfOwnerMatch ExecCGI Includes IncludesNOEXEC SymLinksIfOwnerMatch ExecCGI Includes IncludesNOEXEC SymLinksIfOwnerMatch ExecCGI Includes IncludesNOEXEC SymLinksIfOwnerMatch ExecCGI Includes IncludesNOEXEC SymLinksIfOwnerMatch ExecCGI …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.