서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
IPv6을 올바르게 실행하는 방법은 무엇입니까?
따라서 내 문제는 IPv6을 작동시킬 수 없다는 것입니다. Ping6 은 예를 들어 connect: Network is unreachable핑하려고 할 때 알려줍니다 ipv6.google.com. ifconfig 다음과 같이 보입니다 (약간 검열). eth0 Link encap:Ethernet HWaddr **:**:e9:b6:35:7e inet addr:***.*.65.177 Bcast:***.*.65.191 Mask:255.255.255.224 inet6 addr: fe80::16da:e9ff:feb6:357e/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:* errors:0 dropped:0 overruns:0 …

6
ssh를 통한 Rsync :“오류 : 모듈이 읽기 전용입니다.”갑자기 나타남
나는 때때로 rsync / ssh를 사용하여 공유 호스트 내용을 개인 Synology NAS (그 문제의 경우 212j)에 백업했으며 꽤 잘 작동했습니다. 자세한 내용은 암호가없는 ssh연결을 사용 합니다. 3 일 전에 NAS 소프트웨어를 업데이트했으며 그 이후로는 (또는 그 이후라고 생각합니다) 백업이 더 이상 작동하지 않습니다. 호스트에서 다음과 같은 오류가 발생합니다. rsync: writefd_unbuffered …
11 ssh  backup  rsync 

8
여러 SSH 서버 관리를위한 Clusterssh 대안 [닫기]
닫은. 이 질문은 주제에 맞지 않습니다 . 현재 답변을받지 않습니다. 이 질문을 개선하고 싶습니까? 서버 결함에 대한 주제가 되도록 질문을 업데이트하십시오 . 휴일 3 년 전 . 하나의 인터페이스를 통해 여러 ssh 기반 서버를 관리하기위한 Clusterssh, pssh 등의 대안이 있습니까? Clusterssh의 한 가지 약점은 내 서버가 암호 기반 로그인으로 키 …

3
함수에 매개 변수를 전달하는 방법?
PS 스크립트에서 SVN 작업 복사본을 처리해야하지만 인수를 함수에 전달하는 데 문제가 있습니다. 내가 가진 것은 다음과 같습니다. function foo($arg1, $arg2) { echo $arg1 echo $arg2.FullName } echo "0: $($args[0])" echo "1: $($args[1])" $items = get-childitem $args[1] $items | foreach-object -process {foo $args[0] $_} 내가 전달하려는 $arg[0]로 $arg1에 foo, 및 $arg[1]등 …
11 powershell 

6
격주 cronjob을 예약하는 방법?
crontab (5)는 다음 필드를 정의합니다. field allowed values ----- -------------- minute 0-59 hour 0-23 day of month 1-31 month 1-12 (or names, see below) day of week 0-7 (0 or 7 is Sun, or use names) 그리고 설명 : Step values can be used in conjunction with ranges. Following a …
11 cron 

2
Postfix가 다른 컴퓨터의 SMTP 포트 25에 연결하려고하는 이유는 무엇입니까?
이 오류가 발생합니다. Jul 5 11:09:25 relay postfix/smtp[3084]: connect to ab.xyz.com[10.41.0.101]:25: Connection refused Jul 5 11:09:25 relay postfix/smtp[3087]: connect to ab.xyz.com[10.41.0.247]:25: Connection refused Jul 5 11:09:25 relay postfix/smtp[3088]: connect to ab.xyz.com[10.41.0.101]:25: Connection refused Jul 5 11:09:25 relay postfix/smtp[3084]: connect to ab.xyz.com[10.41.0.247]:25: Connection refused Jul 5 11:09:25 relay postfix/smtp[3087]: connect to …
11 postfix  smtp 

3
앰퍼샌드 (&) 기호는`nohup`에서 무엇을 의미합니까?
나는 &명령 문자열의 끝을 따르는 수많은 예제를 보았지만 그 기능에 대한 설명을 찾을 수없는 것 같습니다. nohup의 man페이지 에도 없습니다 . 이게 껍질인가? 사용 &여부에 관계없이 프로세스가 실행 nohup되면 모든 끊기 신호에 대한 내성이 나타납니다.
11 nohup 

1
왜 Cacti는 데드 폴러 프로세스를 계속 대기합니까?
현재 새 데비안 (6.0.5) 서버를 설정하고 있습니다. 나는 어제 그것에 선인장 (0.8.7g)을 넣고 그 이후로 싸우고있다. 초기 문제 내가 관찰 한 초기 문제는 그래프가 업데이트되지 않았다는 것입니다. 그래서 나는 내 것을 확인 cacti.log하고 메시지와 관련하여 이것을 발견했습니다. POLLER: Poller[0] Maximum runtime of 298 seconds exceeded. Exiting. 좋지 않아요? 그래서 나는 …

2
이메일 MIME에 Content-ID 헤더가 있으면 첨부 파일을 포함해야합니까?
우리가 가지고있는 두 개의 다른 타사 전자 메일 제품 은 전자 메일의 MIME 소스에 content-id 헤더가있는 것과 다르게 반응 합니다. 이로 인해 해결하려는 사용자 환경이 일관되지 않습니다. 예를 들면 다음과 같습니다. --boundary-example Content-Location: CID:somethingatelse Content-ID: <foo4atfoo1atbar.net> Content-Type: IMAGE/GIF Content-Transfer-Encoding: BASE64 R0lGODlhGAGgAPEAAP/////ZRaCgoAAAACH+PUNv cHlyaWdodCAoQykgMTk5LiBVbmF1dGhvcml6ZWQgZHV wbGljYXRpb24gcHJvaGliaXRlZC4A etc.. 한 이메일 제품이이를 임베디드 이미지로 해석합니다. …
11 email  mime  rfc 

4
RAM에서 정적 컨텐츠를 제공하도록 nginx를 구성하는 방법은 무엇입니까?
Nginx를 웹 서버로 설정하고 싶습니다. 이미지 파일을 디스크가 아닌 메모리 (RAM)에 캐시하고 싶습니다. 작은 페이지를 제공하고 있으며 항상 RAM에서 제공되는 몇 가지 이미지를 원합니다. Nginx에 내용을 RAM에 캐시하는 기능이 있다고 생각하기 때문에 Varnish (또는 다른 도구)를 사용하고 싶지 않습니다. Nginx를 어떻게 구성 할 수 있는지 잘 모르겠습니다. 몇 가지 조합을 …
11 nginx  cache  memcache 

3
x11vnc는 느리지 만 사용 가능한 대역폭의 10 % 만 사용
대기 시간이 20ms 인 15Mbit / s 네트워크에서 x11vnc를 사용하고 있습니다. 화면이 많이 바뀌면 x11vnc가 느려집니다 (예 : 브라우저에서 탭을 전환 할 때보 기가 완전히 다시 그려 질 때까지 거의 2 초가 걸립니다. 이상한 점은 x11vnc의 최대 연결 속도가 느린 다시 그리기 중에도 사용 가능한 대역폭의 약 10 %에 불과하다는 …
11 linux 


1
Nginx의 특정 경로에 대해 SSL 비활성화
로 시작하는 경로가있는 URL에 대한 요청을 제외하고 모든 요청을 HTTPS로 수행하려는 웹 사이트가 있습니다 /foo/. Nginx에서 이것을 어떻게 구성합니까? 지금은 SSL로 모든 요청을 실행합니다. server { listen 443; ssl on; ssl_certificate /home/admin/ssl/ssl.crt; ssl_certificate_key /home/admin/ssl/ssl.key; server_name www.mydomain.com; location / { proxy_pass http://localhost:8000; ... } }
11 nginx 


1
서버 {} 블록에서 변수로서 루트 위치 참조
내 nginx 서버 {} 블록에서 경로로 루트를 정의했습니다. 나중에이 경로를 어떻게 참조 할 수 있습니까? 이것이 내가 달성하려고하는 것입니다. server { listen 80; root /var/www/foosite; ... include $root/*.ngaccess; } 불행히도 $ root를 사용하면 작동하지 않습니다 (정의하지 않았기 때문에). Nginx는 루트 값에 액세스하는 방법을 제공합니까?
11 nginx 

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.