서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

3
Linux cron 작업은 각각 순차적으로 또는 병렬로 실행됩니까?
두 개의 cron 작업을 생성한다고 가정 해 보겠습니다. Cron Job A, 매일 오전 8시에 실행 Cron Job B, 매일 오전 8:05에 실행 그러나 Cron Job A는 실행하는 데 12 시간이 걸립니다 (이것이 예인 이유는 묻지 마십시오). 크론 작업 B는 오전 8시 5 분에 실행됩니까, 아니면 크론 작업은 한 번에 하나만 …
10 linux  cron 

2
크기가 변경되지 않으면 Vagrant NFS 공유에 업데이트 된 파일이 표시되지 않습니다
NFS를 통해 / vagrant를 마운트 할 때 크기가 변경되지 않으면 호스트에서 변경된 파일이 게스트에서 새로 고쳐지지 않습니다. 크기를 다르게 수정하지 않으면 빠른 업데이트 / 오타가 즉시 반영되지 않습니다. lookupcache = none을 설정하려고했지만 모든 것을 느리게 만드는 것 외에는 아무것도 변경하지 않았습니다. OSX ML을 호스트로 사용하고 Arch Linux를 게스트로 사용하고 있습니다. …

3
vSphere Command-Line 인터페이스를 통한 vMotion 및 SvMotion 결합
은 vSphere는 우리가 지금 요청할 수 있습니다 5.x를 때문에 결합 만이 CLI (안 PowerCLI)를 통해 수행 할 수 있습니다 - 웹 클라이언트를 통해 동시에 vMotion을 및 스토리지 vMotion을을? 5.1 CLI에 대한 설명서를 읽었고 그것을 열심히 봤지만 참조를 찾을 수 없습니다. 나는 또한 경우에 어떻게 답변을 찾을 나는 그것을 쉽게 찾을 …

5
장치 / dev / sdb1을 찾을 수 없거나 필터링으로 무시 됨
볼륨 그룹을 추가하고 그 안에 LV를 추가하는 데 사용할 물리 볼륨을 추가하려고합니다. 슬프게도 다음과 같은 오류가 발생합니다. [root@server ~]# pvcreate /dev/sdb1 Device /dev/sdb1 not found (or ignored by filtering). [root@server ~]# fdisk -l /dev/sdb WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU …
10 centos  lvm  pv 

2
Logstash가 액세스해야하는 파일을 읽을 수 없습니다
명령을 사용하여 사용자 logstash를 그룹에 추가했습니다 .adm$ usermod -a -G adm logstash logstash 에이전트가 읽으려고하는 파일 중 하나는 /var/log/nginx/foo-access.log다음 권한을 가진 파일입니다 . -rw-r----- 1 www-data adm 0 Jul 25 07:52 /var/log/nginx/foo-access.log 내가하면 sudo su logstash내가 파일을 읽을 수 있지만, 때 $ sudo service logstash_agent restart(이는 같은 초기화 스크립트 실행 …

2
DFS 복제 및 SYSTEM 사용자 (NTFS 권한)
Google 또는 Technet에서 답변을 찾는 데 문제가있는 질문 ... SYSTEMDFS 공유 파일 및 폴더에 사용자 권한을 부여해도 DFS 복제에 영향을 줍니까? (우리가 그것에 인 동안, 어떤 좋은 이유가 되지 수 있도록 SYSTEMDFS 공유 파일에 대한 권한이는?) 다른 사람의 문제를 만들 수없는 DFS 네임 스페이스 및 폴더 모음이 있기 때문에 하나의 …

7
한 네트워크에서 동일한 MAC 주소를 가진 여러 장치를 처리하는 좋은 방법은 무엇입니까?
내가 작업하는 장치는 모두 동일한 MAC 주소로 설정된 생산 라인에서 나옵니다. 각각 고유의 고정 IP를 갖도록 설정할 수 있으며 구성 데이터 (새 MAC 주소 포함)를 전송하기 위해 네트워크에 동시에 연결할 수있는 방법이 있는지 궁금합니다. Cisco SF 200-24 "스마트 스위치"가 있는데 지금까지 스위치의 각 포트를 자체 VLAN (모드 : 액세스)으로 설정하려고 …

1
모든 로그를 여러 원격 서버로 보내려면 rsyslog를 어떻게 설정합니까?
rsyslog가 모든 로그를 2 개의 원격 서버로 보내려고하지만 첫 번째 서버가 실패하면 rsyslog가 보조 서버로만 보내는 것 같습니다. *.* @@server1 *.* @@server2 위의 내용을 /etc/rsyslog.conf에 넣으면 server1이 작동하는 한 server2는 로그를받지 않습니다. rsyslog에 두 서버 모두에게 보내도록 어떻게 지시합니까? 또한 추가 보너스로 원격 서버가 다운되면 로컬 저장을 위해 2 개의 …

2
Freebsd 기본 인터넷 채널 경로 변경
freebsd에 두 개의 인터넷 채널과 게이트웨이가 있습니다. 명령으로 채널을 전환 route change default chan2하면 명령이 netstat -nr변경된 기본 경로를 보여줍니다. 그러나 traceroute패킷이 이전 경로 chan1을 통과 함을 보여줍니다. 예: $netstat -nr Routing tables Internet: Destination Gateway Flags Refs Use Netif Expire default xxx.xxx.183.54 US 0 8432 em3 $sudo route change …

3
일정 약속 있음 / 없음 정보를 O365에서 외부 페더레이션 도메인으로 공유 할 수 없습니다.
페더레이션을 통해 일정 약속 있음 / 없음 정보를 공유하려는 두 개의 도메인이 있습니다. SiteA는 Exchange 2010 SP2의 온-프레미스 배포입니다. SiteB는 Office 365 Enterprise 배포입니다. 두 조직 모두 MSFT 게이트웨이를 통해 페더레이션됩니다. SiteA에서 SiteB로 작업을 공유하면 SiteB의 사용자가 SiteA의 사용자에게 액세스 권한을 요청하고 일정을 볼 수 있습니다. SiteB에서 SiteA로 공유가 작동하지 …

1
유형에 영향을 미치는 모든 selinux 규칙 / 기본 파일 컨텍스트 등을 쿼리하는 방법
실행중인 시스템의 현재 규칙 에서 selinux 유형과 관련된 모든 것을 알아야합니다 . 허용, 허용 감사, dontaudit 규칙. 유형을 사용하여 컨텍스트로 레이블이 지정된 파일. 전환. ... 그리고 다른 정보. 해당 정보를 쿼리하는 데 사용할 수있는 명령이 있습니까, 아니면 모든 selinux 관련 "src"패키지를 다운로드하고, 사용하지 않는 모듈을 걸러 내고 해당 정보의 모든 …

1
Linux와 Linux LVM 파티션 유형의 차이점은 무엇입니까?
Fdisk는 여러 파티션 유형을 보여줍니다. 83) Linux와 8e) Linux LVM을 선택하는 것의 차이점은 무엇입니까? 83) Linux도 LVM 사용에 적합하며 파티션 테이블이 작동하지 않고 / dev / sdb에 물리 볼륨을 생성 할 수도 있습니다. fdisk에서 파티션 유형을 선택하는 것이 정말로 중요합니까? 파티션 유형으로 Linux 또는 Linux LVM을 선택하는 것의 차이점은 무엇입니까? …
10 redhat  lvm  partition  fdisk 

1
폐기 됨으로 표시된 물리 디스크를 제거하는 중 오류가 발생했습니다
하나의 저장소 풀과 하나의 가상 디스크가있는 Server 2012가 있습니다. 가상 디스크는 레이아웃 패리티 및 씬 프로비저닝을 사용합니다. 4 개의 물리 디스크가 포함되어 있습니다. 물리 디스크 중 하나에 장애가 발생했습니다. 잡아 당겨 더 큰 교체 디스크가 추가되었습니다. 서버 관리자는 이제 실패한 드라이브를 "종료"로 표시합니다. 디스크를 제거하려고 시도하면 다음과 같은 결과가 발생합니다. …

2
EC2 IAM 역할에 S3 버킷에 대한 읽기 권한 부여
S3 버킷에서 일부 파일을 가져 오기 위해 구성 스크립트를 통해 구성하는 AWS Elastic Beanstalk Rails 앱이 있습니다. 응용 프로그램을 시작할 때 로그에 다음과 같은 오류가 계속 발생합니다 ( 보안을 위해 버킷 이름이 변경됨 ). Failed to retrieve https://s3.amazonaws.com/my.bucket/bootstrap.sh: HTTP Error 403 : <?xml version="1.0" encoding="UTF-8"?> <Error><Code>AccessDenied</Code><Message>Access Denied</Message> 구성 파일 : …

2
꼭두각시 에이전트 인증서 확인 실패
Puppet Master / Agent가 설정되어 있고 마스터의 에이전트에 대한 인증서에 성공적으로 서명했습니다. 그러나 실행할 때 puppet agent --test다음과 같은 오류가 발생합니다. Warning: Unable to fetch my node definition, but the agent run will continue: Warning: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed: [certificate signature failure for …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.