서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

2
Windows Server 2012를 Server 2008 R2 Hyper-V 호스트에서 게스트 VM으로 실행할 수 있습니까?
Windows Server 2012를 Windows Server 2008 R2 Hyper-V 호스트에서 게스트 가상 시스템으로 실행할 수 있습니까? 그렇다면 게스트 OS가이 시나리오에서 실행할 수있는 작업에 대한 중요하거나 눈에 띄는 제한이 있습니까? W2K8R2 Hyper-V 서버에서 게스트로 실행되는 많은 VM이있는 랩 PC가 있습니다. 나는 VM으로 너무 이국적인 일을하지 않고 기본적으로 내 응용 프로그램 소프트웨어 설치 …

2
rsync-권한을 설정하지 못했습니다-작업이 허용되지 않습니다
이 오류와 함께 다음 명령이 있습니다. rsync -avz --links -O /home/jansiatest/.jenkins/workspace/svn_to_demo/trunk/CPS/ jansia@ps27670.dreamhost.com:/home/tasklite/temp sending incremental file list ./ rsync: failed to set permissions on "/home/tasklite/temp/.": Operation not permitted (1) 그러나 문제는 "/ home / tasklite / temp /"의 권한을 변경하고 싶지 않다는 것입니다. 어떻게 설정합니까?
10 linux  rsync  chmod 

1
유휴 세션을 종료하는 TCP Keepalive 및 방화벽
고객 사이트에서 네트워크 팀은 클라이언트와 서버 사이에 방화벽을 추가했습니다. 이로 인해 약 40 분의 유휴 시간이 지나면 유휴 연결이 끊어집니다. 네트워크 사람들은 방화벽에 유휴 연결 시간 초과가 없다고 말하지만 사실 유휴 연결이 끊어졌습니다. 이 문제를 해결하기 위해 먼저 tcp_keepalive_time = 300, tcp_keepalive_intvl = 300 및 tcp_keepalive_probes = 30000으로 TCP keepalives가 …

3
Kerberos에 대한 TGT를 얻기 위해 kinit 프로세스를 자동화하는 방법은 무엇입니까?
현재 Kerberos를 지원하여 RHEL 서버를 AD 도메인에 가입시키는 프로세스를 자동화하기 위해 꼭두각시 모듈을 작성 중입니다. 현재을 통해 Kerberos 티켓 부여 티켓을 자동으로 가져와 캐시하는 데 문제가 있습니다 kinit. 이 작업을 수동으로 수행하는 경우 다음과 같이하십시오. kinit aduser@REALM.COM AD 사용자 암호를 묻는 메시지가 표시되므로이를 자동화하는 데 문제가 있습니다. 이것을 자동화하려면 어떻게해야합니까? …

1
CentOS 6.2에서“make install”을 통해 설치된 소프트웨어의 제거 절차는 무엇입니까
얼마 전에 CentOS 6.2 서버에 OCILIB를 설치했으며 이제 최신 버전을 설치하고 싶습니다. 공급 업체는 제거가 필요하지만 지침을 제공하지는 않습니다. 리눅스 배경을 가진 사람들에게는 사소한 것이기 때문입니다. http://orclib.sourceforge.net/doc/html/group__g__install.html 다음을 사용하여이 소프트웨어를 설치 한 경우 : 1 단계 : # ./configure --with-oracle-headers-path = / usr / include / oracle / 11.2 / …
10 linux  centos 

3
느린 파일 시스템 액세스
내가 돌보는 서버에서 느린 파일 시스템 문제를 진단하려고합니다. 꽤 오랫동안 진행되어 왔으며 시도 할 수있는 아이디어가 부족합니다. 여기에 두꺼운 것이 있습니다. 서버 자체는 Dell Poweredge T310입니다. RAID5에 구성된 4 개의 SAS 하드 드라이브가 있으며 Citrix XenServer 5.6을 실행하고 있습니다. VM은 (비교적) 오래된 데비안 5.0.6 설치입니다. 코어 4 개와 RAM 4Gb가 …

2
nginx : worker_proccesses 지시어가 작동하지 않습니다
nginx에서 작업자 프로세스를 설정하려고했지만이 오류가 발생합니다. nginx : [emerg] "worker_processes"지시문은 / etc / nginx / sites-enabled / default : 1에서 허용되지 않습니다. nginx : 구성 파일 /etc/nginx/nginx.conf 테스트 실패 여기 내 코드가 있습니다 worker_processes 4; worker_rlimit_nofile 8192; worker_priority 0; worker_cpu_affinity 0001 0010 0100 1000; server { server_name --.--.--.---; listen 80; …
10 nginx 


3
HP ProLiant DL320G6에서 HP SmartArray P410 RAID ORCA 설정을 입력 할 수 없습니다
방금 HP SmartArray P410 컨트롤러를 HP ProLiant DL320G6 서버에 설치했습니다. 컨트롤러는 서버 BIOS (BIOS 설정의 컨트롤러 목록에 표시됨)에서 감지 된 것으로 보이고 하드 드라이브 LED가 깜박이지만 컨트롤러는 부팅 시간 동안 구성되도록 제공되지 않습니다. 부팅 가능한 디스크가 없다고 말하면 그 자리에옵니다. 설명서에 ORCA (어레 이용 옵션 ROM 구성)를 입력하라는 메시지가 표시되면 …

3
userdir을 구성 할 때 nginx fastcgi“기본 스크립트를 알 수 없음”
nginx 구성이 싫습니다. 너무 복잡합니다. 사용자 디렉토리에서 PHP를 작동 시키려면 어떻게해야합니까? 내 nginx.conf의 관련 부분은 다음과 같습니다. location ~ ^/~(.+?)(/.*)?$ { autoindex on; autoindex_exact_size off; alias /home/$1/public_html$2; location ~ \.php { include /etc/nginx/fastcgi.conf; fastcgi_intercept_errors on; fastcgi_pass 127.0.0.1:9000; fastcgi_index index.php; } } 이것은 나에게 오류를 준다 : FastCGI sent in stderr: …
10 nginx  fastcgi  php-fpm 

2
모든 MySQL InnoDB 테이블이 조각난 이유는 무엇입니까?
어떤 이유로 mysqltuner를 실행할 때 MySQL 서버의 모든 InnoDB 테이블이 조각으로 나열됩니다. 몇 시간 전에 서버를 설치했으며 (OSX Lion에) 배치 파일에서 가져온 새로운 데이터가 많이 있습니다. 한 데이터베이스의 모든 테이블을 MYISAM으로 변환하려고 시도했으며 조각난 테이블 수가 충분히 줄었습니다. 이상하게도, 해당 테이블을 InnoDB로 다시 변환하자마자 조각난 테이블 수가 다시 백업되었습니다. 이것은 …
10 mysql 

1
확장 된 속성 비트가 설정된 파일에 대해 getfattr이 아무것도 표시하지 않는 이유는 무엇입니까?
CentOS 6.2에서 Nagios XI 설치를 실행 중이며 백업 스크립트를 수정하고 싶습니다. 이 쉘 스크립트에 확장 속성 비트가 설정되어 있음을 알았으므로 변경할 때 아무것도 엉망이되지 않도록하고 싶습니다. 나는 "cp -p"가이 설정을 유지하지 못한다는 것을 실험하고 발견했다. 나는 Linux에서 확장 속성을 처음 접했고 확장 속성을 표시 해야하는 'getfattr'명령이 있지만이 파일에 대해서는 아무것도 …

5
데이터 읽기를위한 MyISAM
약 10 억 행의 테이블이 있으며 98 % 읽기 집중적입니다. 다른 스토리지 엔진 (MyISAM 및 InnoDB)을 사용하여 데이터베이스 튜닝을 시도했습니다. 그런 다음 성능을 확인하기 위해 몇 가지 테스트를 실행했습니다. where 절에서 기본 키 ID가 있었고 MyISAM Key Cache 저장소가 버퍼에 모든 인덱스를로드하기 때문에 MyISAM을 사용하면 InnoDB보다 약 2 배 빠릅니다. …
10 mysql  innodb  myisam 

3
네트워크에서 모든 snmp 지원 장치를 찾는 방법은 무엇입니까?
네트워크에서 모든 snmp 지원 장치를 찾고 싶습니다. 에이전트 및 관리자 아키텍처에서 작동하는 방식과 같은 것이 있습니다. 원격 장치에서 snmp 데이터를 가져 오는 간단한 응용 프로그램을 만들 수있는 net-snmp 라이브러리가 있습니다.이 작업을 수행하려면 프로그램을 작성해야합니다. 장치의 mac 주소와 더 많은 정보가 필요합니다. 원격 노드에서 데이터를 가져 오는 프로그램이 있지만 시스템의 mac …

6
netsh를 사용하여 패턴을 사용하여 규칙을 찾는 방법
Microsoft의 누군가가 규칙의 이름을 기억할 수없는 상황에 처한 적이 있는지 궁금합니다. 는 netsh advfirewall firewall show rule만 수락 한 이름을 어떠한 패턴 매칭 기능은 같은 패턴을 사용하여 규칙을 찾을 수 있도록 netsh를 볼 수 없습니다 "SQL*"또는 ^SQL.+$ 표시를 사용하여 name=all이 모든 규칙을 나열하는 것이 가능하지만 Windows 용 고체 명령 줄 …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.