getSomething
vs로 시작하는 특정 방법의 이름을 지정 해야하는지 항상 알아내는 데 어려움이 있습니다 findSomething
.
문제는 잘못 설계된 API를위한 헬퍼 를 작성하는 데 있습니다 . 일반적으로 객체에서 데이터를 가져올 때 발생하며,이 경우 객체를 매개 변수로 사용해야합니다. 다음은 간단한 예입니다.
public String getRevision(Item item) {
service.load(item, "revision");
// there is usually more work to do before getting the data..
try {
return item.get_revision();
}
catch(NotLoadedException exception) {
log.error("Property named 'property_name' was not loaded", exception);
}
return null;
}
어떻게 그리고 왜이 메소드 명명 사이에서 결정하는 getRevision()
나 findRevision()
?