openwrt를 실행하는 바보 AP에서 OpenVSwitch 구성


0

현재 OpenWrt에서 openvswitch를 실행하려고합니다. 다음은 내가 달성하고자하는 설정입니다. OpenWRT를 실행하는 AP에 2 대의 무선 클라이언트를 연결했습니다 (내 액세스 포인트는 Netgear WNDR3700 임). AP가 바보 야. 그런 다음 AP를 PI에 연결했습니다. PI가 인터넷에 연결되어 있고 DHCP가 실행 중입니다. 마지막으로 나는 PI를 운영하고 있습니다.

Onos는 장치 (ovs 스위치)를 볼 수 있으며 호스트 (두 대의 랩톱)도 볼 수 있습니다. 그러나 호스트에는 IP 주소가 할당되지 않습니다. 무선 인터페이스가 LAN 네트워크에 할당되면 IP 주소가 할당되지만 호스트는 호스트를 인식하지 못합니다.

============

다음은 몇 가지 업데이트입니다. 나는 wan 인터페이스 eth1.1을 만들고 ovs bridge에 추가했습니다. ovs에 포트 2 (wlan0)에서 들어오는 모든 패킷을 포트 3 (eth1.1)으로 푸시하는 규칙을 추가했습니다. PI는 라우터의 WAN 포트에 연결됩니다. ovs bridge, wlan0 인터페이스 및 eth1.1 인터페이스에서 tcpdump를 수행했습니다. 모든 3 개의 인터페이스에서 무선 클라이언트에서 오는 arp 패킷을 볼 수 있습니다. 그러나 pi의 eth1에서 TCPdump를 수행하면 아무 것도 볼 수 없습니다.

============

여기에 /etc/config/network:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd3c:8eef:8a02::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1 eth1 radio0.network1'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.43.2'
    option gateway '192.168.43.1'
    option dns '192.168.43.1'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option blinkrate '2'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 5t'

config switch_port
    option device 'switch0'
    option port '1'
    option led '6'

config switch_port
    option device 'switch0'
    option port '2'
    option led '9'

config switch_port
    option device 'switch0'
    option port '5'
    option led '2'

config interface 'wlan0'
    option proto 'none'

여기에 / etc / config / wireless가있다.

config wifi-device 'radio0'    
    option type 'mac80211'    
    option channel '11'  
    option hwmode '11g'
    option path 'pci0000:00/0000:00:11.0'
    option htmode 'HT20'

config wifi-iface
    option device 'radio0'
    #option network 'lan'
    option mode 'ap'
    option ssid 'OpenWrt'
    option encryption 'none'

답변:


0

[해결] / etc / config / network의 변경 내용은 다음과 같습니다.

[Solved] here is the change in the /etc/config/network file: 
config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd3c:8eef:8a02::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1 eth1 ovsbr'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.43.2'
    option gateway '192.168.43.1'
    option dns '192.168.43.1'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option blinkrate '2'
    option enable_vlan4k '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 5t'

config switch_port
    option device 'switch0'
    option port '1'
    option led '6'

config switch_port
    option device 'switch0'
    option port '2'
    option led '9'

config switch_port
    option device 'switch0'
    option port '5'
    option led '2'

config interface 'wan'
    option ifname 'eth1.1'
    #option force_link '1'
    option proto 'none'
    #option ipaddr '192.168.43.4'
    #option netmark '255.255.255.0'


config switch_vlan
    option device 'switch0'
    option vlan '3'
    option vid '3'
    option ports '3 5t'

config interface 'lan1'
    option proto 'static'
    option ifname 'eth0.3'
    #option auto '1'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option vid '2'
    option ports '2 5t'

config interface 'lan2'
    option proto 'static'
    option ifname 'eth0.2'

config switch_vlan
    option device 'switch0'
    option vlan '4'
    option vid '4'
    option ports '1 5t'

config interface 'lan3'
    option proto 'static'
    option ifname 'eth0.4'

config switch_vlan
    option device 'switch0'
    option vlan '5'
    option vid '5'
    option ports '0 5t'

config interface 'lan4'
    option proto 'static'
    option ifname 'eth0.5'

#config interface 'ovsbr'
#   option proto 'static'
#   option ifname 'ovsbr'
#   option ipaddr '192.168.43.3'
#   option netmask '255.255.255.0'
#   option type 'bridge'

config interface 'wlan0'
    option protocol 'none'

ovsbr 브릿지에 포트로 eth1.1, eth0.2, eth0.3, eth0.4 및 eth0.5, wlan0을 추가했음을 주목하십시오! :)

당사 사이트를 사용함과 동시에 당사의 쿠키 정책개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.