우분투 12.04 LTS에 램프 서버 및 phpmyadmin을 새로 설치 한 후 phpmyadmin 및 mysql에 로그인 할 수 없음


2

이 문제에 대한 해결책을 찾으려고하지만 해결책을 찾지 못했습니다. phpmyadmin에 로그인하는 동안 오류가 발생합니다

#1045 Cannot log in to the MySQL server

Connection for controluser as defined in your configuration failed.

config-db.php를 구성하려고하는데 config.inc.php 파일은 / etc / phpmyadmin / 디렉토리에 있습니다. 거기에서 루트 사용자 및 암호로 config-db.php의 $ dbname 및 $ dbpass를 변경하고 있지만 여전히 로그인 할 수 없습니다. 구글 후, 나는 config.inc.php에서 단서를 얻었고 주석 처리를하지 않았습니다.

/* Uncomment the following to enable logging in to passwordless accounts,
     * after taking note of the associated security risks. */
    $cfg['Servers'][$i]['AllowNoPassword'] = TRUE;

이 것들이 너무 우스워서 램프 서버 설치 와 같은 기사를 단계별로 보여 주며 같은 일을하지만이 오류가 세 번 나옵니다. 심지어 쉘을 통해 mysql에 로그인 할 수 없습니다. 이 문제를 해결하고 mysql을 설치하는 동안 암호를 두 번 입력 할 때 실제로 발생하는 이유를 알 수 있도록 도와주세요.


수퍼 유저에 대해이 질문을하기 위해 stackoverflow에서 리디렉션되었습니다
— Shashank

어떤 계정으로 로그인하려고합니까? 루트 계정으로 로그인 할 수 있습니까?
— Rhyuk

@Rhyuk : 예 램프 서버 설치 중 설치하는 동안 루트 계정을 사용하고 있습니다
— Shashank

MySQL 비밀번호를 재설정 해 보셨습니까?
— Rhyuk

내 서버에서 루트 계정 만 사용하고 있습니다
— Shashank

답변:


1

MySQL 비밀번호를 변경하십시오.

mysqld 비밀번호를 재설정하려면 다음 지침을 따르십시오.

  1. 이 명령을 사용하여 mysql 클라이언트 프로세스를 시작하십시오.

    mysql -u root

  2. mysql 프롬프트 에서이 명령을 실행하여 모든 암호를 변경할 수 있습니다

    FLUSH PRIVILEGES;

  3. 그런 다음 비밀번호를 재설정 / 업데이트하십시오

    SET PASSWORD FOR root@'localhost' = PASSWORD('password');

  4. 성공적인 쿼리 (하나 이상의 행이 영향을 받음)를 나타내는 메시지를 받으면 권한을 플러시하십시오.

    FLUSH PRIVILEGES;

  5. 그런 다음 mysqld 프로세스를 중지하고 고전적인 방법으로 다시 시작하십시오.

    sudo /etc/init.d/mysql stop sudo /etc/init.d/mysql start

출처 : https://help.ubuntu.com/community/MysqlPasswordReset

최신 정보:

현재 비밀번호를 업데이트 해보십시오. 이 작업을 수행:

$ pkill mysql
$ sudo mysqld --skip-grant-privileges
$ mysql

이 시점에서 mysql 명령 쉘을 얻는다. 비밀번호를 재설정 할 때 루트 비밀번호를 업데이트하고 테이블을 플러시해야합니다.

mysql> set UPDATE mysql.user SET Password=PASSWORD('YOUR_NEW_PASSWORD') WHERE User='root';
mysql> FLUSH PRIVILEGES;

비밀번호를 비웠으니 mysql 데몬을 다시 시작하면된다.

$ sudo pkill mysqld
$ sudo /etc/init.d/mysqld start
$ mysql -u root -p
Enter Password: YOUR_NEW_PASSWORD
mysql>

소스를 알고 있지만 쉘에서 mysql -u root를 입력하면 오류가 발생합니다. ERROR 1045 (28000) : 사용자 'root'@ 'localhost'에 대한 액세스가 거부되었습니다 (비밀번호 사용 : NO)
— Shashank

이제 mysql -u root를 수행 한 후이 오류가 발생합니다. ERROR 1040 (HY000) : 연결이 너무 많습니다
— Shashank

답변을 업데이트했습니다.
— Rhyuk

pkill mysql sudo mysqld --skip-grant-privileges,이 단계 후에, mysql 명령은 ERROR 1040 (HY000)을줍니다 : 너무 많은 연결
— Shashank

최대 연결 제한에 도달하면 /etc/my.cnf로 이동하여 [mysqld] 섹션에서 max_connections = 500을 추가하고 MySQL을 다시 시작한 다음 비밀번호를 다시 업데이트하십시오.
— Rhyuk

1

"mysql"비밀번호를 입력하십시오. mysql 루트와 시스템 로그인 루트 암호는 동기화되지 않으므로 각각 개별적으로 설정해야합니다. mysql 루트 로그인을 변경하십시오!


이 오류 ERROR 1040 (HY000) : mysql 및 mine 암호를 시도한 후 연결이 너무 많지만 작동하지 않음
— Shashank

로 mysql을 재설정하십시오 service mysql restart. 기본 비밀번호가 작동하지 않았으므로 아래와 같이 권한 부여를 건너 뛰어야하는 것처럼 들립니다.
— SilverbackNet
당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.