MySQL 5.5 다운 그레이드> 5.1 - 우분투 12.04


1

MySQL 5.5를 실행하는 우분투 12.04 서버가 있습니다.

MySQL 5.1 또는 5.0을 어떻게 설치할 수 있습니까?

몇 가지 명령을 시도했습니다.

apt-get install mysql-server-5.1
apt-get install mysql-server

아무도 일하지 않았다 ... 나는 힌트를 줘서 googled,하지만 성공하지 못했습니다.

고맙습니다.

답변:


1

STEVEN MARTIN (MySQL 전문가)이 제공하는 솔루션

1 º 스텝 :

이전 mysql 설치를 완전히 제거하십시오.

sudo apt-get purge mysql-server mysql-common

2 º 스텝 :

MySQL 4.1 소스 다운로드 그것을 구축하고 설치하십시오.

wget http://mirror.provenscaling.com/mysql/community/source/4.1/mysql-4.1.24.tar.gz

3 º 스텝 :

다음 명령을 실행하여 소스의 압축을 풀고 소스를 빌드 한 후 설치하십시오.

sudo tar -xvzf mysql-4.1.24.tar.gz --directory=/usr/local/src
cd /usr/local/src/mysql-4.1.24/
sudo groupadd mysql
sudo useradd -g mysql mysql
sudo apt-get install
sudo ./configure --prefix=/usr/local/mysql
sudo make
sudo mkdir /usr/local/mysql
sudo mkdir /usr/local/mysql/include
sudo mkdir /usr/local/mysql/include/mysql
sudo mkdir /usr/local/mysql/lib
sudo mkdir /usr/local/mysql/lib/mysql
sudo mkdir /usr/local/mysql/share
sudo mkdir /usr/local/mysql/man
sudo mkdir /usr/local/mysql/mysql-test
sudo checkinstall
    y
    mysql-server 4.1.24
dpkg -l | grep -i mysql
sudo cp support-files/my-medium.cnf /etc/my.cnf
cd /usr/local/mysql/
pwd
bin/mysql_install_db --user=mysql
sudo chown -R root .
sudo chown -R mysql var
sudo chgrp -R mysql .
bin/mysql --version
bin/mysql_install_db --user=mysql
sudo bin/mysqld_safe user=mysql &

0

현재 설치된 버전을 제거하고 버전 5.1을 다운로드하십시오. 이리 .


제거하는 방법?
— Darkeden

@Darkeden apt-get remove
— user1301428

내가 말한대로 제거 했어 ... 지금 설치 단계에서이 오류가 발생합니다 : MySQL 시스템 테이블 설치 중 ... 130208 12:42:12 [오류] 언어 특정 부분이 감지 된 이전 스타일 - 언어 값 : / usr / share / mysql / english / 130208 12:42:12 [ERROR] 대신 언어 특정 부분없이 --lc-messages-dir을 사용하십시오.
— Darkeden

@Darkeden 조금 돌아 다니면서 나는이 페이지를 발견했다. 유용 할 것이다. grokbase.com/t/mysql/mysql/12bcgmxp4v/mysqld-cannot-start
— user1301428

쓸데없는 ... 나는 MySQL 5.5를 완전히 제거하고 5.1을 설치하기위한 적절한 가이드가 필요하다.
— Darkeden
당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.