CentOS 6.5-bash : service : command not found


10

serviceCentOS 6.5 서버에 입력 할 수 없습니다 . 루트로 로그인했습니다. 입력 service하면이 오류가 발생합니다.

bash : service : 명령을 찾을 수 없습니다

나는 또한 입력하려고했지만 sudo service운이 없다. 그런 다음이 오류가 발생합니다.

sudo : 서비스 : 명령을 찾을 수 없습니다


내 경우에는 cd /sbin/; ./service내가 찾던 것을 주었다.
— Greenish

답변:


10

주석을 통한 확장 된 토론에서 발견 된대로 시스템이 손상되었습니다. 시스템을 완전히 다시 설치하거나 적어도 손상된 패키지를 다시 설치하는 것이 좋습니다.

/sbin/service다시 실행 하려면 yum reinstall initscripts.

권장하지는 않지만 확인에 실패한 모든 패키지를 다시 설치하려면 다음을 실행하십시오.

yum reinstall $(rpm -q --qf '%{NAME}\n' -a | while read rpm; do rpm -V $rpm >/dev/null || echo $rpm; done)

수정 된 구성 파일 또는 변경된 구성조차도 mtime다시 설치를 트리거 할 수 있습니다. .rpmnew원본을 변경 하면 새 구성 파일에 확장자가 나타납니다.


전체 시스템을 다시 설치하는 것이 좋습니다. 문제가 어떻게 발생했는지 알고 있습니까? (이전에 발생했던 마지막 명령은 tmux a -t 스크립트였으며 지금은 로그인 할 때 yum install httpd 및 yum install php-mysql을 수행 한 다음 httpd start 서비스를
— 했는데 실패했습니다

누군가가 서버에 침입했을 수 있습니다. 아마도 당신은 취약한 PHP 응용 프로그램을 실행하고 있었을 것입니다. 손상된 서버 를 어떻게 처리합니까?를 살펴보십시오 . 서버 결함에서. 어쨌든 추가 분석을 위해 다시 설치하기 전에 로그를 저장하는 것을 잊지 마십시오.
— Cristian Ciupitu

괜찮아. 도움을 주셔서 감사합니다. PHP 응용 프로그램을 실행하지 않았습니다. 자바 단지 만. 그들이 문제를 일으킬 수 있는지 모르겠습니다.
— user3524823 2016 년

Java 브라우저 플러그인은 보안 취약점으로 악명 높지만 귀하의 경우 서버 측에 익숙하지 않습니다.
— Cristian Ciupitu

7

service명령이 sbin디렉토리에 있습니다 . 명령이 디렉토리에 있는지 확인하십시오./sbin/service

루트 사용자 인 경우이 메일 링리스트에 따라 다음 경로에 있는지 확인해야합니다 : Centos5-Service Command Not Present .

또한 chkconfig서비스를 활성화 할 수 있기 때문에 라는 유사한 기능을 확인할 수도 있습니다 . CentOS-chkconfig

첨부 된 링크는 CentOS 5 용이지만 CentOS 6.5에서는 다르지 않습니다.


2

CentOS 5.2에서 PATH에 / sbin을 추가하여이 문제를 해결할 수있었습니다.

export PATH=$PATH:/sbin

이것은 다른 답변을 복제하고 새로운 내용을 추가하지 않습니다. 실제로 새로운 내용이 없다면 답변을 게시하지 마십시오.
— DavidPostill

sbin은 루트 사용자의 경로에만 있어야합니다.
— Xyon
당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.