RHEL 7에서 NetworkManager 비활성화


9

vmware vSphere에서 RHEL7 서버를 설정하고 NetworkManager가없는 네트워크에서 서버를 가져 오는 데 문제가 있습니다. 설치 과정에서 서버가 고정 IP를 갖도록 구성하고 NetworkManager를 사용하여 모든 것을 설정했습니다. 이것이 작동하는 동안 우리는 내 사무실에서 NetworkManager를 사용하지 않으므로 NetworkManager없이 RHEL6 서버를 온라인으로 가져 오기 위해 구성 파일을 넣는 것을 입력했습니다.

/ etc / sysconfig / network-scripts / ifcfg-ens192는 다음과 같습니다.

NAME = ens192
TYPE = 이더넷
ONBOOT = 예
NM_CONTROLLED = 아니오
BOOTPROTO = 정적
IPADDR = 10.0.2.15
PREFIX = 24
게이트웨이 = 10.0.2.2

그러나 NetworkManager를 비활성화하면 네트워크 서비스가 다음 오류로 시작되지 않습니다

#service network restart

systemctl을 통한 네트워크 재시작 : network.service 작업에 실패했습니다. 자세한 내용은 'systemctl status network.service'및 'journalctl -xn'을 참조하십시오.

그리고 두 명령 모두 다음을 출력합니다.

네트워크 [1838] : RTNETLINK 답변 : 파일이
네트워크에 존재 함 [1838] : RTNETLINK 답변 : 파일이
네트워크에 존재 함 [1838] : RTNETLINK 답변 : 파일이
네트워크 존재 [1838] : RTNETLINK 답변 : 파일이
네트워크 존재 [1838] : RTNETLINK 답변 : 파일이 존재
network [1838] : RTNETLINK 답변 : 파일이
네트워크에 존재 합니다 [1838] : RTNETLINK 답변 : 파일이 존재합니다
systemd [1] : network.service : 제어 프로세스가 종료되었습니다, code = 종료 상태 = 1
systemd [1] : LSB를 시작하지 못했습니다 : 가져 오기 업 / 다운 네트워킹

또한 'ip addr'명령이 출력하는 내용은 다음과 같습니다.

1 : lo : mtu 65536 qdisc noqueue state UNKNOWN
     링크 / 루프백 00 : 00 : 00 : 00 : 00 : 00 brd 00 : 00 : 00 : 00 : 00 : 00
     inet 127.0.0.1/8 범위 호스트 lo
       valid_lft forever preferred_lft forever
     inet6 :: 1/128 범위 호스트
       valid_lft forever preferred_lft forever
2 : ens192 : mtu 1500 qdisc noop state DOWN qlen 1000
     링크 / 에테르 08 : 00 : 27 : 98 : 8e : df brd ff : ff : ff : ff : ff : ff


RTNETLINK answers: File existsnetwork.service추가하려는 모든 항목 (아마도 IP 주소)이 이미 존재 했음을 의미합니다 . ip addr질문을 실행 하고 결과를 추가하십시오.
— BenjiWiebe

최근에 문제를 디버깅 network.service했으며 ip 명령을 추적하는 가장 좋은 방법은 strace입니다. 일반적으로 이러한 유형의 오류가 발생하지 않아야합니다. 보고하는 것이 좋습니다 (이상적으로 지원을 통해).
— Pavel Šimerda

답변:


2

VM의 MAC 주소를 확인하십시오. ip addr를 실행 했으므로 08 : 00 : 27 : 98 : 8e : df 여야합니다. 다른 것이 있으면 ifcfg-ens192 파일에서 다음과 같이 설정해야하지만 주소를 실제 주소로 바꿔야합니다.

HWADDR="08:00:27:98:8e:df"

나는 같은 문제가 있었고 이것이 나를 위해 해결했다.


질문의 구성 파일은 MAC 주소와 일치하지 않는 NAME = ens192를 사용합니다.
— Pavel Šimerda

1

이 문제를 해결하는 데 필요한 것은 구성의 MAC입니다.

 NAME=ens192
 TYPE=Ethernet
 ONBOOT=yes
 HWADDR="08:00:27:98:8e:df"
 NM_CONTROLLED=no
 BOOTPROTO=static
 IPADDR=10.0.2.15
 PREFIX=24
 GATEWAY=10.0.2.2

하드웨어 주소를 모르면 찾을 수 있습니다.

 cat /sys/class/net/ens192/address

1

가상 머신 네트워크 설정으로 이동하여 네트워크 케이블이 연결되어 있는지 확인하고 방화벽으로이를 차단했는지 확인하십시오.


0

정보가 완료되면 / etc / sysconfig / network에 해당 정보 (GATEWAY = 10.0.2.2)를 입력해야합니다.


0

NetworkManager를 비활성화 한 후 "LSB를 시작하지 못했습니다 : 네트워킹 시작 / 종료"오류가 발생했습니다. 부팅 후 인터페이스를 불러오는 데 2 ​​분이 걸렸습니다. 혼란의 원인은 "... LSB"였습니다. 메시지는 전통적인 /etc/rc.d/init.d/network 스크립트에서 나왔습니다. 제 경우에는 다음과 같은 문제가 해결되었습니다.

에 네트워크 스크립트 /이 ifcfg-eth0를가 추가

NMCONTROLLED=no

NetworkManager가 남겨둔 불필요한 ifcfg- * 파일을 제거했습니다.

# rm /etc/sysconfig/network-scripts/ifcfg-Wired_connection_?

0

문제가 해결됩니다!

# rm /etc/udev/rules.d/70-persistent-ipoib.rules 

# reboot
  • 이제 / etc / sysconfig / network-scripts / ifcfg-eth0를 편집하십시오.
  • 생성 된 새 HWADDR 추가 또는 제거
  • UUID 줄 제거

네트워킹 서비스를 다시 시작하십시오

 #systemctl restart network.service

지금! 일.


0

인터페이스가 nm 비활성화되어 있어도 NetworkManager는 기본 경로 (ip route)를 표시합니다. 전체 시스템이 아닌 해당 인터페이스 일뿐입니다.

ps aux | grep -I net   # will probably find NetworkManager still running.
chkconfig network on
systemctl disable NetworkManager.service
systemctl stop NetworkManager.service

1
systemctl disable서비스를 멈추지 않으며 chkconfig ... off기본적으로 동일한 명령으로 변환 하지 않습니다 .
— Pavel Šimerda

-1

나는 같은 문제를 겪고 있었다. 난 그냥 백업 파일을 삭제 그래서 나는에서 만든 /etc/sysconfig/network-scripts같은, ifcfg-Bridge_connection_1.home그리고 ifcfg-Bridge_connection_1.office내가 백업 사용을 위해 만든. 그것들은 거기서 만들어서는 안됩니다. 은 /etc/init.d/network restart후 잘 작동하는 쓸모 ifcfg- *을 삭제할 수 있습니다.

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.