Raspberry pi 2 위에서 OPENWRT 혼돈 진정기를 실행하고 있습니다. OPENVPN 클라이언트 및 클라이언트가 VPN 터널을 통해 트래픽을 라우팅하도록 구성했습니다. 그러나 pi LAN 인터페이스를 재부팅하면 짧은 시간 동안 WAN 인터페이스에 직접 연결하고 트래픽을 VPN 터널 외부로 라우팅합니다. 이것은 아주 작은 시간 동안 만 발생합니다. (VPN 클라이언트를 시작해야하는 시간). 그러나 나는 이것을 멈춰야한다. VPN 클라이언트를 통해 거의 모든 트래픽을 항상 라우팅해야하며 연결되지 않은 VPN 사용자가 인터넷에 액세스 할 수없는 경우. 이 설정으로 TINYPROXY라는 프록시 클라이언트를 구성했으며 문제가 발생할 수 있습니다. 그러나 나는 이것을 막는 방법을 모른다.
이것들은 내 설정입니다
/ etc / config / network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.2.1'
option dns '8.8.8.8 8.8.4.4'
config interface 'wan'
option ifname 'eth1'
option proto 'dhcp'
option peerdns '0'
option dns '8.8.8.8 8.8.4.4'
config globals 'globals'
option ula_prefix 'fd14:b495:5965::/48'
config interface 'vpn0'
option ifname 'tun0'
option proto 'none'
option auto '1'
option delegate '0'
/ etc / config / firewall
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'
config zone
option name 'wan'
option output 'ACCEPT'
option masq '1'
option mtu_fix '1'
option input 'ACCEPT'
option forward 'ACCEPT'
option network 'wan wan6 vpn0'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config include
option path '/etc/firewall.user'
config redirect
# option target 'DNAT'
# option dest 'vpn'
option name 'Transparent Proxy Redirect'
option src 'lan'
option proto 'tcp'
option dest_port '8888'
option src_dport '80'
option src_dip '!192.168.2.1'
option dest_ip '192.168.2.1'
config zone
option name 'vpn'
option masq '1'
option input 'ACCEPT'
option forward 'ACCEPT'
option output 'ACCEPT'
option network 'vpn0'
config forwarding
option src 'vpn'
option dest 'lan'
/ etc / config / tinyproxy
config tinyproxy
option enabled '1'
option User 'nobody'
option Group 'nogroup'
option Port '8888'
option Timeout '600'
option DefaultErrorFile '/usr/share/tinyproxy/default.html'
option StatFile '/usr/share/tinyproxy/stats.html'
option LogFile '/var/log/tinyproxy.log'
option LogLevel 'Info'
option MaxClients '100'
option MinSpareServers '5'
option MaxSpareServers '20'
option StartServers '10'
option MaxRequestsPerChild '0'
option ViaProxyName 'tinyproxy'
list Allow '127.0.0.1'
list Allow '192.168.2.1/24'
list ConnectPort '443'
list ConnectPort '563'
list ConnectPort '80'
option Filter '/www/textui/tinyproxy/blocked.txt'
나는 이것을 정확하게 달성하고 싶다
사용자-> LAN-> TINYPROXY-> VPN-> WAN
TINYPROXY가 완벽하게 작동합니다. 다른 모든 구성은 정상적으로 작동합니다. PI 재부팅시 짧은 시간 동안 만 문제가 발생합니다.
누군가 나를 도울 수 있습니까?