SSH 거부 연결- "sshd : 인식 할 수없는 서비스"


10

SSH에 문제가 있습니다.

ssh: connect to host 192.168.1.7 port 22: Connection refused

SSH를 사용하여 데스크탑을 다른 데스크탑에 연결하려고 할 때마다 위의 오류가 발생하지만 다른 데스크탑을 성공적으로 ping 할 수 있습니다.

ssh: connect to host 192.168.1.7 port 22: Connection refused

sshd를 다시 시작하려고하면 다음 오류가 발생합니다.

sshd: unrecognized service

SSH를 사용하여 원격 서버에 연결할 수 있지만 로컬 네트워크 내에서는 연결할 수 없습니다. 이 문제를 어떻게 해결할 수 있습니까?


사용중인 명령 행 또는 응용 프로그램을 제공하십시오. 또한 우분투 버전을 추가하십시오 . 이 두 데스크탑이 동일한 LAN (로컬 네트워크)에 있습니까?
— david6

1
ssh 데몬을 어떻게 시작하려고합니까? 을 사용해야합니다 sudo service ssh start. 그래도 문제가 해결되지 않으면 ls -l /etc/init/ssh.conf?
— Jeremy Kerr

@ david6, 동일한 LAN에 있지 않으면 연결이 실패하거나 블랙홀됩니다. 연결이 거부되었습니다. 즉, 컴퓨터가 요청을보고 거부를 다시 보냈 음을 의미합니다.
— Nathan JB

동일한 로컬 네트워크 내의 다른 컴퓨터로 ssh 해야하는 Ubuntu 12.10을 사용하고 있습니다. 그러나 다른 네트워크의 원격 서버에 연결할 수 있습니다. 도와주세요 ...
— Rudra

방화벽을 사용하고 있는지 확인하십시오. 되어 SSH 서버가 각 대상 호스트에 설치?
— david6

답변:


13

openssh-server를 설치 제거한 후 설치하십시오.

sudo apt-get remove openssh-client openssh-server

그리고

sudo apt-get install openssh-client openssh-server

이것은 나를 위해 일했습니다. 여전히 연결할 수 없으면 시도하십시오

sudo ufw status verbose

출력이 무엇인지 알려주십시오.


나는 같은 문제를 겪고 있으며 sudo ufw status verboseis 의 출력 status: inactive이므로 활성화했지만 오류가 지속됩니다. 이것은 새로운 출력입니다Status: active Logging: off Default: deny (incoming), allow (outgoing) New profiles: skip To Action From -- ------ ---- 22 ALLOW IN Anywhere 22 ALLOW IN Anywhere (v6)
— Nishant

6

먼저 192.168.1.7에서 실행되는 ssh 서비스가 아닌지 확인하십시오. 시스템에 SSH 데몬이 없을 수 있으므로 해당 시스템에 ssh를 설치해야합니다.

sudo apt-get install openssh-server

이미 설치되어 sudo service ssh restart있으면를 실행 한 다음 두 시스템 모두에서이 명령의 출력으로 여기에 주석을 답니다.


ssh를 다시 시작하면 먼저 중지되고 PID 번호로 시작합니다.
— Rudra

고맙습니다. 이것은 저에게 정확히 맞는 것 같습니다 ... opensh-server가 대상 시스템에 설치되어 있어야합니다.
— Br. Sayan

0

Ubuntu 웹 사이트에서 Ubuntu 14.04 LTS 데스크탑 버전을 설치하면 openssh-server가 기본적으로 설치되지 않습니다. 큰 뚱뚱한 가슴 다운 정식 !!!!! 설치는 비교적 쉽고 위의 다른 답변에서 이미 언급했습니다.

sudo apt-get update && sudo apt-get upgrade && sudo apt-get install openssh-server


1
많은 사람들이 ssh를 사용하지 않습니다. 데스크톱 버전에는 기본적으로 서버가 포함되지 않는 것이 좋습니다.
— ps95

0

라우터가 ssh를 허용하거나 설정의 어딘가에 활성화되어 있는지 확인하십시오. 때때로이 단순한 것을 간과 할 수 있습니다.


0
  1. 이동 vim /etc/ssh/sshd_config

  2. 인증 "PermitRootLogin"을 "yes"로 변경하십시오.

    예 :

    Authentication:
    
    PermitRootLogin yes
    
  3. service sshd restart


0

SSH 서버가 설치되어 있는지 확인하십시오.

dpkg -l openssh-server

그렇지 않은 경우 설치하십시오.

sudo apt update && sudo apt install -y ssh

이제 22 포트가 사용 중인지 확인하십시오.

netstat -atn | grep :22
당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.