Sudo가 작동하지 않습니다.“/ etc / sudoers는 uid 1000이 소유하고 있으며 0이어야합니다.”


21

터미널별로 sudo 명령을 입력하면 오류가 표시됩니다.이 문제를 해결하는 방법

sudo: /etc/sudoers is owned by uid 1000, should be 0
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin

답변:


31

소유자를 다시 루트로 변경하십시오.

pkexec chown root:root /etc/sudoers /etc/sudoers.d -R

또는 visudo명령을 사용하여 파일의 일반적인 정확성을 보장하십시오 ( @KasiyA 덕분에 ).

pkexec visudo

3
그것을 고치는 더 쉬운 방법은 :pkexec visudo
— αғsнιη

문제가 있는데 EC2 인스턴스가 있고 솔루션을 시도했는데 암호를 묻습니다. 이것을 어떻게 완화합니까?
— david

글쎄, 그건 짜증나; " 'pkexec'프로그램이 현재 설치되어 있지 않습니다. 다음을 입력하여 설치할 수 있습니다. sudo apt-get install policykit-1"
— Koen.

@ 코엔. 우분투에 기본적으로 설치됩니다 (아마도 서버를 말하거나 최소 설치를하지 않는 한).
— muru

실제로 서버 설치이지만 단일 사용자 모드로 부팅하여 수정했습니다.
— 코엔.
당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.