재시작 후 Nginx 502 불량 게이트웨이


1

방금 이전 직원이 설정 한 서버 관리를 인수했습니다. Ubuntu 16.04.3 LTS 서버이며 일부 레거시 코드 (AWS에서 실행)의 SVN 서버로 순수하게 사용됩니다.

nginx를 실행 중이며 일반적으로 브라우저에서 URL https://mysvn.com에 액세스하여 "It works!"라는 페이지를 얻을 수 있습니다.

최근에 서버에 최신 업데이트를 패치했으며 재부팅 후 브라우저에 502 Bad Gateway 메시지가 표시되었습니다. 그러나 가장 이상한 점은 가장 최근의 스냅 샷을 사용하여 첨부 된 새 볼륨을 생성했는데 문제가 계속 발생한다는 것입니다. 그래서 이것은 패치로 인한 것이 아니라 재부팅을 처리 할 수없는 nginx 구성에 관한 것입니다.

불행히도 구성에 어떤 문제가 있는지 nginx에 대해 충분히 알지 못합니다.

로그의 오류 메시지는 다음과 같습니다.

2018/01/08 09:35:05 [error] 10387#10387: *162 connect() failed (111: Connection refused) while connecting to upstream, client: XX.XX.XXX.XX, server: mysvn.com, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:8080/", host: "mysvn.com"

/ etc / nginx / sites-available에있는 파일의 코드는 다음과 같습니다.

server {
        listen 80 default_server;
        listen [::]:80 default_server;
        root /var/www/html;

        server_name mysvn.com;

        location /.well-known {
            alias /var/www/html/.well-known;
        }
}

server {
        listen              443 ssl;
        server_name         mysvn.com;
        ssl_certificate     /home/jenkins/.acme.sh/mysvn.com/mysvn.com.cer;
        ssl_certificate_key /home/jenkins/.acme.sh/mysvn.com/mysvn.com.key;
        ssl_protocols       TLSv1 TLSv1.1 TLSv1.2;
        ssl_ciphers         "EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH";
        ssl_dhparam         /etc/ssl/certs/dhparam.pem;

        root /var/www/html;

        # Add index.php to the list if you are using PHP
        index index.html index.htm index.nginx-debian.html;

        location / {
                # First attempt to serve request as file, then
                # as directory, then fall back to displaying a 404.
                # try_files $uri $uri/ =404;
                proxy_pass http://localhost:8080/;
        }
        client_max_body_size 200M;

}

오류의 원인에 대한 자세한 정보를 찾을 수있는 방법이 있습니까?

답변:


1

이 주제가 askubuntu.com에 대한 것인지 확실하지 않지만 답변을 시도합니다.

proxy_pass http://localhost:8080/;nginx는 모든 요청을 처리하고 프록시 할 것으로 예상되는 것을 가지고 있습니다. 어쩌면 아파치가 있고 서버 재부팅 후 실행되지 않을 수 있습니다.

를 사용하여 시작해보십시오 service apache2 start. "작동합니다!" 페이지!


때로는 어떤 사이트가 특정 질문에 가장 적합한 지 명확하지 않습니다. 어쨌든이 서버에는 아파치가 전혀 설치되어 있지 않습니다.
— shaneoh

따라서 어떤 응용 프로그램이 포트 8080을 사용하는지 찾습니다. 구성에서 Nginx는 포트 8080이 열리기를 기다립니다. 그렇지 않으면 "잘못된 게이트웨이"가 표시됩니다. 도움이
— 되길

나는 결국 아파치가 도커 컨테이너 내부에서 실행 중이며이 컨테이너를 실행하는 것이 문제라는 것을 발견했습니다.
— shaneoh
당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.