dbus : [시스템] 'org.freedesktop.login1'서비스를 활성화하지 못했습니다 : 시간이 초과되었습니다


25

내 서버 중 하나의 syslog에 다음과 같은 오류 메시지가 계속 나타납니다.

# tail /var/log/syslog
Oct 29 13:48:40 myserver dbus[19617]: [system] Failed to activate service 'org.freedesktop.login1': timed out
Oct 29 13:48:40 myserver dbus[19617]: [system] Activating via systemd: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'
Oct 29 13:49:05 myserver dbus[19617]: [system] Failed to activate service 'org.freedesktop.login1': timed out
Oct 29 13:49:05 myserver dbus[19617]: [system] Activating via systemd: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'

ProFTPd 데몬의 FTP 로그인과 관련이있는 것 같습니다.

# tail /var/log/proftpd/proftpd.log
2015-10-29 13:48:40,433 myserver proftpd[17872] myserver.example.com (remote.example.com[192.168.22.33]): USER switch: Login successful.
2015-10-29 13:48:40,460 myserver proftpd[17872] myserver.example.com (remote.example.com[192.168.22.33]): FTP session closed.
2015-10-29 13:48:40,664 myserver proftpd[17881] myserver.example.com (remote.example.com[192.168.22.33]): FTP session opened.
2015-10-29 13:49:05,687 myserver proftpd[17881] myserver.example.com (remote.example.com[192.168.22.33]): USER switch: Login successful.
2015-10-29 13:49:05,705 myserver proftpd[17881] myserver.example.com (remote.example.com[192.168.22.33]): FTP session closed.
2015-10-29 13:49:05,908 myserver proftpd[17915] myserver.example.com (remote.example.com[192.168.22.33]): FTP session opened.

그러나 FTP 로그인 자체는 사용자에게 아무런 문제없이 작동하는 것 같습니다. ProFTPd를 실행하는 다른 서버가 몇 대 있지만 지금까지 이러한 오류가 발생하지 않았습니다.

데비안 7에서 데비안 8 로의 최근 업그레이드와 관련이있을 수 있습니다.

메시지가 무엇을 말하고 싶은지, 또는 그것들을 야기하는 아이디어가 있습니까?

이미 dbus 및 proftpd 데몬 및 서버를 다시 시작하려고 시도했으며 DBUS 소켓 / var / run / dbus / system_bus_socket이 있는지 확인했지만 지금까지 메시지가 계속 표시됩니다.

편집 : 의견에서 요청한대로 journalctl의 출력 :

root@myserver:/home/chammers# systemctl status -l dbus-org.freedesktop.login1.service
● systemd-logind.service - Login Service
   Loaded: loaded (/lib/systemd/system/systemd-logind.service; static)
   Active: active (running) since Tue 2015-10-27 13:23:32 CET; 1 weeks 0 days ago
     Docs: man:systemd-logind.service(8)
           man:logind.conf(5)
           http://www.freedesktop.org/wiki/Software/systemd/logind
           http://www.freedesktop.org/wiki/Software/systemd/multiseat
 Main PID: 467 (systemd-logind)
   Status: "Processing requests..."
   CGroup: /system.slice/systemd-logind.service
           └─467 /lib/systemd/systemd-logind

Oct 28 10:15:25 myserver systemd-logind[467]: New session c3308 of user switch.
Oct 28 10:15:25 myserver systemd-logind[467]: Removed session c3308.
Oct 28 10:15:25 myserver systemd-logind[467]: New session c3309 of user switch.
Oct 28 10:15:25 myserver systemd-logind[467]: Removed session c3309.
Oct 28 10:15:25 myserver systemd-logind[467]: New session c3310 of user switch.
Oct 28 10:15:25 myserver systemd-logind[467]: Removed session c3310.
Oct 28 10:15:25 myserver systemd-logind[467]: New session c3311 of user switch.
Oct 28 10:15:25 myserver systemd-logind[467]: Removed session c3311.
Oct 28 10:19:52 myserver systemd-logind[467]: New session 909 of user chammers.
Oct 28 10:27:11 myserver systemd-logind[467]: Failed to abandon session scope: Transport endpoint is not connected

그리고 더 많은 journalctl 출력 :

Nov 03 16:21:19 myserver dbus[19617]: [system] Failed to activate service 'org.freedesktop.login1': timed out
Nov 03 16:21:19 myserver proftpd[23417]: pam_systemd(proftpd:session): Failed to create session: Activation of org.freedesktop.login1 timed out
Nov 03 16:21:19 myserver proftpd[23418]: pam_systemd(proftpd:session): Failed to create session: Activation of org.freedesktop.login1 timed out
Nov 03 16:21:19 myserver proftpd[23417]: pam_unix(proftpd:session): session closed for user switch
Nov 03 16:21:19 myserver proftpd[23418]: pam_unix(proftpd:session): session closed for user switch
Nov 03 16:21:19 myserver proftpd[23420]: pam_unix(proftpd:session): session opened for user switch by (uid=0)
Nov 03 16:21:19 myserver dbus[19617]: [system] Activating via systemd: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'
Nov 03 16:21:19 myserver proftpd[23421]: pam_unix(proftpd:session): session opened for user switch by (uid=0)

systemctl status -l dbus-org.freedesktop.login1.service루트로 실행할 때 무엇을 보고합니까? 출력에서 journalctl(특히 오류 메시지 시간에) 눈에 띄는 것이 있습니까?
— Ferenc Wágner

위의 systemctl / journalctl 출력을 추가했습니다.
— lathspell

1
로그인 ( systemctl restart systemd-logind)을 다시 시작하면 도움이됩니까?
— Ferenc Wágner

지금까지는 도움이되었습니다. 이제 서버를 재부팅하여 문제가 여기에보고되기 전에 간단한 재부팅이 도움이되지 않았는지 다시 확인했습니다.
— lathspell

다시 시작하면 문제가 해결 된 것 같습니다. 가장 실망스러운;) 간단한 "shutdown -r now"로 해결할 수없는 것은 무엇입니까? 도와 주셔서 감사합니다!
— lathspell

답변:


19

로그인 다시 시작 :

# systemctl restart systemd-logind

dbus를 다시 시작하면 연결이 다시 끊어집니다.


이것은 일시적으로 만 문제를 해결합니다. 잠시 후 (수개월) 같은 문제가 다시 나타납니다.
— Ortomala Lokni

3
# systemctl restart systemd-logind systemd-logind.service를 다시 시작하지 못했습니다. 연결 시간이 초과되었습니다. 자세한 내용은 시스템 로그 및 'systemctl status systemd-logind.service'를 참조하십시오.
— Dalibor Filus

그리고 @DaliborFilus를 보셨습니까?
— Ferenc Wágner

≤systemctl status php7.0-fpm나에게 같은 것을 말했기 때문에 그 당시 systemctl 상태를 실행하는 것은 무의미하다고 생각했습니다. 이것은 프로덕션 서버였습니다. 나는 빨리 행동해야했습니다. 다음에 시도합니다.
— Dalibor Filus

실제 문제가 SSH 로그인 속도가 느린 곳에서 수정했습니다. 필자의 경우 문제는 최근 시스템 업데이트와 관련이 있으며 그 이후에는 재부팅하지 않을 수 있습니다. needs-restarting(여전히) systemd는 재부팅이 필요하다고 말합니다.
— Nicolas Melay

7

재부팅은 나를 위해 일한 유일한 솔루션이었습니다. 나는 도망가는 dbus 프로세스를 죽였고 다른 것들은 실패했습니다.

이것은 내가 httpd-를 다시로드하려고 할 때 일어난 일입니다.

Error getting authority: Error initializing authority: Error calling StartServiceByName for org.freedesktop.PolicyKit1: GDBus.Error:org.freedesktop.DBus.Error.TimedOut: Activation of org.freedesktop.PolicyKit1 timed out (g-dbus-error-quark, 20)
Failed to reload httpd.service: Connection timed out

Centos7은 버그가 있습니다.


1

나는 오늘 같은 문제에 직면했으며 처음에 사용 가능한 모든 메모리를 먹는 서비스로 인해 발생한다는 것을 알았습니다. 관련 로그 라인을 찾았는데, 이는 / var / log / messages 로그의 메모리 할당으로 인한 것임을 분명히했습니다 .

systemd: Starting Session 750154 of user root.
systemd: Failed to fork: Cannot allocate memory
systemd: Assertion 'pid >= 1' failed at src/core/unit.c:1997, function unit_watch_pid(). Aborting.
systemd: Caught <ABRT>, cannot fork for core dump: Cannot allocate memory
systemd: Freezing execution.
dbus[697]: [system] Failed to activate service 'org.freedesktop.systemd1': timed out

내가 실행 한 대부분의 메모리를 사용하여 서비스를 찾으려면 다음을 수행하십시오.

ps aux --sort=-%mem

이 문제를 해결하기 위해 먼저 메모리를 확보하려고했지만 여전히 systemd-logind를 시작할 수 없었습니다. 따라서 서버를 재부팅해야했고 문제가 해결되었습니다.


1

systemd-logind 서비스 만 다시 시작하는 것만으로는 충분하지 않으며 단지 주요 문제를 연기합니다.

'/ run / systemd / system /'아래에 너무 많은 파일이 채워 져서 서비스에 의해 생성되고 특히 로그인이 많은 호스트에서 제대로 정리되지 않은 것 같습니다. 결국 얼마 후 hostnamectl이 어떤 것을보고하지 않거나 timedatectl이 서버를 쿼리하지 못했습니다 : 연결 시간 초과 및 기타 이상한 것들과 같은 이상한 동작이 나타납니다. 또한 증상은 원래보고되었습니다.

한 가지 해결 방법은 모든 'session-*. scope'파일을 삭제하고 systemd를 다시 시작하는 것입니다. 이 경우 호스트를 다시 시작할 필요가 없습니다. 이것은 아마도 systemd 및 dbus의 버그와 관련이있을 것입니다. 다음 업데이트에서는 수정 될 것입니다.


-3

systemd를 다시 설치하십시오.

apt install --reinstall systemd

이것은 많은 VM에서 나에게 문제를 해결합니다.

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.