서버 관리자

시스템 및 네트워크 관리자를위한 Q & A



1
docker-compose에서“다시 시작 : 항상”정책은 어떻게 작동합니까?
다음과 같이 PostgreSQL 및 내 응용 프로그램으로 도커 작성 파일이 있습니다. version: '3' services: postgresql: image: postgres:9.6.6 ports: - 9932:5432 expose: - "5432" environment: - POSTGRES_PASSWORD=pass restart: always volumes: - /data:/var/lib/postgresql/data myapp: image: myapp links: - postgresql depends_on: - "postgresql" restart: always ports: - "5000:5000" 문제는 restart: always컨테이너를 죽일 때 …

4
재 구축 중에 RAID5 시스템에 URE가 발생하면 모든 데이터가 손실됩니까?
더 큰 드라이브가 재 구축 중에 URE를 경험할 가능성이 높아졌다는 주장을 이해하지만, 실제 영향이 무엇인지 잘 모르겠습니다. 이 답변에 따르면 전체 재 구축이 실패하지만 모든 데이터에 액세스 할 수 없습니까? 왜 그런가요? 드라이브의 단일 섹터에서 나온 단일 URE는 최대 몇 개의 파일과 관련된 데이터에만 영향을 미칩니다. 몇 개의 파일이 약간 …
23 raid  zfs  zfsonlinux 

5
SSL & Ngnix : SSL 핸드 쉐이킹 동안 SSL 포트에서 수신 대기하는 서버에 "ssl_certificate"가 정의되어 있지 않습니다
오류없이 LE를 사용하여 인증서를 만들었으며, 트래픽을 포트 80에서 포트 443으로 리디렉션했습니다. 그러나 nginx 서버를 다시로드 할 때 웹 사이트에 액세스 할 수 없습니다. Ngnix 오류 로그에는 다음 줄이 표시됩니다. 4 no "ssl_certificate" is defined in server listening on SSL port while SSL handshaking, client: 192.168.0.104, server: 0.0.0.0:443 나는 이것이 내가 …


2
Docker : 페어 인터페이스를 추가하지 못했습니다 (작업이 지원되지 않음)
Docker를 설치 한 후 Hello World 예제를 실행하려고 할 때 오류가 발생합니다. Error response from daemon: Cannot start container 4145d0fccd96b904e4ab4413735f1129b8765429bad5be71dc8d5f4c0760666d: failed to create endpoint high_saha on network bridge: failed to add the host (veth7f6f907) <=> sandbox (veth788d9dc) pair interfaces: operation not supported (방금 데비안 서버를 Wheezy에서 Jessie로 업그레이드했습니다.) 누구 든지이 …

4
CoreOS에서 부팅시 Docker 데몬이 시작되지 않음
CoreOS (835.9.0)의 바닐라 설치가 있으며 시작할 때 도커 데몬을 시작하지 않습니다. 내가 SSH 할 때만 시작하고 예를 들어 docker ps. 시스템 부팅시 도커 데몬이 자동으로 시작되도록하려면 어떻게해야합니까? 도커 데몬이라고 말하면, 내가 ps -ef | grep docker할 때까지 프로세스가 없음을 의미합니다.docker ps
23 boot  docker  coreos 

2
특정 사용자로 Ansible 작업 실행
플레이 북을 실행하는 사용자와 다른 사용자로 특정 Ansible 작업을 실행하려고합니다. 내 .yml파일은 다음과 같습니다 --- - hosts: staging_servers tasks: - name: check user remote_user: someusername shell: whoami 이 작업을 실행하면 whoami명령 이 작업 에서 정의한 것과 다른 사용자를 반환 한다는 것을 알 수 있습니다 (정확하게는 hosts라는 파일에 정의 된 사용자를 …

2
CPU 시간과 CPU 사용량은 어떻게 동일합니까?
에 대한 위키 백과 페이지에서 CPU 시간 , 그것은 말한다 CPU 시간은 클럭 틱 또는 초 단위로 측정됩니다. 종종 CPU 시간을 CPU 용량의 백분율 (CPU 사용량이라고 함)로 측정하는 것이 유용합니다. 지속 시간을 백분율로 대체하는 방법을 이해하지 못합니다. 내가 볼 때 top,하지 않는 %CPU것을 말해 MATLAB내 코어의 2.17를 사용? PID USER …

5
공개 postgresql rds 인스턴스에 연결할 수 없습니다
단일 퍼블릭 서브넷이 있고 퍼블릭 인터넷을 통해 연결할 수있는 VPC에서 기본 테스트 PostgreSQL RDS 인스턴스를 생성했습니다. 포트 5432에 대해 열려있는 기본 보안 그룹을 사용합니다. 연결하려고하면 실패합니다. 나는 매우 간단한 것을 놓치고 있어야합니다. 그러나 나는 이것을 잃어 버렸습니다. 데이터베이스 설정은 Publicly Accessible다음 과 같습니다. 보안 그룹 설정은 다음과 같습니다 (위의 RDS …


3
Linux에서 ECC 오류에 대한 알림을 받으려면 어떻게합니까?
ECC 메모리가 장착 된 Linux 시스템이 메모리 오류를 인식하면 알림을 받으려면 어떻게합니까? 수정 가능한 오류와 수정할 수없는 오류 모두에 관심이 있습니다. 메시지가 dmesg / syslog에 작성된 경우 이미 문제가 없지만 찾을 내용을 알고 싶습니다. 추가 데몬 (하드 드라이브 용 smartmontools) 설치는 허용됩니다 Nagios / Icinga 모니터링은 또 다른 방법입니다. 모니터링 …
23 linux  ecc 

2
앱 풀 재활용 후 어떻게 asp.net mvc webapp을 예열 할 수 있습니까?
IIS 8.0에서 ASP.NET MVC webapp을 실행하고 있습니다. 요청을하기 전에 내 응용 프로그램을 예열해야합니다. 새로운 코드를 배포 할 때 애플리케이션을 자동으로 준비하는 프로세스가 이미 있습니다. 그러나 주기적으로 앱 풀 재활용 이벤트가 발생하여 앱이 예열되지 않습니다. 앱 풀 재활용 이벤트를 감지하고 스크립트 또는 코드를 실행하는 가장 좋은 방법이 있습니까?

4
ramfs와 tmpfs의 성능 차이
많은 100kb 단일 파일 (이미지)로 구성된 약 10GB의 데이터에 대해 메모리 저장 시스템을 설정해야합니다. 많은 읽기와 상당히 정기적 인 쓰기가있을 것입니다 (새 파일 추가, 일부 오래된 파일 삭제). 이제 tmpfs 가 예를 들어 df로 여유 공간 / 사용 공간을 확인할 수있는 일반 파일 시스템처럼 작동 한다는 것을 알고 있습니다. 그러나 …

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.