서버 관리자

시스템 및 네트워크 관리자를위한 Q & A

1
127.0.0.1 포트 80에 연결하지 못했습니다
nginx 서버를 실행 중입니다 (어떤 서버는 중요하지 않습니다). $ sudo netstat -tulpn | grep 80 tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 4268/nginx tcp6 0 0 :::80 :::* LISTEN 4268/nginx 그런 다음 127.0.0.1로 요청을 보냈습니다. $ curl -v 127.0.0.1 * Rebuilt URL to: 127.0.0.1/ * Hostname was NOT found in DNS …
13 linux  ubuntu  port  localhost 

1
ssh 세션 내에서 openssh-server 업그레이드
apt-get upgradessh 세션에서 발행 하고 업그레이드 할 패키지 중 하나가 openssh-server라고 가정하십시오. 업그레이드 후 새 sshd 프로세스가 다시 시작 되었습니까? 그렇다면 세션은 어떻게 유지됩니까? 그렇지 않은 경우 명시 적으로 다시 시작해야합니까, 아니면 누락 된 것이 있습니까?
13 linux  ssh  debian  apt 

2
apt-get upgrade를 실행 한 후 GRUB 오류를 피하는 방법-Ubuntu
EC2에서 우분투 14.04를 실행 중입니다. 를 실행 한 후 apt-get upgradeGRUB 부트 로더를 다시 설치하라는 화면이 나타납니다. GRUB 부트 로더는 더 이상 존재하지 않거나 어떤 이유로 고유 식별자가 변경된 디스크에 이전에 설치되었습니다. 설치된 GRUB 코어 이미지가 GRUB 모듈 및 grub.cfg와 동기화 상태를 유지하는 것이 중요합니다. GRUB이 적절한 부팅 장치에 기록되어 …

5
로드시 HP 서버 전원 공급 장치의 전력 수요를 어떻게 확인할 수 있습니까?
HP DL360 G7 1U 랙 마운트 서버를 구입했습니다. 코 로케이션 시설에 넣고 싶습니다. 문제는 내가 본 거의 모든 시설에서 제공되는 기본 금액보다 더 많은 전력을 사용하기 위해 액세스 할 수있는 전력량을 제한하거나 추가로 충전하는 것입니다. 서버의 전원 공급 장치 등급을 엄격히 말하면 한 조각에 7 암페어를 끌어 들이고 그중 2 …

2
OS X 인증 메커니즘은 실제로 무엇을합니까?
배경 VPN Single Sign On 을 달성하는 가장 좋은 방법을 결정하기 위해 OS X 로그인 프로세스를 더 잘 이해하려고합니다 . 내가 틀렸다면 저를 바로 잡으십시오. 그러나 나는 믿습니다. launchd(8)를 호출 하여에 대해 실행 을 gettyent(3)결정 합니다 .ttys(5)loginwindow.app/dev/console loginwindow.appsystem.login.console인증 데이터베이스가 다음 메커니즘을 지정하는 인증 권한 획득 시도 (기능에 대한 이해와 함께 …

3
Windows Server 2012 R2에서 356GB에서 1.32GB로 중복 제거
Server 2012 R2 스토리지 공간에서 중복 제거를 실험하고 있습니다. 지난 밤에 첫 중복 제거 최적화를 실행했으며 340GB가 줄었다는 것을 알게되어 기뻤습니다. 그러나 나는 이것이 사실 이기에는 너무 좋다는 것을 알았습니다. 해당 드라이브에서 중복 제거의 100 %가 SQL Server 백업에서 나왔습니다. 폴더에 20 배 크기의 데이터베이스 백업이 있다는 점을 고려하면 비현실적으로 …

2
왜 nginx server_name 지시문의 최대 길이가 14 자입니까?
다음 가상 호스트가 있습니다 server { server_name abc.example.com; root /var/www/test/; index index.html; } 실행 nginx -s reload하면 다음 오류가 발생합니다. nginx : [emerg]가 server_names_hash를 빌드 할 수 없습니다. server_names_hash_bucket_size를 늘려야합니다. 32 15 자 이상의 문자를 가진 server_name에 대해서도 마찬가지입니다. server_name ab.example.com(또는 15 자 미만의 이름)을 설정하면 문제가 중지됩니다. 이 문제를 …

3
ToD 서버, "시간"(NTP 아님)
간단한 작업이 있습니다 : ToD 서버 설정 ... NTP가 아닙니다. 포트 37에서 실행됩니다. inetd 또는 xinetd와 함께 제공되는 것 같습니다. 데비안 또는 CentOS에 설치해야합니다. 또는 FreeBSD (pfsense 라우터). 진행하는 방법에 대한 힌트가 있습니까? 내가 붙어있는 후 두 개의 스타터 링크 : http://www.linuxquestions.org/questions/linux-server-73/tod-server-641674/ http://en.wikipedia.org/wiki/Time_Protocol ToD 서버가 이미 실행 중인지 테스트하는 방법 …
13 time  xinetd  inetd 

4
역 DNS 조회
모두 아침, 총 100k 대의 컴퓨터에 c.150k DNS 레코드가있는 도메인을 받았습니다. DNS 레코드는 모두 동일한 도메인의 단일 정방향 조회 영역에 있으며 도움을주기 위해 역방향 조회 영역이 없습니다. 청소와 노화는 옵션이 아니기 때문에 (나의 운이 좋다!) 부실한 기록을 없애는 쉬운 방법을 찾아야한다. 가장 간단한 출발점은 1 년보다 오래된 타임 스탬프 (대략 …

4
AWS :: Route53 :: RecordSet를 생성하려고 할 때 AWS CloudFormation이 "잘못된 요청"을 반환 함
나는 이것에 손실이 있습니다. 99 %의 시간은 CloudFormation이 작업 할 수있는 일종의 디버그 메시지를 제공하는 데 능숙하지만, "잘못된 요청"으로 인해 특히 리소스가 시작하기 매우 단순 할 때 문제가 발생했습니다. 이 문제는 Ansible에서 생성 한 템플릿이므로 {{...}} 표기법을 사용하는 문제입니다. "DatabaseDNSRecord": { "Type": "AWS::Route53::RecordSet", "Properties": { "HostedZoneId": "HOSTED_ZONE_ID", "Name": "db.{{ item.env_name|lower …

1
icacls를 사용하여 디렉토리 소유권 나열
IIS_IUSRS에 디렉토리 아래의 특정 폴더에 대한 모든 권한이 있는지 확인하려고합니다. 예 나는 c : \ inetpub \ sites \를 가지고있다 c : \ inetpub \ sites \ 아래에 약 50 개의 사이트 폴더가 있습니다. 각 폴더에는 업로드, 미디어, 요청이라는 3 개의 폴더가 있습니다. BUILTIN \ IIS_IUSRS에 FullControl이 있는지 확인하고 싶습니다. …

1
sec가 타임 스탬프를 올바르게 무시하도록하는 방법
그렇게 설정된 규칙이 있습니다. /etc/sec/rules.d에서 나는 가지고 있습니다; type=SingleWithSuppress ptype=regexp pattern=(\S+) sshd\[\d+\]: PAM \d+ more authentication failures\; logname=.* uid=.* euid=.* tty=ssh ruser=.* rhost=(.*) user=(.*) desc=Login Failure: $0 action=pipe '%s ' /bin/mail -s "login failure $2 to $3@$1" team@team.com window=300 만약 이것이 syslog를 통해 온다면; Nov 21 11:24:10 servername.server.com sshd[26846]: PAM …
13 linux  logging  syslog  regex 

1
Docker는 이미지 진입 점에 인수를 추가하지 않습니다.
도커 파일이 있습니다 : ENTRYPOINT ["uwsgi", "--ini /home/docker/app/uwsgi_app.ini"] (아니요 CMD) 내가 uwsgi를 실행하면 올바르게 불평합니다. uWSGI running as root, you can use --uid/--gid/--chroot options *** WARNING: you are running uWSGI as root !!! (use the --uid flag) *** 이제 docker run다음과 같이 통해 진입 점에 인수를 추가 할 수 있다고 …
13 docker 

3
MSTSC : 원격 데스크톱의 검은 영역
Windows Server 2012 R2 에서 RDP (mstsc.exe)를 통해 Windows 8.1 을 실행 하는 Hyper-V 가상 컴퓨터에 연결하고 있습니다. VM은 내가 연결하는 동일한 컴퓨터에서 호스팅됩니다. 오늘까지 모든 것이 잘되었습니다. 오늘 VM에 연결하면 아래 스크린 샷과 같이 창이 올바르게 렌더링되지 않고 임의의 검은 사각형이 나타납니다. 이 문제는 모든 프로그램과 열려고 크기 조정하려는 …

1
HTTP 헤더를 통해 SSL 프로토콜 정보를 백엔드에 전달
푸들 취약점이 최근에 밝혀진 후 우리 팀은 SSLv3에서 계속하기로 결정했습니다. 그러나 완전한 제거하기 전에, 그들은 할 경고 일일 사용자 브라우저 사용이 SSLv3에 사용되지 않는 것으로합니다. 그래서 우리는 아이디어를 프런트 엔드 SSL 오프 로딩에서 프로토콜 (SSLv3, TLS1 등) 감지 (nginx 사용) HTTP 헤더를 통해 해당 정보 (SSL 프로토콜)를 Apache-backend로 전달하십시오. 그런 …
13 nginx  ssl  poodle 

당사 사이트를 사용함과 동시에 당사의 쿠키 정책과 개인정보 보호정책을 읽고 이해하였음을 인정하는 것으로 간주합니다.
Licensed under cc by-sa 3.0 with attribution required.